Choose style:

Author Topic: fstab problem, I can't get a partition to auto mount at startup [SOLVED]  (Read 181 times)

0 Members and 1 Guest are viewing this topic.

Offline Matthew

  • Jr. Member
  • **
  • Posts: 50
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 7, 8 and 9
I wasn't able to boot into Peppermint after adding a line to my fstab.  After much searching of the net and reading everything I could find about fstab I wasn't seeing the problem.

After I worked on some other issues and returned to fstab the problem was suddenly very clear.  I didn't put "UUID=" at the beginning of the line.  Once that was inserted everything worked as I had expected.  I deleted the original question and comments because they were irrelevant and an example of how easy it is to overlook the obvious.  When all else fails, look closer, possibly someplace else for the problem. :-[

Code: [Select]
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=7e950189-8d13-4f2c-acfa-27619173e29e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda7 during installation
UUID=dd8e32e4-46ce-46f5-a1a4-cc92d7036fb7 none            swap    sw              0       0
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
0ba1f0a9-f883-481c-9edb-ec1a962d3d41 /media/matthew/sharedstorage ext4 auto,exec,rw,async,user 0 0

With the last line changed to UUID=0ba1f0a9-f883-481c-9edb-ec1a962d3d41   /media/matthew/sharedstorage   ext4   auto,exec,rw,async,user   0   0 everything works just as it should.
« Last Edit: January 06, 2019, 10:59:21 pm by Matthew »