Choose style:

Author Topic: Error with vlc codecs  (Read 431 times)

0 Members and 2 Guests are viewing this topic.

Offline Daileon

  • nOOb
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Error with vlc codecs
« on: December 08, 2018, 01:32:09 pm »
Hello, I'm new with Linux Peppermint.
I have tried to install nvidia drivers on my desktop, and i followed this tutorial https://ubuntuforums.org/showthread.php?t=2396263, and now all works fine with the graphics, before it, my screen freezed a lot of times.
But now, i can't play any video on any media player(I tried vlc,smplayer,mplayer,banshee), when i try to see a video on vlc i receive the following message:
Codec not supported:
VLC could not decode the format "mp4v" (MPEG-4 Video)

I have uninstalled the vlc and made the instalation process again, but nothing works.
I'm very frustated.I took 3 hours until install the nvidia drivers, and now i can't play videos on my pc . :'(
Can anyone help-me, i  searched a lot on google, but i dind't find nothing.

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Error with vlc codecs
« Reply #1 on: December 08, 2018, 06:22:39 pm »
Try running these commands in the terminal:

 
Code: [Select]
sudo apt-get update

Code: [Select]
sudo apt-get dist-upgrade

If you get any updates listed on the second one, be sure to install them. If not, that's fine. After those, run this:

Code: [Select]
sudo apt-get install xubuntu-restricted-extras

After you install the packages with that last command, try playing your video again.

Offline Lord Rodin

  • Jr. Member
  • **
  • Posts: 43
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Error with vlc codecs
« Reply #2 on: December 25, 2018, 10:26:20 am »
To add the Proprietary NVIDIA GPU Drivers PPA into Peppermint and update the software sources, use the following commands in the terminal

sudo add-apt-repository ppa:graphics-drivers/ppa    push enter

sudo apt-get  update

Close terminal then go to - All - Additional Drivers and install latest nVidia drivers

after that is done now check to see if  libavcodec57 is installed - you can do that through the Synaptic Package Manager