Author Topic: Networking suddenly stopped  (Read 1859 times)

Offline samboyan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Networking suddenly stopped
« on: December 21, 2018, 05:41:39 pm »
Hi all,

I have been running peppermint for a few years now with almost no issues on an old Asus Netbook. It seems that due to some upgrades, the networking (wired and wi-fi)  is working no more. I have also noted that since jumping from version 7, firefox or chromium are extremely slow to load and keeps working slow no matter what. It gets worse if trying to watch any youtube videos.  I barely use this netbook but need to get it working for a project so I will appreciate any help you can provide me with.
Network hardware for wired  is Qualcomm Atheros AR8132 Fast Ethernet with driver :atl1c
Wi-Fi  has a Atheros AR9285 wireless network adapter with driver: ath9k

Thanks in advance for your help

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Networking suddenly stopped
« Reply #1 on: December 21, 2018, 05:46:13 pm »
Have you tried booting into the previous kernel and seeing if networking works ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline samboyan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Re: Networking suddenly stopped
« Reply #2 on: December 21, 2018, 08:00:19 pm »
Sorry, I was unable to reply from my laptop. For some reason the reply button does not show up so I'm doing it from my phone.
I tried from oldest kernel but stays the same. It detects my two networks, but says there's no internet when trying to open a web page. I checked the connection info and see that the speed sits at 1Mb/s.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Networking suddenly stopped
« Reply #3 on: December 22, 2018, 02:19:59 pm »
So network manager says you're connected to your router, but you cannot access the internet ?

Can you ping your router and get a response ?
ping -c 5 <ip.address.of.router>
eg.
Code: [Select]
ping -c 5 192.168.0.1if so, can you ping Google and get a response ?
Code: [Select]
ping -c 5 216.58.204.78?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline samboyan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Re: Networking suddenly stopped
« Reply #4 on: December 22, 2018, 07:01:32 pm »
I get ping: sendmsg: Operation not permitted

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Networking suddenly stopped
« Reply #5 on: December 23, 2018, 08:20:13 am »
do you see "yes" anywhere if you run:
Code: [Select]
rfkill list?

and if you run
Code: [Select]
nmcli connection showis anything in green text ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline samboyan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Re: Networking suddenly stopped
« Reply #6 on: December 23, 2018, 12:41:11 pm »
rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard Blocked: no


nmcli connection show

NAME                           UUID                                                                 TYPE                   DEVICE
Nexxt_58198C-2.4G   9fa24fc4-51ab-4e5c-9bf8-7bbb4c5fe989  802-11-wireless  wlp2s0
Wired connection 1    c7713d81-50c8-32be-b74f-3b23f6bb4662  802-3-ethernet   --   

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Networking suddenly stopped
« Reply #7 on: December 23, 2018, 12:58:26 pm »
Are any of those lines in GREEN text ?

And what's the output from
Code: [Select]
iwconfigand
Code: [Select]
iwlist scanyou may have to copy this output to a text file, then copy the text file to a working computer to post it here.

And just out of curiosity, I take it you've already tried restarting your router ?
« Last Edit: December 23, 2018, 01:01:18 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline samboyan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Re: Networking suddenly stopped
« Reply #8 on: December 23, 2018, 01:28:59 pm »
iwconfig

NAME                UUID                                  TYPE             DEVICE
Nexxt_58198C-2.4G   9fa24fc4-51ab-4e5c-9bf8-7bbb4c5fe989  802-11-wireless  wlp2s0
Wired connection 1  c7713d81-50c8-32be-b74f-3b23f6bb4662  802-3-ethernet   --   


enp1s0    no wireless extensions.

lo        no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:"Nexxt_58198C-2.4G" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: C0:25:67:58:19:8C   
          Bit Rate=1 Mb/s   Tx-Power=17 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-26 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:19   Missed beacon:0



iwlist scan
enp1s0    Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlp2s0    Scan completed :
          Cell 01 - Address: C0:25:67:58:19:8C
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=-33 dBm 
                    Encryption key:on
                    ESSID:"Nexxt_58198C-2.4G"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000016cbea9840
                    Extra: Last beacon: 89004ms ago
                    IE: Unknown: 00114E657878745F3538313938432D322E3447
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1AEE1117FFFF000001000000000000000000000000000000000000
                    IE: Unknown: 3D1606070600000000000000000000000000000000000000
                    IE: WPA Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 7F09000000000000000000
                    IE: Unknown: 0B05060000127A
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 4A0E14000A002C01C8001400

Router is working fine, have 2 laptops and 3 phones upstairs connected to the same router.  Reset router again but no change at all. Keeps saying that there's no internet when trying to open any website.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Networking suddenly stopped
« Reply #9 on: December 23, 2018, 02:15:59 pm »
Have you tried restarting the router ? .. give it a shot anyway.

If that doesn't makew any difference, let's try get a handle on the wireless chipset .. can you post the output from:
Code: [Select]
lsusbif it's a USB wireless adapter.

and/or:
Code: [Select]
lspci -vnn | grep -i netif it's an internal adapter
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5821
  • Karma: 1122
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Networking suddenly stopped
« Reply #10 on: December 23, 2018, 02:30:33 pm »
This thread got me thinking... I haven't started my EeePC in awhile. Turns out, the last time I booted it was 22 Apr 2017, according to the logs.

Good ol' girl. I literally had to dust her off. Then, plugged in the battery, a P9R 32bit ISO thumb drive, hit the 'on' button, danced on the 'Esc' button, and she sprang to file - WiFi and all. Hadn't even plugged the charger in yet - wanted to see if would happen without it    ;D
 
Don't know if this will help, but here's the dialog I'm getting on my WORKING EeePC 1000HD:

Spoiler (click here to view / hide)
[close]

Guess I'll leave her running for a bit, while the battery is charging...
« Last Edit: December 23, 2018, 02:45:50 pm by VinDSL »

Offline samboyan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Re: Networking suddenly stopped
« Reply #11 on: December 23, 2018, 02:44:50 pm »
lspci -vnn | grep -i net


01:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8132 Fast Ethernet [1969:1062] (rev c0)
   Subsystem: ASUSTeK Computer Inc. AR8132 Fast Ethernet [1043:838a]
02:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Networking suddenly stopped
« Reply #12 on: December 23, 2018, 03:29:49 pm »
Try this, and tell me if you get any errors:
Code: [Select]
sudo rmmod ath9kthen
Code: [Select]
sudo modprobe ath9k nohwcrypt=1did wireless come back to life ? .. and is it connecting faster than 1Mb now ?

If it didn't come back to life (or threw an error on the rmmod command), reboot (which will get you back to where you are now), and we'll have to try it another way.

If it works, let me know and we'll make that permanent.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline samboyan

  • Newly Subscribed
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3
Re: Networking suddenly stopped
« Reply #13 on: December 23, 2018, 03:40:42 pm »
Just tried it and the wi-fi shows a connection speed of 120 Mb/s but as soon as I try to open a webpage, drops to 1Mb/s and stays the same :o

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Networking suddenly stopped
« Reply #14 on: December 23, 2018, 03:48:27 pm »
Okay let's test temporarily making it permanent and rebooting. (good grief I just used "temporarily" and "permanent" in the same sentence ???)

Anyway, run:
Code: [Select]
gksudo xed /etc/modprobe.d/ath9k.confwhen a BLANK file opens, add this line to it
Code: [Select]
options ath9k nohwcrypt=1SAVE the file and close the text editor.

Now REBOOT.

How is wifi now ?

If it's still having problems, can you answer this question .. does your laptop have bluetooth as well as wireless ?
« Last Edit: December 23, 2018, 03:51:43 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec