Choose style:

Author Topic: keyboard set to UK, but reverts back to US. (SOLVED)  (Read 598 times)

0 Members and 1 Guest are viewing this topic.

Offline worldstream

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
keyboard set to UK, but reverts back to US. (SOLVED)
« on: November 15, 2018, 09:59:52 am »
This is the best distro, but I am in the UK so obviously need UK keyboard layout, but it keeps reverting back to the US-style keyboard.
There was a previous query a while back and he was asked for the output as below. Here's mine

worldstream@worldstream-All-Series ~ $ gedit ~/.config/peppermint-control-center/keyboard_layout

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(gedit:5183): GLib-GIO-CRITICAL **: 14:49:46.172: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
worldstream@worldstream-All-Series ~ $

worldstream@worldstream-All-Series ~ $ ls -l ~/.config/autostart/peppermint-control-center.desktop
-rwxr-xr-x 1 worldstream worldstream 195 Nov 15 09:24 /home/worldstream/.config/autostart/peppermint-control-center.desktop

I installed alongside Windows 10, so loath to re-install, probably mess up.

« Last Edit: November 15, 2018, 04:37:56 pm by worldstream »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: keyboard set to UK, but reverts back to US.
« Reply #1 on: November 15, 2018, 10:19:02 am »
Which version of Peppermint ?

and can you post the output from
Code: [Select]
cat /etc/default/keyboard
and the CONTENTS of
Code: [Select]
xed ~/.config/xfce4/xfconf/xfce-perchannel-xml/keyboard-layout.xml
« Last Edit: November 15, 2018, 10:27:58 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline worldstream

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: keyboard set to UK, but reverts back to US.
« Reply #2 on: November 15, 2018, 02:34:13 pm »
peppermint 9, just installed.
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

<?xml version="1.0" encoding="UTF-8"?>

<channel name="keyboard-layout" version="1.0">
  <property name="Default" type="empty">
    <property name="XkbDisable" type="bool" value="false"/>
    <property name="XkbOptions" type="empty">
      <property name="Group" type="string" value="grp:lalt_lshift_toggle"/>
    </property>
    </property>
</channel>

Thanks

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: keyboard set to UK, but reverts back to US.
« Reply #3 on: November 15, 2018, 02:59:24 pm »
Run
Code: [Select]
gksudo xed /etc/default/keyboard
make the file read
Code: [Select]
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="gb"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"
SAVE the file and exit the text editor.

Right-click the flag on your bottom panel, and select "Keyboard settings"

In the resulting dialog select the "Layouts" tab.

Make sure "Use system defaults" is UNticked.

If the "Keyboard Layouts" box only contains "English (US)", click the "+Add" button .. highlight "English (UK)", and click the "OK" button.

The Keyboard Layouts box should now list both "English (US)" AND "English (UK)" .. highlight "English (US)" and click the "Delete" button.

Click the "Close" button.

Reboot.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline worldstream

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: keyboard set to UK, but reverts back to US.
« Reply #4 on: November 15, 2018, 03:36:26 pm »
Thanks. Easy when you know how.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26082
  • Karma: 2842
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: keyboard set to UK, but reverts back to US.
« Reply #5 on: November 15, 2018, 04:21:23 pm »
No problem my friend :)

If you're happy with the solution, can you please edit the FIRST posting in this topic and change:-

Subject: keyboard set to UK, but reverts back to US. (SOLVED)

Thanks in advance :)

[EDIT]

Oh, and welcome to the forum :)
« Last Edit: November 15, 2018, 04:24:02 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec