Choose style:

Author Topic: Lenovo Ideapad S100  (Read 321 times)

0 Members and 1 Guest are viewing this topic.

Offline kagashe

  • nOOb
  • *
  • Posts: 2
  • Karma: 1
  • New Forum User
    • View Profile
    • My tryst with Linux
  • Peppermint version(s): 9
Lenovo Ideapad S100
« on: November 05, 2018, 08:47:58 am »
I am presently at Bhopal and these people have Lenovo Ideapad S100 with Windows 7. Last time I had tried antiX Linux on USB boot on this machine.

This time I found that they had to reformat the disk and reinstall Windows 7 which was not working well.

When I boot this Laptop on Windows 7 there were auto key presses of space bar for sometime. Afterwards I could use it but space bar did not produce "space". I had to use onscreen keyboard for typing "space".

I decided to try Linux on the machine and since it has only 2 GB RAM I decided to try Peppermint Linux.

I downloaded Peppermint 9 (32 bit), checked md5sum, bought SanDisk from local market and made bootable usb disk using Rufus.

This Laptop is not friendly for USB booting. On Lenovo Laptops pressing F12 is supposed to show boot menu but the Laptop does not have F12 key and suppose to work with Fn+F11 but Fn does not work on BIOS.

I pressed F2 to enter the BIOS Set up but there is no option to bring up the USB boot option above HDD boot, however, the BIOS suggests that you could disable HDD boot option by putting "x" after selecting it and pressing x key.

After disabling HDD boot I could boot from USB. The Space Bar key did not work on Live Peppermint Desktop and I had to install "onboard" to get onscreen keyboard.

Even then I decided to install Peppermint in dual boot with Windows 7.

After install and booting Peppermint Desktop once again I had to install "onboard" and use it for space bar.

After applying all updates, however, I find that the Space Bar key is working.

Mission successful.

Code: [Select]
$ inxi -Fz
System:    Host: gauri-Ideapad-S100 Kernel: 4.15.0-38-generic i686 bits: 32
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: laptop System: LENOVO product: 20109 v: Ideapad S100 serial: N/A
           Mobo: LENOVO model: N/A v: 2 serial: N/A
           BIOS: LENOVO v: 50CN12WW date: 04/22/2011
Battery    BAT1: charge: 13.7 Wh 50.0% condition: 27.3/50.1 Wh (55%)
CPU:       Dual core Intel Atom N570 (-MT-MCP-) cache: 512 KB
           clock speeds: max: 1667 MHz 1: 997 MHz 2: 997 MHz 3: 1127 MHz
           4: 1114 MHz
Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x600@59.98hz
           OpenGL: renderer: Mesa DRI Intel Pineview M x86/MMX/SSE2
           version: 1.4 Mesa 18.0.5
Audio:     Card Intel NM10/ICH7 Family High Def. Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network:   Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp1s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
           driver: ath9k
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 320.1GB (2.2% used)
           ID-1: /dev/sda model: WDC_WD3200BPVT size: 320.1GB
Partition: ID-1: / size: 92G used: 6.7G (8%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 177 Uptime: 1:03 Memory: 796.5/2001.1MB
           Client: Shell (bash) inxi: 2.3.56

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1571
  • Karma: 219
  • Peppermint - Void - NetBSD
    • View Profile
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: Lenovo Ideapad S100
« Reply #1 on: November 05, 2018, 09:28:31 am »
Great stuff  :D
And welcome to the family  ;)

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23524
  • Karma: 2615
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Lenovo Ideapad S100
« Reply #2 on: November 05, 2018, 10:59:08 am »
Well that's a pleasant win then :)

Welcome to the forum kagashe.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4809
  • Karma: 1011
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Lenovo Ideapad S100
« Reply #3 on: November 06, 2018, 12:35:33 am »
Hi kagashe, welcome to the Peppermint Forum   :).  Good detective work, well done ;).  It might be worth checking the Lenovo website.   There may be a BIOS update for your model of laptop.  If there is, it could bring in some additional features that make life easier for you  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline kagashe

  • nOOb
  • *
  • Posts: 2
  • Karma: 1
  • New Forum User
    • View Profile
    • My tryst with Linux
  • Peppermint version(s): 9
Re: Lenovo Ideapad S100
« Reply #4 on: November 06, 2018, 04:47:29 am »
Hi kagashe, welcome to the Peppermint Forum   :).  Good detective work, well done ;).  It might be worth checking the Lenovo website.   There may be a BIOS update for your model of laptop.  If there is, it could bring in some additional features that make life easier for you  ;).
I have checked. There is no update to this version of BIOS.

I had installed 32 bit Peppermint because Windows 7 was 32 bit but I found that CPU is capable of 64 bit so i have replaced the installation with 64 bit.

Code: [Select]
$ inxi -Fz
System:    Host: gauri-Ideapad-S100 Kernel: 4.15.0-38-generic x86_64 bits: 64
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: laptop System: LENOVO product: 20109 v: Ideapad S100 serial: N/A
           Mobo: LENOVO model: N/A v: 2 serial: N/A
           BIOS: LENOVO v: 50CN12WW date: 04/22/2011
Battery    BAT1: charge: 18.0 Wh 66.0% condition: 27.3/50.1 Wh (55%)
CPU:       Dual core Intel Atom N570 (-MT-MCP-) cache: 512 KB
           clock speeds: max: 1667 MHz 1: 997 MHz 2: 997 MHz 3: 1172 MHz
           4: 1235 MHz
Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x600@59.98hz
           OpenGL: renderer: Mesa DRI Intel Pineview M version: 1.4 Mesa 18.0.5
Audio:     Card Intel NM10/ICH7 Family High Def. Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-38-generic
Network:   Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp1s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
           driver: ath9k
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 320.1GB (2.3% used)
           ID-1: /dev/sda model: WDC_WD3200BPVT size: 320.1GB
Partition: ID-1: / size: 92G used: 6.8G (8%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 181 Uptime: 5 min Memory: 793.9/1982.6MB
           Client: Shell (bash) inxi: 2.3.56
« Last Edit: November 06, 2018, 04:50:05 am by kagashe »