Choose style:

Author Topic: Very weak wifi signal reception. (SOLVED)  (Read 1041 times)

0 Members and 1 Guest are viewing this topic.

Offline kukel21

  • nOOb
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Very weak wifi signal reception. (SOLVED)
« on: October 28, 2018, 09:03:17 am »
Hi guys im having problems with my wifi reception signal its very weak like i cant get away for 2  meters from my router and if i get too far away the connection drops. i tried to use lubuntu 18.10 and wifi works great but its slow for me so im hoping for your support again so i can fully use pm 9 thanks.

Code: [Select]
 sudo lspci -vnn | grep -i net
[sudo] password for michael:
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:81c1]
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
    Subsystem: Hewlett-Packard Company RTL810xE PCI Express Fast Ethernet controller [103c:81e1]

Code: [Select]
 sudo lshw -C network
[sudo] password for michael:
  *-network                 
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: 3c:a0:67:79:0c:87
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.15.0-38-generic firmware=N/A ip=192.168.254.111 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:18 ioport:2000(size=256) memory:91200000-91203fff
  *-network
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 07
       serial: 30:e1:71:80:73:b9
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:116 ioport:1000(size=256) memory:91100000-91100fff memory:91000000-91003fff
Code: [Select]
iwconfig
lo        no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:"Engineer's Playground" 
          Mode:Managed  Frequency:2.457 GHz  Access Point: 84:16:F9:EC:47:08   
          Bit Rate=7.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on
          Link Quality=38/70  Signal level=-72 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:598   Missed beacon:0

enp3s0    no wireless extensions.
Code: [Select]
sudo iwlist scan
[sudo] password for michael:
lo        Interface doesn't support scanning.

wlp2s0    Scan completed :
          Cell 01 - Address: 84:16:F9:EC:47:08
                    Channel:10
                    Frequency:2.457 GHz (Channel 10)
                    Quality=38/70  Signal level=-72 dBm 
                    Encryption key:on
                    ESSID:"Engineer's Playground"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000122edb2cf58
                    Extra: Last beacon: 72ms ago
                    IE: Unknown: 0015456E67696E656572277320506C617967726F756E64
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 03010A
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1116FF00000001000000000000000000000000000000000000
                    IE: Unknown: 3D160A000600000000000000000000000000000000000000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 4A0E14000A002C01C800140005001900
                    IE: Unknown: 7F0400000001
                    IE: Unknown: DD07000C4300000000
                    IE: Unknown: 0706504800010D10

enp3s0    Interface doesn't support scanning.
Code: [Select]
rfkill list
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
Some codes that may help thanks alot again :D
« Last Edit: October 29, 2018, 08:19:50 am by kukel21 »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24925
  • Karma: 2753
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very weak wifi signal reception.
« Reply #1 on: October 28, 2018, 09:14:21 am »
Does running
Code: [Select]
sudo xed /etc/modprobe.d/rtl8723be.conf
then when a BLANK file opens, adding the line:-
Code: [Select]
options rtl8723be ant_sel=2
SAVING the file, then REBOOTING
help ?

If not, you can UNDO this by running:
Code: [Select]
cd /etc/modprobe.d
then
Code: [Select]
sudo rm -v rtl8723be.conf
then rebooting
« Last Edit: October 28, 2018, 09:26:35 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kukel21

  • nOOb
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Very weak wifi signal reception.
« Reply #2 on: October 28, 2018, 09:41:33 am »
i tried this but its still the same unfortunately  :( so i reverted back using your instructions thanks.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24925
  • Karma: 2753
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very weak wifi signal reception.
« Reply #3 on: October 28, 2018, 09:42:27 am »
I'd changed the instructions .. did you follow them as they are NOW ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kukel21

  • nOOb
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Very weak wifi signal reception.
« Reply #4 on: October 28, 2018, 09:45:12 am »
Yes the edited one with the putting the line  options rtl8723be ant_sel=2 etc.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24925
  • Karma: 2753
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very weak wifi signal reception.
« Reply #5 on: October 28, 2018, 09:51:45 am »
okay try ant_sel=1

as in....

Does running
Code: [Select]
sudo xed /etc/modprobe.d/rtl8723be.conf
then when a BLANK file opens, adding the line:-
Code: [Select]
options rtl8723be ant_sel=1
SAVING the file, then REBOOTING  <-- it's important that you reboot here
help ?

If not, you can UNDO this by running:
Code: [Select]
cd /etc/modprobe.d
then
Code: [Select]
sudo rm -v rtl8723be.conf
then rebooting
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24925
  • Karma: 2753
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very weak wifi signal reception.
« Reply #6 on: October 28, 2018, 09:58:10 am »
First try the posting just above this one (with ant_sel=1) and If that makes no difference, try this...

Does running
Code: [Select]
sudo xed /etc/modprobe.d/rtl8723be.conf
then when a BLANK file opens, adding the line:-
Code: [Select]
options rtl8723be swenc=1 fwlps=0 ips=0
SAVING the file, then REBOOTING  <-- it's important that you reboot here
help ?

If not, you can UNDO this by running:
Code: [Select]
cd /etc/modprobe.d
then
Code: [Select]
sudo rm -v rtl8723be.conf
then rebooting
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kukel21

  • nOOb
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Very weak wifi signal reception.
« Reply #7 on: October 28, 2018, 11:13:06 am »
tried all of the above twice and check if anything worked but still the same sadly

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24925
  • Karma: 2753
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very weak wifi signal reception.
« Reply #8 on: October 28, 2018, 04:40:02 pm »
Okay try this .. with an ethernet connection open a terminal and run these commands in sequence:
Code: [Select]
sudo apt-get install git libelf-dev
then
Code: [Select]
git clone https://github.com/lwfinger/rtlwifi_new.git
then
Code: [Select]
cd rtlwifi_new
then
Code: [Select]
make
then
Code: [Select]
sudo make install
then
Code: [Select]
sudo modprobe -rv rtl8723be
then
Code: [Select]
sudo modprobe -v rtl8723be ant_sel=2
then
Code: [Select]
sudo ip link set wlp2s0 up
did wireless spring to life, and work properly ?

If so you can make this permanent by running
Code: [Select]
sudo xed /etc/modprobe.d/rtl8723be.conf
and making the file read:-
Code: [Select]
options rtl8723be ant_sel=2
and saving the file.



Original instruction source:
https://connectwww.com/how-to-solve-realtek-rtl8723be-weak-wifi-signal-problem-in-ubuntu/4625/
(but modified)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kukel21

  • nOOb
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Very weak wifi signal reception.
« Reply #9 on: October 29, 2018, 01:10:29 am »
hi i tried this one but still the same results and the make command is not found so i installed by typing apt install not like make install. but sadly im still having the same problem ;(

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24925
  • Karma: 2753
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very weak wifi signal reception.
« Reply #10 on: October 29, 2018, 06:11:27 am »
Try
Code: [Select]
sudo apt-get install build-essential
then try those commands again.

did it build this time ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kukel21

  • nOOb
  • *
  • Posts: 10
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Very weak wifi signal reception.
« Reply #11 on: October 29, 2018, 08:19:19 am »
YAY! finally works  :D thanks alot the commands work after i got those essentials and now i got reception even im down stairs. Thanks alot Admin for your time and effort :D now ill have time to enjoy and learn about linux using peppermint. Thanks Alot again :D p.s ill mark this one as solved  ;)

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24925
  • Karma: 2753
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very weak wifi signal reception. (SOLVED)
« Reply #12 on: October 29, 2018, 08:26:20 am »
Terrific news my mate .. and thanks for marking the topic solved :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec