Choose style:

Author Topic: Preventing LXPanel from starting at boot  (Read 2147 times)

0 Members and 1 Guest are viewing this topic.

Offline xanadu

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 6
Preventing LXPanel from starting at boot
« on: August 01, 2014, 08:39:45 pm »
I want to replace the LXPanels at the bottom of the screen with Cairo-Dock. I did this in Peppermint 3, but I forgot how I did it. What would be the best way to do this? A simple
Code: [Select]
killall lxpanel
works, of course, but I would like to prevent LXPanel from loading at boot. Which config file would I edit to do this?
« Last Edit: August 01, 2014, 08:43:07 pm by xanadu »

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2175
  • Karma: 590
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Preventing LXPanel from starting at boot
« Reply #1 on: August 02, 2014, 03:39:24 am »
I'm not exactly sure how to stop it from starting when you log into your session other than removing lxpanel completely. If you are sure that you will not want to go back to lxpanel then open a terminal and enter:
Code: [Select]
sudo apt purge lxpanel
But if you want to keep it, but just prevent it from starting then wait for a better suggestion.  8)
Regards,
--Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline MNFrozenfish

  • Jr. Member
  • **
  • Posts: 96
  • Karma: 16
  • Smile! - It makes people wonder what you're up to.
    • View Profile
  • Peppermint version(s): Peppermint 9 Respin-64 bit / P10
Re: Preventing LXPanel from starting at boot
« Reply #2 on: August 04, 2014, 08:49:15 am »
Another option would be to move the panel to the top/left/right of your display, and set it to auto minimize.

Offline rjm65

  • Veteran
  • ****
  • Posts: 1010
  • Karma: 310
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Preventing LXPanel from starting at boot
« Reply #3 on: August 04, 2014, 09:04:07 am »
Easiest way I can think of is to right click on the lxpanel and choose remove panel, it will ask for confirmation, but it will delete it...
This is how I remove the top panel in PCLinuxOS which is also running LXDE, it should be the same for bottom panel as well...  good luck  ;)
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline xanadu

  • Jr. Member
  • **
  • Posts: 66
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 6
Re: Preventing LXPanel from starting at boot
« Reply #4 on: August 11, 2014, 04:08:37 pm »
I'm not exactly sure how to stop it from starting when you log into your session other than removing lxpanel completely. If you are sure that you will not want to go back to lxpanel then open a terminal and enter:
Code: [Select]
sudo apt purge lxpanel
But if you want to keep it, but just prevent it from starting then wait for a better suggestion.  8)
Regards,
--Slim

Does anyone know if purging lxpanel will cause any problems? I'm hesitant to do that unless I know for sure it won't break anything else. I'd prefer to just disabling it from starting in the first place, if anyone knows how I might do that.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26454
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Preventing LXPanel from starting at boot
« Reply #5 on: August 11, 2014, 04:40:06 pm »
Whilst a simulated run of purge suggests it's safe to do, I'd still advise against it.

Here's how to stop lxpanel being autostarted correctly....

Go to
menu > Prefefrences > Default aplications for LXSession

choose the "Core applications" tab

Change:-

Panel: lxpanel

to

Panel:

and close the "LXSession configuration" window.

Log off/on.



This way if you ever need to restart the panel, you can hit Ctrl+Alt+T top open a terminal and run:
Code: [Select]
nohup lxpanel -p Peppermint
and the panel willl fire right up :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec