Choose style:

Author Topic: Failed too mount (Live USB)  (Read 1075 times)

0 Members and 1 Guest are viewing this topic.

Offline Vu3L5TmD

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Failed too mount (Live USB)
« on: September 16, 2018, 05:12:06 am »
Hello, I am trying to run an USB live session of peppermint 9, however when I boot into the USB an error message occurs:

Code: [Select]
BusyBox v1.27.2 (Ubuntu 1:1.27.2-2ubuntu3) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(iniramfs) mount: mounting /dev/loop0) on //filesystem.squashfs failed: Invalid argument
Can not mount /dev/loop0 (/cdrpm/casper/filesystem.squashfs) on //filesystem.sqauashfs


I have an Asus E402S, with a dual-core N3060, 2 GB RAM no graphic card besides the built in some kind of Intel. (It is currently running lubuntu)
I first suspected that it might be the image, so ran an md5sum check and it turned out alright.
I tried creating the bootable media with "Startup disk creator", the built in image writer in Linux mint and "unetbootin".
Tried as EXT4/EXT3, Fat32 (Have not done it for NTFS as that is windows only right?)

Tried to run an
Code: [Select]
sudo fsck /dev/sda1
returned
Code: [Select]
fsck from util-linux 2.31.1

I am kind of lost, could anyone point me in the right direction?

Online murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1922
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Failed too mount (Live USB)
« Reply #1 on: September 16, 2018, 08:45:52 am »
the built in image writer in Linux mint

That should normally work but some computers are fussy about what they will boot from. Do you have a Windows machine that you could try using Rufus on?

Offline Vu3L5TmD

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Failed too mount (Live USB)
« Reply #2 on: September 16, 2018, 10:41:37 am »
the built in image writer in Linux mint

That should normally work but some computers are fussy about what they will boot from. Do you have a Windows machine that you could try using Rufus on?


Not at home, but I have a windows machine at my work.
Do you think it is how the image is written on the USB stick?
I tried using the same USB with Lubutu on and it ran perfectly.

Also when the grub menu shows, it is kinda snowy, like a television if that helps you visualize it better :)

Online murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1922
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Failed too mount (Live USB)
« Reply #3 on: September 16, 2018, 11:22:05 am »
It could be. Try getting Rufus on Windows, it has a pretty good success rate of making things bootable.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25098
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Failed too mount (Live USB)
« Reply #4 on: September 17, 2018, 06:02:56 pm »
Is that output a direct copy/paste ?

I'm asking because:-

Quote
(iniramfs) mount: mounting /dev/loop0) on //filesystem.squashfs failed: Invalid argument
Can not mount /dev/loop0 (/cdrpm/casper/filesystem.squashfs) on //filesystem.sqauashfs

Was "cdrpm" a typo ?

If it was a typo, which version of Mint were you using to create the LiveUSB ?

I don't think "Startup Disk Creator" has worked properly for some time now .. but recent versions of Mint (17/18/19) should have "USB Image Writer" installed by default .. that should work.

Oh, and the USB stick should be formatted as FAT32.
« Last Edit: September 17, 2018, 06:05:16 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Vu3L5TmD

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Failed too mount (Live USB)
« Reply #5 on: September 18, 2018, 11:31:28 am »
It could be. Try getting Rufus on Windows, it has a pretty good success rate of making things bootable.

I've now tried using Rufus, but the same result.

Is that output a direct copy/paste ?

I'm asking because:-

Quote
(iniramfs) mount: mounting /dev/loop0) on //filesystem.squashfs failed: Invalid argument
Can not mount /dev/loop0 (/cdrpm/casper/filesystem.squashfs) on //filesystem.sqauashfs

Was "cdrpm" a typo ?

If it was a typo, which version of Mint were you using to create the LiveUSB ?

I don't think "Startup Disk Creator" has worked properly for some time now .. but recent versions of Mint (17/18/19) should have "USB Image Writer" installed by default .. that should work.

Oh, and the USB stick should be formatted as FAT32.

Yes it was a typo, I did not know you could copy paste the error code :)
It was meant to say cdrom.

I was using mint 19 Cinnamon, and I did format the USB as FAT32 before I used image writer :)

I don't know if it is a BIO's setting?
Fast boot is disable
Secure boot is disabled
CSM (Don't know if it effects anything) Is disabled.

Even with Rufus the results ends up being the same.

Online murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1922
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Failed too mount (Live USB)
« Reply #6 on: September 18, 2018, 12:33:02 pm »
http://www.lxle.net/forums/discussion/276/live-usb-key-doesnt-boot/p1

Someone over there ^ had this problem and they managed to solve it by hybridizing the ISO. It shouldn't need to be done but I dunno...  :-\

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25098
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Failed too mount (Live USB)
« Reply #7 on: September 18, 2018, 12:47:24 pm »
Startup Disk Creator, and USB Image Writer are 2 different apps.

Use USB Image Writer.

And make sure you have the 64bit version of Peppermint 9, not the 32bit version.

and have you tried a different USB stick ?

Is this going to be the only OS installed ? .. or are you planning on dual booting ?
« Last Edit: September 18, 2018, 12:52:10 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Vu3L5TmD

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Failed too mount (Live USB)
« Reply #8 on: September 18, 2018, 02:13:47 pm »
http://www.lxle.net/forums/discussion/276/live-usb-key-doesnt-boot/p1

Someone over there ^ had this problem and they managed to solve it by hybridizing the ISO. It shouldn't need to be done but I dunno...  :-\

Did it but now the USB does not show up as a bootable media, think it might be something with partition, I'll look into it tomorrow.

Startup Disk Creator, and USB Image Writer are 2 different apps.

Use USB Image Writer.

And make sure you have the 64bit version of Peppermint 9, not the 32bit version.

and have you tried a different USB stick?

Is this going to be the only OS installed ? .. or are you planning on dual booting?

I tried another USB, formatted it with USB stick Formatter (Linux mint FAT32) and used USB image writer.
But same result.

It is supposed to be the only OS installed since the laptop I am trying to run it on have 32 GB of disk space.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25098
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Failed too mount (Live USB)
« Reply #9 on: September 18, 2018, 05:31:30 pm »
In that case, have you tried enabling CSM and booting in legacy BIOS mode ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Vu3L5TmD

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Failed too mount (Live USB)
« Reply #10 on: September 19, 2018, 01:33:43 pm »
In that case, have you tried enabling CSM and booting in legacy BIOS mode ?

Tried it, sadly it was the same result

Edit:
So the USB works on my other laptop Asus GL752vw, I am able to boot into a live session.
However, nothing changed on my Asus E402SA, made sure E402SA and GL752vw had the same boot menu options
« Last Edit: September 19, 2018, 03:06:42 pm by Vu3L5TmD »

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1811
  • Karma: 250
    • View Profile
Re: Failed too mount (Live USB)
« Reply #11 on: September 19, 2018, 03:44:14 pm »
You said you have Lubuntu running. Is it based on Ubuntu 18.04 or 16.04?
Does any other distro boot? If so which?
Have you tried another usb?
Just say NO to flatpak and snap!!

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25098
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Failed too mount (Live USB)
« Reply #12 on: September 19, 2018, 05:13:08 pm »
After answering pin's question above .. let's try creating a UEFI **ONLY** USB stick.

In your current Lubuntu, open Gparted and make sure the USB stick is formatted as a single FAT32 partition


If under the "Flags" column, "Boot" is not listed, right-click on the partition and select "Manage Flags" .. then put a tick in the "boot" checkbox


and click "Close"

Your single FAT32 partition should now list "Boot" in the "Flags" column

.

Exit Gparted.

Okay, now navigate to wherever you downloaded the Peppermint 9 64bit ISO image .. right-click on the Peppermint-9-20180621-amd64.iso file and select:-

Open With > Archive Manager

Highlight all the files/folders in the image below


and extract them to your USB stick.

At the end of the extraction you'll probably see this warning


You can safely ignore that, and click the "Close" button.

Okay now try booting from that USB stick in UEFI mode.

Did it boot ?



In short, if you extract the 64bit Peppermint ISO into a FAT32 USB stick that has the boot flag set, it should be possible to boot it on a UEFI system .. it will NOT however be bootable in Legacy BIOS mode (as GRUB wasn't written to the MBR).
« Last Edit: September 19, 2018, 05:18:11 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Vu3L5TmD

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Failed too mount (Live USB)
« Reply #13 on: September 20, 2018, 11:19:29 am »
You said you have Lubuntu running. Is it based on Ubuntu 18.04 or 16.04?
Does any other distro boot? If so which?
Have you tried another usb?

It is based on 18.04 LTS
Yes, Xubuntu, Lubuntu they work fine
I have tried two other USB keys with the same result, the one I am using is working fine on my other PC

After answering pin's question above .. let's try creating a UEFI **ONLY** USB stick.

In your current Lubuntu, open Gparted and make sure the USB stick is formatted as a single FAT32 partition

If under the "Flags" column, "Boot" is not listed, right-click on the partition and select "Manage Flags" .. then put a tick in the "boot" checkbox

and click "Close"

Your single FAT32 partition should now list "Boot" in the "Flags" column

Exit Gparted.

Okay, now navigate to wherever you downloaded the Peppermint 9 64bit ISO image .. right-click on the Peppermint-9-20180621-amd64.iso file and select:-

Open With > Archive Manager

Highlight all the files/folders in the image below

and extract them to your USB stick.

At the end of the extraction you'll probably see this warning


You can safely ignore that, and click the "Close" button.

Okay now try booting from that USB stick in UEFI mode.

Did it boot ?



In short, if you extract the 64bit Peppermint ISO into a FAT32 USB stick that has the boot flag set, it should be possible to boot it on a UEFI system .. it will NOT however be bootable in Legacy BIOS mode (as GRUB wasn't written to the MBR).

It continues with the same error :/

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1811
  • Karma: 250
    • View Profile
Re: Failed too mount (Live USB)
« Reply #14 on: September 20, 2018, 03:51:08 pm »
This is very strange  :-\ there should be no difference  :-\
Just say NO to flatpak and snap!!