Choose style:

Author Topic: Slow boot time (SOLVED)  (Read 1209 times)

0 Members and 1 Guest are viewing this topic.

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1885
  • Karma: 410
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Slow boot time (SOLVED)
« on: August 21, 2018, 01:06:35 am »
Hi guys
I have a HP Compaq 6710b laptop which I've had a while running PM8,

Here's the stats
Spoiler (click here to view / hide)
Code: [Select]
graeme@graemes-laptop ~ $ inxi -F
System:    Host: graemes-laptop Kernel: 4.15.0-32-generic x86_64 bits: 64
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: laptop System: Hewlett-Packard product: HP Compaq 6710b (GR679ET#ABU) v: F.10 serial: N/A
           Mobo: Hewlett-Packard model: 30C0 v: KBC Version 71.2E serial: N/A
           BIOS: Hewlett-Packard v: 68DDU Ver. F.10 date: 01/11/2008
Battery    C23B: charge: 45.3 Wh 89.5% condition: 50.6/50.6 Wh (100%)
CPU:       Dual core Intel Core2 Duo T7250 (-MCP-) cache: 2048 KB
           clock speeds: max: 2001 MHz 1: 1307 MHz 2: 1275 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.00hz
           OpenGL: renderer: Mesa DRI Intel 965GM version: 2.1 Mesa 18.0.5
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-32-generic
Network:   Card: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlp16s0 state: up mac: 00:1f:3c:07:65:e7
Drives:    HDD Total Size: 240.1GB (3.0% used)
           ID-1: /dev/sda model: WDC_WDS240G2G0A size: 240.1GB
Partition: ID-1: / size: 220G used: 6.8G (4%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 39.0C mobo: 27.5C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 155 Uptime: 18 min Memory: 548.3/1481.5MB
           Client: Shell (bash) inxi: 2.3.56
[close]


 it runs perfectly except boot time is painfully slow, it never bothered me before because it only had a 40gb HDD (spinning disc) which I intended upgrading to an SSD anyway in the belief it would possibly sort out the slow boot issue, I finally got a brand new 240gb WD Green SSD and installed PM9, almost right away I realised it wasn't going to be any better as even the live disc took an age to boot up, and even after installation the boot time is 3 mins to login screen and a further minute to fully log in to a usable desktop. 

systemd-analyse blame shows some interesting figures, if I'm reading it right the problem lies with network manager, Plymouth & Lightdm,

Spoiler (click here to view / hide)
Code: [Select]
graeme@graemes-laptop ~ $ systemd-analyze blame
    1min 30.039s nmbd.service
         31.855s plymouth-start.service
         31.651s plymouth-read-write.service
         31.538s plymouth-quit-wait.service
         31.537s lightdm.service
          7.331s NetworkManager-wait-online.service
          6.656s apparmor.service
          2.038s hddtemp.service
          1.918s dev-sda1.device
          1.315s mintsystem.service
          1.103s networkd-dispatcher.service
           787ms udisks2.service
           561ms NetworkManager.service
           542ms ModemManager.service
           481ms accounts-daemon.service
           478ms grub-common.service
           455ms keyboard-setup.service
           454ms snapd.service
           400ms systemd-udev-trigger.service
           371ms systemd-journald.service
           343ms systemd-rfkill.service
           318ms swapfile.swap
           311ms avahi-daemon.service
           265ms wpa_supplicant.service
           262ms bluetooth.service
[close]

Plymouth certainly has a problem as it only flashes up momentarily during the boot process, once booted up it's fine, I'm not normally one to care all that much about boot time but 4 mins from switch on to workable desktop is a bit long for a fresh install on a brand new SSD I think .

Any help or advice would be much appreciated

Many thanks

Graeme
 
« Last Edit: August 22, 2018, 01:39:54 am by emegra »
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1823
  • Karma: 250
    • View Profile
Re: Slow boot time
« Reply #1 on: August 21, 2018, 01:32:54 am »
Hi emegra.
Don't know if you want to mess with it, or if that would even help. But, the BIOS on that machine is outdated.
That said, I've managed to brick a hp a month or so ago attempting a BIOS update outside Windows, so a word of warning there  ;)
Hp provides BIOS updates as .exe only.

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1885
  • Karma: 410
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: Slow boot time
« Reply #2 on: August 21, 2018, 01:43:49 am »
Hi pin

Thanks for your reply
I don't think I fancy going down the bios update route knowing me as well as I do if it can be screwed up I'll screw it up  :(

I think I'd probably opt to live with the slow boot time rather than risk bricking the machine completely

I did wonder if this was a bios issue but hoped there was maybe some setting I could change in the bios but I'm not sure what to look for

Thanks for your help pin :)


Graeme

If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1752
  • Karma: 466
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Slow boot time
« Reply #3 on: August 21, 2018, 02:58:12 am »
Hi emegra,

I doubt that these things (below) will bring a great improvement, but every little bit will help! Looking at your "blame" list I would suggest removing apparmor. If you do not need it, you can also disable the following two services

Code: [Select]
nmbd.serviceNetworkManager-wait-online.service

using the following commands in a terminal:

Code: [Select]
sudo systemctl disable nmbd.service
sudo systemdctl disable NetworkManager-wait-online.service

Perhaps even trying what VinDSL and I use: wicd in place of the current network-manager.

For some info about working with systemd services see this article.

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1885
  • Karma: 410
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: Slow boot time
« Reply #4 on: August 21, 2018, 03:38:41 am »
Hi Slim
Thanks for your suggestions, I'll give them a try this evening, nothing ventured

Plymouth seems to be a big problem as well and if it helped in any significant way I wouldn't have a problem removing it from the boot process if that was possible, it's not really serving much of a purpose at the moment anyway

Many thanks

Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Slow boot time
« Reply #5 on: August 21, 2018, 03:54:50 am »
During the boot process, one of the jobs of Plymouth is to write out the error logs if something is causing a problem.  Deleting Plymouth would not help and would most probably cause more problems.  You need to find out by checking the error logs what is causing the problem that is keeping Plymouth busy.

A good place to start is to check

Code: [Select]
sudo dmesg | grep -i "error\|warn\|fail"
......to infinity and beyond..............

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5246
  • Karma: 940
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Slow boot time
« Reply #6 on: August 21, 2018, 06:56:19 am »
During the boot process, one of the jobs of Plymouth is to write out the error logs if something is causing a problem.

Speaking of which, I do a lot of experimenting and my error logs grow quite large.

Clearing out the 'systemd journal' occasionally seems to have a positive effect on boot times as well as recovering wasted disk space.

I do this manually in CLI using:

Code: [Select]
sudo journalctl --vacuum-time=1d
Just saying ...

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1885
  • Karma: 410
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: Slow boot time
« Reply #7 on: August 21, 2018, 04:39:34 pm »


Ok I tried all the suggestions Slim put forward but to avail boot time remains exactly the same, what I don't understand according to my most recent blame list nmbd is no longer showing which should be shaving 1min 30secs of my boot time  neither is apparmor which should be shaving 6 secs off the time, clearly I'm not understanding this  ???

latest blame list
Spoiler (click here to view / hide)
Code: [Select]
graeme@graemes-laptop ~ $ systemd-analyze blame
         31.811s plymouth-start.service
         31.620s plymouth-read-write.service
         31.454s plymouth-quit-wait.service
         31.450s lightdm.service
          1.656s dev-sda1.device
          1.417s mintsystem.service
          1.230s wicd.service
          1.167s networkd-dispatcher.service
           770ms smbd.service
           706ms udisks2.service
           584ms ModemManager.service
           482ms NetworkManager.service
           427ms keyboard-setup.service
           379ms systemd-journald.service
           362ms swapfile.swap
           356ms accounts-daemon.service
           351ms systemd-udev-trigger.service
           345ms grub-common.service
           337ms bluetooth.service
           323ms avahi-daemon.service
           289ms systemd-rfkill.service
           284ms lm-sensors.service
           269ms systemd-logind.service
           269ms systemd-journal-flush.service
           245ms iio-sensor-proxy.service
[close]

Tonys suggestion of checking the logs for what's keeping Plymouth busy isn't really making a lot of sense to me but here's the log if anyone cares to have a look

Spoiler (click here to view / hide)
Code: [Select]
graeme@graemes-laptop ~ $ sudo dmesg | grep -i "error\|warn\|fail"
[sudo] password for graeme:
[    0.136180] acpi PNP0A08:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
[    1.544177] tpm tpm0: [Hardware Error]: Adjusting reported timeouts: A 750->750000us B 2000->2000000us C 750->750000us D 750->750000us
[    2.505925] RAS: Correctable Errors collector initialized.
[    3.196059] tg3 0000:18:00.0: VPD access failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update
[   13.280087] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   13.384108] WARNING: CPU: 0 PID: 121 at /build/linux-wuhukg/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[   23.520046] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   33.760046] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:plane A] flip_done timed out
[   34.934981] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   35.969806] ACPI Warning: SystemIO range 0x0000000000001028-0x000000000000102F conflicts with OpRegion 0x0000000000001000-0x0000000000001042 (\_SB.C003.C004.C0D2) (20170831/utaddress-247)
[   35.969819] ACPI Warning: SystemIO range 0x0000000000001130-0x000000000000113F conflicts with OpRegion 0x0000000000001100-0x000000000000113B (\_SB.C003.C004.C0E4) (20170831/utaddress-247)
[   35.969827] ACPI Warning: SystemIO range 0x0000000000001100-0x000000000000112F conflicts with OpRegion 0x0000000000001100-0x000000000000113B (\_SB.C003.C004.C0E4) (20170831/utaddress-247)
[   45.536072] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   45.640129] WARNING: CPU: 0 PID: 299 at /build/linux-wuhukg/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[   55.776061] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:34:pipe A] flip_done timed out
[   66.016073] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:plane A] flip_done timed out
[   78.816170] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[   78.920262] WARNING: CPU: 1 PID: 299 at /build/linux-wuhukg/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[   89.056151] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[   99.296161] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  109.792161] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  109.892973] WARNING: CPU: 1 PID: 687 at /build/linux-wuhukg/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  120.032163] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  130.272166] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  140.512166] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  140.616269] WARNING: CPU: 1 PID: 687 at /build/linux-wuhukg/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  150.752159] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  160.992178] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  191.968138] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  192.072415] WARNING: CPU: 1 PID: 687 at /build/linux-wuhukg/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  202.208089] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  212.448105] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
[  222.944133] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  223.044968] WARNING: CPU: 0 PID: 687 at /build/linux-wuhukg/linux-4.15.0/drivers/gpu/drm/drm_vblank.c:1073 drm_wait_one_vblank+0x181/0x190 [drm]
[  233.184132] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  237.857612] xdg-desktop-por[1105]: segfault at 8 ip 000056380b2557c8 sp 00007ffe3dd28680 error 4 in xdg-desktop-portal[56380b242000+7c000]
[  243.424130] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out
graeme@graemes-laptop ~ $
[close]


Many thanks



Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Slow boot time
« Reply #8 on: August 21, 2018, 05:44:14 pm »
Quote
what I don't understand according to my most recent blame list nmbd is no longer showing which should be shaving 1min 30secs of my boot time

That's not necessarily true .. these processes/services are started in parallel, NOT in sequence.

Can you provide us with your entire dmesg output... run:
Code: [Select]
dmesg > ~/Desktop/dmesg.txt
you'll now find a file called dmesg.txt on your desktop .. host this somewhere like
http://www.tinyupload.com/
and provide us with a link to it.
« Last Edit: August 21, 2018, 05:47:56 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Slow boot time
« Reply #9 on: August 21, 2018, 05:56:16 pm »
This sample line from the error report indicates that the problem is with the intel graphics driver.

Code: [Select]
[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out

Please try:

Code: [Select]
sudo xed /etc/default/grub
Look for the line that contains quiet splash then add the kernel boot parameter: video=SVIDEO-1:d
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"
save and exit then
Code: [Select]
sudo update-grub
(If you have more than one OS, please update grub at the primary one i.e. first one in the grub menu)
then reboot and see if it boots any quicker.
......to infinity and beyond..............

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Slow boot time
« Reply #10 on: August 21, 2018, 09:39:10 pm »
Nicely spotted Tony :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1885
  • Karma: 410
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: Slow boot time
« Reply #11 on: August 22, 2018, 01:38:13 am »
Tony !

yOU IZ DA MAN :)

Switch on to Login Screen:       39 secs
Login Screen to Desktop:           4 secs


Blame list
Spoiler (click here to view / hide)
Code: [Select]
graeme@graemes-laptop ~ $ systemd-analyze blame
          1.698s dev-sda1.device
          1.600s plymouth-start.service
          1.452s plymouth-read-write.service
          1.129s mintsystem.service
           932ms wicd.service
           908ms plymouth-quit-wait.service
           896ms lightdm.service
           888ms networkd-dispatcher.service
           604ms udisks2.service
           530ms smbd.service
           499ms systemd-journal-flush.service
           493ms NetworkManager.service
           421ms keyboard-setup.service
           378ms systemd-journald.service
           327ms systemd-udev-trigger.service
           324ms accounts-daemon.service
           323ms swapfile.swap
           306ms iio-sensor-proxy.service
           287ms systemd-logind.service
           279ms wpa_supplicant.service
           251ms ModemManager.service
           236ms systemd-rfkill.service
           216ms lm-sensors.service
           202ms upower.service
           199ms systemd-modules-load.service
[close]




Big thanks guys for your help


Graeme
« Last Edit: August 22, 2018, 01:45:52 am by emegra »
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline BearVader

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
Re: Slow boot time (SOLVED)
« Reply #12 on: February 23, 2019, 09:28:37 am »
had same trouble with a HP 6720s...

sorted it out with that code change.... super thanks from me too!!!!!!