Choose style:

Author Topic: SAMBA problem again in Peppermint 9 (SOLVED)  (Read 590 times)

0 Members and 1 Guest are viewing this topic.

Offline dipper

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8, 9
SAMBA problem again in Peppermint 9 (SOLVED)
« on: August 10, 2018, 07:24:22 am »
I have an old PC with "windows xp" on a local network with "windows 7". There was a Peppermint 8 on it for several weeks.
After updating with the regular updating tools, I caught the "kernell panic" that could not be solved. So I decided to install version 9. However, Nemo does not display any shared windows resources, although the previous version Peppermint was all great. smbtree shows every shares. Also access from "windows-pc" to peppermint shares passes. Output of
Code: [Select]
testparm
:
Spoiler (click here to view / hide)
[global]
   dns proxy = No
   log file = /var/log/samba/log.%m
   map to guest = Bad User
   max log size = 1000
   obey pam restrictions = Yes
   pam password change = Yes
   panic action = /usr/share/samba/panic-action %d
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   passwd program = /usr/bin/passwd %u
   server role = standalone server
   server string = %h server (Samba, Ubuntu)
   syslog = 0
   unix password sync = Yes
   usershare allow guests = Yes
   idmap config * : backend = tdb


[printers]
   browseable = No
   comment = All Printers
   create mask = 0700
   path = /var/spool/samba
   printable = Yes


[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers


[Public]
   comment = test share
   guest ok = Yes
   path = /home/peppermint/Public
[close]

Is there any solution, what can be the problem?
« Last Edit: August 13, 2018, 10:57:54 pm by PCNetSpec, Reason: tagged as solved »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2863
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: SAMBA problem again in Peppermint 9
« Reply #1 on: August 10, 2018, 09:18:12 am »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dipper

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8, 9
Re: SAMBA problem again in Peppermint 9
« Reply #2 on: August 13, 2018, 10:00:18 am »
See this tutorial by TonyBronze
https://forum.peppermintos.com/index.php/topic,7086.0.html
Thanks for the advice, everything seems to have worked out.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26468
  • Karma: 2863
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: SAMBA problem again in Peppermint 9
« Reply #3 on: August 13, 2018, 10:57:21 pm »
Great news .. chalk up another one for Tony's tutorial :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec