Choose style:

Author Topic: NetworkManager on Panel  (Read 1438 times)

0 Members and 2 Guests are viewing this topic.

Offline fra

  • nOOb
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: NetworkManager on Panel
« Reply #15 on: October 10, 2018, 09:31:41 am »
Hello,

Thanks for your help, but the command you gave me leads to an error message saying:
Gtk-Warning: can't set a parent on widget which has a parent
and
Gtk-Critical: gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed

What should I try next?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25094
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: NetworkManager on Panel
« Reply #16 on: October 10, 2018, 11:35:12 am »
Ignoring those warnings, did the networkmanager icon appear in your panel ?

and what is that blue icon above the notification area in your panel screenshot ?
« Last Edit: October 10, 2018, 11:49:26 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1922
  • Karma: 335
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: NetworkManager on Panel
« Reply #17 on: October 10, 2018, 01:41:38 pm »
It looks like a workspace switcher with only one workspace.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25094
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: NetworkManager on Panel
« Reply #18 on: October 10, 2018, 05:43:07 pm »
What's the output from:
Code: [Select]
cat /etc/network/interfaces
and does the nm-applet display in a Guest session ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline fra

  • nOOb
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: NetworkManager on Panel
« Reply #19 on: October 11, 2018, 06:33:48 am »
Hi,
no, ignoring those commands does not put the network manager on the panel.
You are right the blue thing is a workspace switcher with only one workspace.
The output for the given command is:
Code: [Select]
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback 
Yes, the nm-applet appears in a guest session.
« Last Edit: October 11, 2018, 06:43:06 am by fra »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25094
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: NetworkManager on Panel
« Reply #20 on: October 11, 2018, 11:57:29 am »
Do you fancy creating a second (admin) user account and seeing if it works there ?

If so, let me know the output from
Code: [Select]
groups
and I'll post instructions.



And just out of interest, did you keep a home partition/folder from a previous install ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline fra

  • nOOb
  • *
  • Posts: 17
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: NetworkManager on Panel
« Reply #21 on: July 02, 2019, 08:10:19 am »
I created another admin account and gave my previous account the permission to connect to wireless networks (which it didn't have by default).  Now typing
Code: [Select]
dbus-launch nm-applet
lets it appear on the panel, but only until I close the terminal.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25094
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: NetworkManager on Panel
« Reply #22 on: July 02, 2019, 10:14:50 am »
What's the output from:
Code: [Select]
ls /etc/xdg/autostart
and
Code: [Select]
ls ~/.config/autostart
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec