Choose style:

Author Topic: Very slow boot time for Latitude D630  (Read 2167 times)

0 Members and 1 Guest are viewing this topic.

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Very slow boot time for Latitude D630
« Reply #15 on: July 29, 2018, 07:09:05 am »
Not finished yet :)

Samba was also slowing things down.  Maybe an idea to disable it.  There are other ways to file share if you need to such as Nitro Share.

To disable it copy/paste:

Code: [Select]
sudo apt remove samba
......to infinity and beyond..............

Offline kloos

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 5
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 (64 bit)
Re: Very slow boot time for Latitude D630
« Reply #16 on: July 29, 2018, 07:16:47 am »
 8)
That's done.  We're down to 1 minute 12 seconds.  I only use the laptop for libre office, email and browsing so dont need filesharing.  Files are saved on dropbox.

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1636
  • Karma: 229
    • View Profile
Re: Very slow boot time for Latitude D630
« Reply #17 on: July 29, 2018, 07:34:39 am »
You could try removing apparmor and btrfs to see if you gain a few more seconds.

Skickat från min SM-G900F via Tapatalk
« Last Edit: July 29, 2018, 07:59:08 am by pin »

Offline kloos

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 5
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 (64 bit)
Re: Very slow boot time for Latitude D630
« Reply #18 on: July 29, 2018, 11:04:29 am »
Thanks Pin, I removed those but it didn't make any difference to log in time.

5 seconds for the bios
44 seconds of black screen before you see the logo
57 seconds to to the log in screen
1 min 14 to backdrop.


Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Very slow boot time for Latitude D630
« Reply #19 on: July 29, 2018, 11:16:09 am »
Can you post output from
Code: [Select]
systemd-analyze blame
to see if there is anything else we can blame :)
......to infinity and beyond..............

Offline kloos

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 5
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 (64 bit)
Re: Very slow boot time for Latitude D630
« Reply #20 on: July 29, 2018, 01:18:54 pm »
Can you post output from
Code: [Select]
systemd-analyze blame
to see if there is anything else we can blame :)

Thin pickings now, but loving all of your help.

         14.518s dev-sda1.device
         13.446s systemd-journal-flush.service
         12.906s keyboard-setup.service
         10.588s systemd-tmpfiles-setup-dev.service
          7.470s systemd-sysctl.service
          6.439s NetworkManager-wait-online.service
          4.166s plymouth-start.service
          3.294s systemd-modules-load.service
          3.108s NetworkManager.service
          2.939s networkd-dispatcher.service
          2.813s mintsystem.service
          2.148s ModemManager.service
          1.766s udisks2.service
          1.399s accounts-daemon.service
          1.231s wpa_supplicant.service
          1.129s run-rpc_pipefs.mount
          1.118s lightdm.service
          1.113s plymouth-quit-wait.service
          1.108s systemd-rfkill.service

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Very slow boot time for Latitude D630
« Reply #21 on: July 29, 2018, 04:09:20 pm »
Doesn't look like there is much more to do there.  Looks about the same as my D631

Only other thing that may help is tweak the set up

Press F2 when you boot.

Under system, Boot Sequence make sure the Internal HDD is at the top of the list
Under Onboard Devices Integrated NIC change to just "enabled"
Internal Modem turn off
Parallel Port turn off (this would only apply if you have a dock)
Under Video Set the video memory size to 128mb
Security - nothing to do there
After security I have performance but it refers to the AMD CPU.  If you have a performance option, make sure it is turned on
Under Wireless, If you are not using internal cellular, then turn it off

I think thats all
......to infinity and beyond..............

Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 4801
  • Karma: 880
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Very slow boot time for Latitude D630
« Reply #22 on: July 29, 2018, 07:49:37 pm »
Great ideas, all the way around. Only thing I can add is that I personally find the following command ...

Code: [Select]
systemd-analyze critical-chain
... more useful than ...

Code: [Select]
systemd-analyze blame

It's a little more 'in your face' so perps standout.  Here's a (positive) example - my 14 year-old, 32-bit Dell 'doorstop' test box.

Peppermint 9 boots in 14 seconds, which is amazing in itself, but in the pic you can see everything is fairly congruous.

I'm used to seeing Network Manager and other pigs taking 30 seconds or more to load in other vers.

Must say, I didn't need to tweak Peppermint 9  much to get low boot times. Hats-off to Mark.  8)

Nothing left to do here ...



Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 4801
  • Karma: 880
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Very slow boot time for Latitude D630
« Reply #23 on: July 29, 2018, 07:54:25 pm »
BTW, for the sake of conversation, here's my stupid-simple GRUB config ...

Code: [Select]
# If you change this file, run 'update-grub' afterwards to update
GRUB_DEFAULT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline quiet splash"
GRUB_CMDLINE_LINUX="libata.force=noncq"

That's it - the whole enchilada. LoL  :D

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Very slow boot time for Latitude D630
« Reply #24 on: July 29, 2018, 08:15:28 pm »
The problem here was more to do with the bug that effects some Intel graphic chips caused by the 14.15.0 kernel.  Fortunately disabling S-Video using the grub command cured the main problem but I would be hesitant to make any further changes to the grub config in this case as it could reintroduce the bug again. 
......to infinity and beyond..............

Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 4801
  • Karma: 880
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Very slow boot time for Latitude D630
« Reply #25 on: July 29, 2018, 08:24:29 pm »
Agreed.

Good job!  ;)





Offline kloos

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 5
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 (64 bit)
Re: Very slow boot time for Latitude D630
« Reply #26 on: July 30, 2018, 04:25:17 am »
Great ideas, all the way around. Only thing I can add is that I personally find the following command ...

Code: [Select]
systemd-analyze critical-chain
... more useful than ...

Code: [Select]
systemd-analyze blame

It's a little more 'in your face' so perps standout.  Here's a (positive) example - my 14 year-old, 32-bit Dell 'doorstop' test box.


So I ran  critical-chain and this is what I got...

graphical.target @30.917s
└─multi-user.target @30.917s
  └─hddtemp.service @30.873s +43ms
    └─network-online.target @30.870s
      └─NetworkManager-wait-online.service @24.458s +6.411s
        └─NetworkManager.service @20.796s +3.659s
          └─dbus.service @20.426s
            └─basic.target @20.400s
              └─systemd-ask-password-plymouth.path @20.400s
                └─plymouth-start.service @16.113s +4.196s
                  └─keyboard-setup.service @2.726s +13.384s
                    └─systemd-journald.socket @2.646s
                      └─system.slice @2.646s
                        └─-.slice @2.640s

Very interesting to see what is causing the boot time.  Not that I have a clue how to resolve it.  That's where you guys come in.  Fantastic stuff!

Martin

Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 4801
  • Karma: 880
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Very slow boot time for Latitude D630
« Reply #27 on: July 30, 2018, 10:58:02 am »
Interesting.

On face value,it looks like systemd is waiting for your drive(s) to be up and visible to the system.

Never run across this situation before, so not sure how to progress.

Might try booting into 'init' and seeing what happens.

Offline kloos

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 5
  • Fairly new at Linux
    • View Profile
  • Peppermint version(s): Peppermint 9 (64 bit)
Re: Very slow boot time for Latitude D630
« Reply #28 on: July 30, 2018, 11:12:03 am »
I would, but i don't know what init is?

Just noted, yay me I'm now a Jnr Member of the forum and not a Newbe anymore  8) :D

Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 4801
  • Karma: 880
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Very slow boot time for Latitude D630
« Reply #29 on: July 30, 2018, 11:29:13 am »
Okay, forget that. You're getting there ...  ;D

I did a quick search on your spinner and evidently that series had probs that required a firmware update: https://goo.gl/yXbsMQ

If it was me, I'd start looking for a SSD. I prefer HGST Travelstar SSDs for my portables - I think Mark likes WB Blacks.

For a long time, my Dell D630 ATG (with a cheap SanDisk SSD) was the fastest machine in the house.

Anyway, I'm guessing this will be the upshot. If not, at least you'll have a very fast lappy, once it boots.

Or, maybe somebody will have a better idea. Who knows? It's a crap shoot at this point IMO.
« Last Edit: July 30, 2018, 11:32:46 am by VinDSL, Reason: Addendum »