Choose style:

Author Topic: Capture Problems n OBS-Studio with AMD graphics [SOLVED]  (Read 325 times)

0 Members and 1 Guest are viewing this topic.

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« on: July 26, 2018, 01:06:15 pm »
Hi

I am trying to use OBS to capture my ETS2 game play as per usual - however

In Pep 9 with the AMD card I am getting a black window when I tell it to look at the ETS window.

This does not happen in windows 10 and does not happen in Fedora 28

Both Pep and Fedora are using

Code: [Select]
zebedee@i7-peppermint ~ $ glxinfo | grep "OpenGL version"
OpenGL version string: 3.0 Mesa 18.0.5
zebedee@i7-peppermint ~ $

Regards Zeb...

ps I have tried all things I can find in google search

This happens on the 4.15.0-29 kernel and the 4.17.9-041709 kernel
« Last Edit: July 27, 2018, 06:41:33 am by zebedeeboss »
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Capture Problems n OBS-Studio with AMD graphics
« Reply #1 on: July 26, 2018, 01:15:21 pm »
Have you tried selecting use alpha less texture format (Mesa Workaround)  Scroll to the bottom of the window properties to find it.
......to infinity and beyond..............

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Re: Capture Problems n OBS-Studio with AMD graphics
« Reply #2 on: July 26, 2018, 01:16:55 pm »
Hiya TB,

Yeah and all I get is a washed out pink affect  :(

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Capture Problems n OBS-Studio with AMD graphics
« Reply #3 on: July 26, 2018, 01:36:40 pm »
Hiya Zeb

Bit of a long shot but are you using a Peppermint Theme?  If so can you try using Adwaita-dark to eliminate that it may be a problem.

Reason being, Kdenlive doesn't like the Peppermint themes and gives black boxes for the save as /open file boxes but works fine with Adwaita-Dark.

Tony
......to infinity and beyond..............

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Re: Capture Problems n OBS-Studio with AMD graphics
« Reply #4 on: July 26, 2018, 01:43:44 pm »
Hiya TonyB

Great shout but no luck unfortunately.  A friend of mine DasGeek, also has a Vega 64 card and he says he does not get the issue with xubuntu.  Very odd

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Re: Capture Problems n OBS-Studio with AMD graphics
« Reply #5 on: July 26, 2018, 02:00:48 pm »
When I try and install OBS from the OBS PPA I am getting the following error

Quote
E: /var/cache/apt/archives/obs-studio_21.1.0-0obsproject1~bionic_amd64.deb: trying to overwrite '/usr/share/obs/libobs/bicubic_scale.effect', which is also in package libobs0:amd64 21.0.2+dfsg1-1

and then this
Quote
(Reading database ... 384009 files and directories currently installed.)
Preparing to unpack .../obs-studio_21.1.0-0obsproject1~bionic_amd64.deb ...
Unpacking obs-studio (21.1.0-0obsproject1~bionic) over (21.0.2+dfsg1-1) ...
dpkg: error processing archive /var/cache/apt/archives/obs-studio_21.1.0-0obsproject1~bionic_amd64.deb (--unpack):
 trying to overwrite '/usr/share/obs/libobs/bicubic_scale.effect', which is also in package libobs0:amd64 21.0.2+dfsg1-1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/obs-studio_21.1.0-0obsproject1~bionic_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...

Regards Zeb...

Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Capture Problems n OBS-Studio with AMD graphics
« Reply #6 on: July 26, 2018, 03:15:47 pm »
I got the same error with the PPA and ended up using the snap pack
......to infinity and beyond..............

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #7 on: July 26, 2018, 04:22:13 pm »
Thanks TonyB,

The Snap pack of OBS-Studio worked

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22254
  • Karma: 2485
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #8 on: July 26, 2018, 07:27:15 pm »
If you want the PPA version, try running:
Code: [Select]
sudo apt-get remove --purge libobs0
then installing the version from the PPA
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #9 on: July 27, 2018, 05:46:30 am »
Thanks

I will keep those instructions to hand if the Snap version gives me grief.

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline TonyBronze

  • Trusted User
  • Member
  • *****
  • Posts: 160
  • Karma: 34
  • Peppermintaholic
    • View Profile
  • Peppermint version(s): 8 & 9
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #10 on: July 27, 2018, 05:55:58 am »
I have tried it and it worked to install the PPA version.
......to infinity and beyond..............

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #11 on: July 27, 2018, 06:32:05 am »
Oh this just gets better and better - Sigh!!!

Now the snap OBS does not recognise my video driver...



Gong to try the ppa version again.

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Online zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2569
  • Karma: 501
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): Peppermint 9 x64
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #12 on: July 27, 2018, 06:40:59 am »
Happy to report all working AOK now on the OBS PPA

Regards Zeb...
« Last Edit: July 27, 2018, 07:14:38 am by zebedeeboss »
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P9 x64 Desktop - i7-6700K @ 4.00GHz - 32Gb RAM - NVIDIA GTX1070ti 8Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 3440 x 1440
x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22254
  • Karma: 2485
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #13 on: July 27, 2018, 07:06:06 am »
Nice :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline stevesveryown

  • Member
  • ***
  • Posts: 141
  • Karma: 28
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 8 & Peppermint 9
Re: Capture Problems n OBS-Studio with AMD graphics [SOLVED]
« Reply #14 on: July 27, 2018, 09:40:47 am »
Zeb,

I don't think this was exclusive to amd. I was getting it on my desktop with nvidia graphics. I was trying to record gimp 2.10, snap version, in obs. I had closed obs and opened again and I was able to find the gimp window. When I do set for desktop recording I do get black screen.

Sent from my SM-T813 using Tapatalk

Thanks!

Steve

My main machine:
AMD FX-8320 Piledriver (Vishera) 3.5GHz (4.1GHz turbo) (Eight Core) AM3+ 8MB Cache
AMD Black Edition Copper HeatPipe EXTRA QUIET fan
NVIDIA GeForce GT 730
ASUS SABERTOOTH 990FX AM3+, SLI & Cross Fire, SATA3, USB 3.0
16GB (2x8GB) PC17000 DDR3 2133 Dual Channel (high