Choose style:

Author Topic: lxpanel not loading all System Tray.  (Read 4961 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
lxpanel not loading all System Tray.
« on: July 26, 2014, 07:09:54 am »
Hi all, how is everyone?  I'm having some issues with lxpanel not loading the System Tray and Task Bar (Window List), (the internet connection icon, power icon and Skype).  When I check in Panel Settings they are listed as active.  I have tried several methods to correct the issue with varying success.  First I navigate to
Code: [Select]
~/.config/lxpanel/Peppermint/panels
I swap out the current panel file for its backup and reboot.  Below is the file contents:
Spoiler (click here to view / hide)
# lxpanel <profile> config file. Manually editing is not recommended.
# Use preference dialog in lxpanel to adjust config when you can.

Global {
    edge=top
    allign=left
    margin=0
    widthtype=percent
    width=100
    height=26
    transparent=0
    tintcolor=#9d1b1f
    alpha=235
    autohide=0
    heightwhenhidden=2
    setdocktype=1
    setpartialstrut=1
    usefontcolor=1
    fontsize=15
    fontcolor=#ebebeb
    usefontsize=1
    background=1
    backgroundfile=/usr/share/peppermint/images/panel-red-background.png
    iconsize=24
    loglevel=2
}

Plugin {
    type = menu
    Config {
        image=/usr/share/peppermint/images/menu-four.png
        tintcolor=#000000
        system {
        }
        separator {
        }
        item {
            name=Google-Chrome
            image=google-chrome
            action=google-chrome
        }
        item {
            name=QupZilla
            image=qupzilla
            action=qupzilla
        }
        item {
            name=Synaptic
            image=synaptic
            action=gksu synaptic
        }
        item {
            name=File Manager
            image=system-file-manager
            action=pcmanfm
        }
        item {
            name=Stellarium
            image=stellarium
            action=stellarium
        }
        item {
            image=system-run
            command=run
        }
        separator {
        }
        item {
            image=gnome-logout
            command=logout
        }
    }
}

Plugin {
    type = launchbar
    Config {
        Button {
            id=/usr/share/applications/terminator.desktop
        }
        Button {
            id=/home/andy/.local/share/applications/gmail.desktop
        }
        Button {
            id=/home/andy/.local/share/applications/googlecalendar.desktop
        }
        Button {
            id=/usr/share/applications/netflix-desktop.desktop
        }
        Button {
            id=/home/andy/.local/share/applications/bbcnews.desktop
        }
        Button {
            id=/usr/share/applications/deja-dup-preferences.desktop
        }
    }
}

Plugin {
    type = space
    Config {
        Size=4
    }
}

Plugin {
    type = taskbar
    expand=1
    Config {
        tooltips=1
        IconsOnly=1
        ShowAllDesks=0
        UseMouseWheel=1
        UseUrgencyHint=0
        FlatButton=0
        MaxTaskWidth=150
        spacing=1
        GroupedTasks=0
    }
}

Plugin {
    type = pager
}

Plugin {
    type = launchbar
    Config {
        Button {
            id=/home/andy/.local/share/applications/open.desktop
        }
    }
}

Plugin {
    type = tray
}

Plugin {
    type = volumealsa
}

Plugin {
    type = dclock
    Config {
        ClockFmt=%R
        TooltipFmt=%A %x
        BoldFont=0
        IconOnly=0
        CenterText=0
    }
}

Plugin {
    type = launchbar
    Config {
        Button {
            id=peppermint-logout.desktop
        }
    }
}
[close]

It sometimes holds on reboot.  It fails when I logout.  Also, it maybe worth mentioning as it may be related.  I use the panel image by default Everytime I start, reboot or logout, the application desktop pager is rendered  to the same colour as the rest of the bar.  I have to go into the Panel Settings>Apperance click on and off, Image.  The desktop pager now is black.  If I restart the panel:
Code: [Select]
lxpanelctl restart
The CPU immediately starts running continuously at 45 to 50%.  Any help would be much appreciated as it is really annoying.  Many thanks  :(.
« Last Edit: July 26, 2014, 07:51:40 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: lxpanel not loading all System Tray.
« Reply #1 on: July 26, 2014, 09:26:07 am »
I've noticed the same thing with "lxpanelctl restart" making the CPU load go mad .. so I've been using
Code: [Select]
killall lxpanel
nohup lxpanel -p Peppermint &
or combined into one
Code: [Select]
killall lxpanel && nohup lxpanel -p Peppermint &

Have you tried swapping the entire contents of
~/.config/lxpanel/Peppermint
with a copy of those from:
/usr/share/lxpanel/profile/Peppermint

[EDIT]

Oddly after killing/restarting lxpanel in the above way "lxpanelctl restart" also works from that point forward without raising the CPU load .. I think this is something to do with the way lxsession-default-apps is autostarting lxpanel in 14.04
« Last Edit: July 26, 2014, 10:58:59 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5722
  • Karma: 1077
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: lxpanel not loading all System Tray.
« Reply #2 on: July 26, 2014, 01:39:56 pm »
Probably totally unrelated, but when I read the "45 to 50%" CPU usage comment, above...

I've always had a problem running LXDE on this desktop box (the one I'm typing on, right now).

At some point, 'lxsession' decides to go crazy.  I never have been able to figure out WHY.  The only thing that fixes this problem is a fresh install.  And, then, it's only a matter of days or weeks, and the problem crops up again.

I'm NOT saying this is your problem.  However, the way to test it is to stop (not kill) 'lxsession'.  Of course, this will make it impossible to log off, reboot, shutdown, et cetera.  To do any of these things, you will need to start 'lxsession' again.

Anyway, to rule out that possibility, you might want to stop/pause 'lxsession' temporarily, and see if the excessive CPU usage goes away.

Just saying...

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: lxpanel not loading all System Tray.
« Reply #3 on: July 26, 2014, 02:15:19 pm »
Thanks guys for the replies.  I've tried Mark's suggestion and it appears to work after I changed the ownership of the copied /usr/share/lxpanel/profile/Peppermint.  The solution to the lxpanel's excessive CPU usage seems to work.  A new file, "nohup.out has been created in: ~/.config/lxpanel/Peppermint/panels.  The Desktop Pager is still not loading properly though.  I still have to go into Panel Setting>Appearance and toggle on/off, Image for it to be visible. 

VinDSL, I'll try your idea too.  It might give me a better idea of what's going on. One question, how do I stop  the lxsession?  Thanks again  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5722
  • Karma: 1077
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: lxpanel not loading all System Tray.
« Reply #4 on: July 26, 2014, 02:40:23 pm »
VinDSL, I'll try your idea too.  It might give me a better idea of what's going on. One question, how do I stop  the lxsession?  Thanks again  ;).

I'm lazy as the next guy -- I simply use Menu ->> System Tools ->> Task Manager

Locate 'lxsession' -- highlight it -- right-click -- and choose Stop

Sorry if this is hard to see (I like dark themes)...


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: lxpanel not loading all System Tray.
« Reply #5 on: July 26, 2014, 03:01:51 pm »
Just as an experiment, go to

menu > Preferences > Peppermint Control Center

and adjust the "Number of workspaces"

Did that make any difference ?



And what happens if you don't use a panel background image .. just set a colour and fade it to transparent .. is the pager being displayed "underneath" as it were ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: lxpanel not loading all System Tray.
« Reply #6 on: July 26, 2014, 03:47:01 pm »
Just as an experiment, go to

menu > Preferences > Peppermint Control Center

and adjust the "Number of workspaces"

Did that make any difference ?



And what happens if you don't use a panel background image .. just set a colour and fade it to transparent .. is the pager being displayed "underneath" as it were ?

Changing the number of, "workspaces" made no difference.  Swapping to a solid colour with transparency works fine.  It appears lxpanel doesn't like loading panel images. 
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: lxpanel not loading all System Tray.
« Reply #7 on: July 26, 2014, 03:50:04 pm »
It's working fine for me.

Can you upload the panel image you're using and provide a link

And state where you are loading the image from .. its path on your system.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: lxpanel not loading all System Tray.
« Reply #8 on: July 26, 2014, 04:19:28 pm »
Hi Mark, here is the link to the image I'm using: https://www.dropbox.com/s/qopp7tsyzwikcq4/panel-red-background.png.  The path to the image is:
Code: [Select]
/usr/share/peppermint/images/panel-red-background.png

Thanks again  ;).
« Last Edit: July 26, 2014, 04:21:41 pm by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: lxpanel not loading all System Tray.
« Reply #9 on: July 26, 2014, 04:50:23 pm »
Nope .. that works perfectly for me too  :-\

Have you tried reinstalling:
Code: [Select]
sudo apt-get install --reinstall lxpanel lxpanel-indicator-applet-plugin
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: lxpanel not loading all System Tray.
« Reply #10 on: July 26, 2014, 05:11:14 pm »
Nope .. that works perfectly for me too  :-\

Have you tried reinstalling:
Code: [Select]
sudo apt-get install --reinstall lxpanel lxpanel-indicator-applet-plugin

That's weird, I just ran the re-install, unfortunately it made no difference.  Its not a problem, I was just curious to know if it was solvable or just lxpanel being flaky  ;D.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: lxpanel not loading all System Tray.
« Reply #11 on: July 26, 2014, 05:13:28 pm »
does it work after restarting the panel as I mentioned above ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: lxpanel not loading all System Tray.
« Reply #12 on: July 26, 2014, 05:27:08 pm »
Yes, when I enter the code:
Code: [Select]
killall lxpanel && nohup lxpanel -p Peppermint &
the panel restarts and renders correctly. 

Edit: I take that back.  When I click on the Desktop Pager all the inactive desktops become the background colour.  It is strange, this is only happening when the panel background is an image file  :-\.
« Last Edit: July 26, 2014, 05:31:46 pm by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: lxpanel not loading all System Tray.
« Reply #13 on: July 26, 2014, 06:04:13 pm »
Heh .. just thought of a workaround :)

make the panel transparent, then paint it onto your wallpaper  :o
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rjm65

  • Veteran
  • ****
  • Posts: 1011
  • Karma: 310
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: lxpanel not loading all System Tray.
« Reply #14 on: July 26, 2014, 06:20:38 pm »
that is a good workaround Mark. LOL    :D
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40