Choose style:

Author Topic: Can't set higher resolution after install but works in Live mode  (Read 215 times)

0 Members and 1 Guest are viewing this topic.

Offline some1

  • nOOb
  • *
  • Posts: 10
  • Karma: 1
  • New Forum User
    • View Profile
Peppermint 9.

Here is system info taken from Live session.

Code: [Select]
peppermint@peppermint ~ $ inxi -Fz
System:    Host: peppermint Kernel: 4.15.0-23-generic x86_64 bits: 64 Desktop: N/A
           Distro: Peppermint Nine
Machine:   Device: desktop Mobo: Foxconn model: 661 7MJ serial: N/A
           BIOS: Phoenix v: 6.00 PG date: 03/10/2006
CPU:       Single core Intel Celeron (-UP-) cache: 256 KB speed: 2666 MHz (max)
Graphics:  Card: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
           Display Server: x11 (X.Org 1.19.6 )
           drivers: vesa (unloaded: modesetting,fbdev)
           Resolution: 1280x1024@0.00hz
           OpenGL: renderer: llvmpipe (LLVM 6.0, 128 bits)
           version: 3.3 Mesa 18.0.0-rc5
Audio:     Card-1 USB Audio Device driver: USB-Audio
           Card-2 C-Media driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.15.0-23-generic
Network:   Card: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet
           driver: sis900
           IF: enp0s4 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 160.0GB (0.6% used)
           ID-1: /dev/sda model: HITACHI_HTS54251 size: 160.0GB
Partition: ID-1: / size: 981M used: 35M (4%) fs: overlay dev: N/A
           ID-2: swap-1 size: 1.03GB used: 0.00GB (0%) fs: swap dev: /dev/zram0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 133 Uptime: 3 min Memory: 346.9/1961.4MB
           Client: Shell (bash) inxi: 2.3.56
peppermint@peppermint ~ $ 

And here after installation, fully updated.

Code: [Select]
pc@pc-desktop ~ $ inxi -Fz
System:    Host: pc-desktop Kernel: 4.15.0-23-generic x86_64
           bits: 64
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: desktop Mobo: Foxconn model: 661 7MJ serial: N/A
           BIOS: Phoenix v: 6.00 PG date: 03/10/2006
CPU:       Single core Intel Celeron (-UP-) cache: 256 KB
           speed: 2666 MHz (max)
Graphics:  Card: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
           Display Server: x11 (X.Org 1.19.6 )
           drivers: fbdev (unloaded: modesetting,vesa)
           Resolution: 640x480@73.00hz
           OpenGL: renderer: llvmpipe (LLVM 6.0, 128 bits)
           version: 3.3 Mesa 18.0.0-rc5
Audio:     Card-1 USB Audio Device driver: USB-Audio
           Card-2 C-Media driver: USB Audio
           Sound: ALSA v: k4.15.0-23-generic
Network:   Card: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet
           driver: sis900
           IF: enp0s4 state: up speed: 100 Mbps duplex: full
           mac: <filter>
Drives:    HDD Total Size: 160.0GB (4.1% used)
           ID-1: /dev/sda model: HITACHI_HTS54251 size: 160.0GB
Partition: ID-1: / size: 146G used: 6.2G (5%)
           fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 43.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 151 Uptime: 7 min Memory: 506.4/1961.4MB
           Client: Shell (bash) inxi: 2.3.56
pc@pc-desktop ~ $

There is no other option besides 640x480 in Monitor setting.

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1279
  • Karma: 163
  • Peppermint - Void - NetBSD
    • View Profile
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: Can't set higher resolution after install but works in Live mode
« Reply #1 on: July 17, 2018, 02:39:50 am »
If you look closer to those outputs, you will see that in the live session you are using the vesa video driver. While on the installed system the one in use is fbdev.
You have a SiS900 PCI graphics card, so the correct driver should be video-sis.
I'm not in front of my laptop right now, but you could check if the xserver-xorg-video-sis driver is available in the repos?

Code: [Select]
apt-cache search xserver-xorg-video-sis

Or search for it using Synaptic package manager.

You could, alternativly, force the system to use the vesa driver instead of the fbdev.

A third alternative, would be to play with xrandr to see if you can get it to diplay the resolution you want. See, https://wiki.archlinux.org/index.php/xrandr

Regards

Skickat från min SM-G900F via Tapatalk
« Last Edit: July 17, 2018, 04:24:55 am by pin »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22254
  • Karma: 2485
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: Can't set higher resolution after install but works in Live mode
« Reply #2 on: July 17, 2018, 11:17:52 am »
Or maybe try adding vesa=791 as a kernel boot parameter and see if that makes a difference ?

Let us know if you don't know how to do that.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Can't set higher resolution after install but works in Live mode
« Reply #3 on: July 26, 2018, 04:52:10 pm »
I had a post with the solution that would set resolution to 1024x768 I think but cannot find my post.

It is here in the forums *somewhere*.

I think I had to edit Grub but can't remember.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22254
  • Karma: 2485
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec