Choose style:

Author Topic: Disable the pinch zoom gesture on the touchpad of a laptop  (Read 576 times)

0 Members and 1 Guest are viewing this topic.

Offline Fritz74

  • Jr. Member
  • **
  • Posts: 97
  • Karma: 8
  • m, 45, Austria
    • View Profile
  • Peppermint version(s): 10
Disable the pinch zoom gesture on the touchpad of a laptop
« on: July 15, 2018, 06:36:10 am »
I am using two fingers for scrolling. On my new installation of Peppermint 9, Chrome often interpreted this as a pinch zoom gesture, which is a little annoying, so I disabled it:

Code: [Select]
xinput list
shows the input devices

Code: [Select]
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ HAILUCK CO.,LTD Usb Touch                id=9 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Video Bus                                id=6 [slave  keyboard (3)]
    ↳ Power Button                            id=7 [slave  keyboard (3)]
    ↳ USB 2.0 Camera: USB 2.0 Camera          id=10 [slave  keyboard (3)]
    ↳ Intel HID events                        id=11 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=12 [slave  keyboard (3)]
    ↳ HAILUCK CO.,LTD Usb Touch                id=8 [slave  keyboard (3)]

Disabling Usb Touch in Virtual core keyboard did the trick for me:
Code: [Select]
xinput disable 8


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Disable the pinch zoom gesture on the touchpad of a laptop
« Reply #1 on: July 15, 2018, 07:34:34 am »
Nice .. thanks for taking the time to post your solution :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec