Choose style:

Author Topic: Peppermint 9 - Changing the Firefox user interface language.  (Read 5540 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25967
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
[EDIT]

These instructions are no longer necessary .. please see the next posting below.
https://forum.peppermintos.com/index.php/topic,7147.msg83609.html#msg83609

[END EDIT]

Are you installing Peppermint 9 in a language other than English, but when you start Firefox the UI is still in English ?

I'm currently not sure why this is (it shouldn't because it's set to matchOS), but I'm looking into it.

Meanwhile here's a fix....

1) Install the language pack for your locale, for example for French install firefox-locale-fr
Code: [Select]
sudo apt-get install firefox-locale-fr
2) Now fire up Firefox, and go to:- about:config

3) Search for the key:- intl.locale.requested

4) if that key doesn't exist, right click in a blank space and choose:- New > String and enter: intl.locale.requested and click the OK button.

5) In the next dialog enter the string value that equates to your language, such as for example:
fr
for French .. then click the OK button.

6) Restart Firefox.

And the Firefox UI should now be in the language you selected.



If at any stage you'd like the UI back in English, simply set:-

intl.locale.requested = en

and restart Firefox.



[EDIT]

It looks like Mozilla are planning on adding a UI locale switcher to the Firefox settings :)
https://bugzilla.mozilla.org/show_bug.cgi?id=1469684
and
https://bug1425941.bmoattachments.org/attachment.cgi?id=8937602
« Last Edit: March 21, 2019, 12:15:14 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25967
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 9 - Changing the Firefox user interface language.
« Reply #1 on: March 21, 2019, 12:13:02 pm »
In recent versions of Firefox you can change the user interface language in Firefox itself.

In Firefox go to:-

Edit > Preferences > General (tab)

and in the "Language" section under "Choose the languages used to display menus, messages, and notifications from Firefox.", choose the language you want the user interface to be displayed in from the drop-menu, then click the button to "Apply and Restart".

The Firefox user interface should now be in the language selected.
« Last Edit: March 21, 2019, 12:16:09 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec