Choose style:

Author Topic: Firefox UI always in English ?  (Read 554 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Firefox UI always in English ?
« on: July 01, 2018, 10:59:05 am »
Are you installing Peppermint 9 in a language other than English, but when you start Firefox the UI is still in English ?

I'm currently not sure why this is (it shouldn't because it's set to matchOS), but I'm looking into it.

Meanwhile here's a fix....

1) Install the language pack for your locale, for example for French install firefox-locale-fr
Code: [Select]
sudo apt-get install firefox-locale-fr
2) Now fire up Firefox, and go to:- about:config

3) Search for the key:- intl.locale.requested

4) if that key doesn't exist, right click in a blank space and choose:- New > String and enter: intl.locale.requested and click the OK button.

5) In the next dialog enter the string value that equates to your language, such as for example:
fr
for French .. then click the OK button.

6) Restart Firefox.

And the Firefox UI should now be in the language you selected.



If at any stage you'd like the UI back in English, simply set:-

intl.locale.requested = en

and restart Firefox.
« Last Edit: July 05, 2018, 06:58:21 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline some1

  • nOOb
  • *
  • Posts: 10
  • Karma: 1
  • New Forum User
    • View Profile
Re: Firefox UI always in English ?
« Reply #1 on: July 02, 2018, 09:51:23 am »
My Firefox UI too wasn't in a language selected on install.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Firefox UI always in English ?
« Reply #2 on: July 02, 2018, 10:15:51 am »
Yeah, I'm trying to figure out if this was something we did (or didn't do), or a problem with Firefox 60 itself.

The good news is that Mozilla are looking into adding an option in the Firefox settings that allows users to switch the UI language without the need to go digging in about:config).
https://bugzilla.mozilla.org/show_bug.cgi?id=1469684
In fact they already have a mockup
https://bug1425941.bmoattachments.org/attachment.cgi?id=8937602
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 165
  • Karma: 200
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 8 & 9
Re: Firefox UI always in English ?
« Reply #3 on: July 04, 2018, 05:16:21 am »
In my case I cannot find intl.locale.requested in about:config. I can also not download the language pack because Firefox is on old version (60 instead of 61) (it seems it doesn't update automagically.....)

Is there any other way to update so I can install the right language pack?

Thank you in advance, and with kind regards,

Laurens Swarte
the Netherlands.


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Firefox UI always in English ?
« Reply #4 on: July 04, 2018, 09:31:49 am »
The instructions above tell you what to do if that key doesn't exists .. step 4.

And the language pack should be in the repos.

Which language are you wanting ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 165
  • Karma: 200
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 8 & 9
Re: Firefox UI always in English ?
« Reply #5 on: July 04, 2018, 04:45:32 pm »
I was confused with the language packs in Firefox. This is the cause of my misunderstanding. I am sorry.

I didn't understand to search in the repos. I just searched for the Firefox language packs in the add-ons.



The message is that FF is an old version. So at first instance I wondered how to update. I assumed the updates come with the usual updates.

Thank you for your help.

With kind regards,

Laurens Swarte
the Netherlands.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Firefox UI always in English ?
« Reply #6 on: July 04, 2018, 05:39:12 pm »
So are you sorted now Laurens ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline lswarte

  • Trusted User
  • Member
  • *****
  • Posts: 165
  • Karma: 200
  • Once a noob, always a noob.
    • View Profile
    • Facebook
  • Peppermint version(s): Peppermint 8 & 9
Re: Firefox UI always in English ?
« Reply #7 on: July 05, 2018, 03:51:14 am »
Yes, Mark, it is all clear now. Thank you very much!

By the way, my PM8 machine has the same issue. Solved in the same way too ;-)

With kind regards,

Laurens Swarte
the Netherlands


Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1160
  • Karma: 130
  • Peppermint - Void - NetBSD
    • View Profile
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: Firefox UI always in English ?
« Reply #8 on: July 05, 2018, 03:45:24 pm »
This works perfectly!
...and I only had to follow it to the word :D as my daughter wanted it in French 8)

Skickat från min SM-G900F via Tapatalk


Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Firefox UI always in English ?
« Reply #9 on: July 23, 2018, 01:47:09 pm »
It does not work for me.
I want the Swedish UI.
intl.locale.requested did not change a thing. It is still in English after restart of Firefox.

/ Hans Gatu

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Firefox UI always in English ?
« Reply #10 on: July 23, 2018, 01:59:38 pm »
Try running this in a terminal:
Code: [Select]
sudo apt-get install firefox-locale-sv
then in Firefox, set:-

intl.locale.requested

to:-

sv

Then you MUST restart Firefox.
« Last Edit: July 23, 2018, 02:03:40 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Firefox UI always in English ?
« Reply #11 on: July 23, 2018, 02:14:31 pm »
OK. I had it set to se, not sv.
Now it is sv, but that is after I already made the work around procedure.

/ Hans Gatu

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Firefox UI always in English ?
« Reply #12 on: July 23, 2018, 02:28:13 pm »
Set

intl.locale.requested

to

sv-SE

then restart Firefox.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec