Choose style:

Author Topic: Peppermint 9 - conky-manager now available in the default repository.  (Read 1855 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25260
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
There are some instructions making the rounds on various websites instructing how to install conky-manager in Ubuntu 18.04 that we consider sub-optimal (probably not dangerous, just not optimal). They require the user install a "realpath" package from Ubuntu 17.10 because conky-manager requires realpath as a dependency.

The problem with these instructions is that  /usr/bin/realpath is now part of the coreutils package and already exists on the system, so installing the realpath package from 17.10 may overwrite this newer version of the binary .. which is probably not an ideal solution.

So we have added a dummy package of realpath to the Peppermint 9 default repository .. this dummy metapackage doesn't actually install ANYTHING (because /usr/bin/realpath already exists), it simply satisfies dpkg that a package called "realpath" exists on the system when installing conky-manager, so that installation proceeds smoothly.

The long and the short of this is that any Peppermint 9 user that wants Conky Manager can now install it in the normal way
Code: [Select]
sudo apt update
then
Code: [Select]
sudo apt install conky-manager
.
or via the Software Manager / Synaptic Package Manager.



If anyone has previously installed conky-manager in Peppermint 9 following instructions they found on the interweb that included installing the 17.10 (artful) version of realpath, we'd suggest you reinstall coreutils to pull back in the 18.04 version of the /usr/bin/realpath binary.
Code: [Select]
sudo apt-get install --reinstall coreutils
« Last Edit: June 28, 2018, 10:06:36 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MadScintist

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • I'm Madscintist i break everything and fix it up
    • View Profile
I posted in a topic That was called conky-manager? by VinDSL I was trying to get in touch with him to see about hes conky he did and how i can get it. 

Did you remove this topic also? because i would have like to be informed. Thank you

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5164
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Hi MadScintist.

The 'HOWTO: VinDSL Conky Script' thread is over in the Ubu Forums: https://goo.gl/pn6SOS - if that's what you're talking about.

It was started by 42dorian, in 2011, when he was running support for me. It's still active - 463K views, 273 pages, 2700 replies.

AFAIK, we've never discussed my script in the Peppermint Forums. I'm known as the guy that doesn't support his own work. LoL

Really, it's an impossible task, keeping up with all the requests, so I leave it to others on Ubu, and elsewhere.

Anyway, that's what I would suggest - give the Ubu thread a shot. Somebody will help you, over there, I'm sure.   ;)

Offline MadScintist

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • I'm Madscintist i break everything and fix it up
    • View Profile
Hi VinDSL

I was wondering which i should start with so i can have it like your conky match up to this day 2018

As I know weather forecast stuff is outdated and some scripts might be as well.

I know you had a screenshot in here recently. If you can give me page you followed to this day current

What should i start with?

Thanks,

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5164
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
I was wondering which i should start with so i can have it like your conky match up to this day 2018

As I know weather forecast stuff is outdated and some scripts might be as well.

Heh! Yeah, I was making my own weather app, for awhile, and scrapping data off an undocumented Google feed. It was fun, until they turned the API off, in the middle of the night, with no notice. That's when I hooked up with Paramvir Likhari in India. I ran across his git, when I was looking for a script to haxor... and the rest is history.

So, last things first, I would recommend using Paramvir's Conkywx script for the weather (that's what I use): http://foreverquest.blogspot.com/2018/

You'll find my current weather templates and fonts over there (listed at the bottom of the Distro box). I've modularized a few features, but haven't released it to the public yet.

And, first things last, I would recommend installing the package(s) listed in the first post (above). I haven't tried it, but that should give you a working Conky install, which is half the battle - then, haxor away.  ;)

Back On Topic, please ...

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5164
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
I would recommend installing the package(s) listed in the first post (above). I haven't tried it, but that should give you a working Conky install[...]

Er...

Correct me, if that's wrong, Chief.

I've never actually used 'conky-manager', 'conky-colors', etc. Not sure what they do  :-\

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25260
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Installing conky-manager will pull in conky-std as a dependency .. if your script requires conky-all you'll have to install that manually.

Conky Manager is a GUI for switching between conky's .. it also allows you to make some changes to colouring/screen position/etc. via the GUI (dunno if that works with ALL conky's or just the included ones), set autostart options (I think), and access the conky script itself for editing.

[EDIT]

There is no requirement to install conky-manager if you don't want the GUI, just install conky-std or conky-all and configure your conky manually ;)

I can't say much beyond that as I use neither.
« Last Edit: June 29, 2018, 01:54:27 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5164
  • Karma: 939
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Oh, okay.

Yeah, conky-all is a 'must', and you need to make sure the binary has 'lua' baked in (or compile it yourself). Some vers don't come with 'lua'.


Sent from my Moto E⁴ via Tapatalk


Offline English Bob

  • nOOb
  • *
  • Posts: 16
  • Karma: 7
  • Peppermint Addict
    • View Profile
    • Bob's Youtube
  • Peppermint version(s): 8&9
Awesome Job MArk

It seems both Pepp 9 and Mark are just getting better and better.
Thanks All
English Bob

Never Rub Another Man's Rhubarb

PC Specs - Main PC - PepermintOS8 64Bit Linux -  8x AMD FX(tm)-8350 - Eight-Core Processor - 16GB Dual-Channel DDR3 @  1600MHz - ASUSTeK COMPUTER INC. M5A78L-M - PLUS - NVIDIA GeForce GTX 960 4Gb

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Awesome Job MArk

It seems both Pepp 9 and Mark are just getting better and better.

For a small distro, we pack mighty big wallop  ;)!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline English Bob

  • nOOb
  • *
  • Posts: 16
  • Karma: 7
  • Peppermint Addict
    • View Profile
    • Bob's Youtube
  • Peppermint version(s): 8&9
Re: Peppermint 9 - conky-manager now available in the default repository.
« Reply #10 on: July 02, 2018, 12:07:13 am »
Hey Andyln

Pepp 9 may be small but when i'm done the whole planet will know just how dam good it is, as I always say to people why have a burger when you can have a Peppermint lmao.
Thanks All
English Bob

Never Rub Another Man's Rhubarb

PC Specs - Main PC - PepermintOS8 64Bit Linux -  8x AMD FX(tm)-8350 - Eight-Core Processor - 16GB Dual-Channel DDR3 @  1600MHz - ASUSTeK COMPUTER INC. M5A78L-M - PLUS - NVIDIA GeForce GTX 960 4Gb

Offline stevesveryown

  • Member
  • ***
  • Posts: 218
  • Karma: 37
  • Peppermint Fan
    • View Profile
    • stevesveryown
  • Peppermint version(s): Peppermint 8, 9 & 10!!!!
Re: Peppermint 9 - conky-manager now available in the default repository.
« Reply #11 on: July 02, 2018, 11:14:28 pm »
Hey Andyln

Pepp 9 may be small but when i'm done the whole planet will know just how dam good it is, as I always say to people why have a burger when you can have a Peppermint lmao.

You crack me up, EB!  :D