Author Topic: Turn On/Off System Sounds  (Read 3648 times)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Turn On/Off System Sounds
« Reply #15 on: June 29, 2018, 05:13:54 pm »
Try installing gnome-session-canberra and sox
Code: [Select]
sudo apt-get install gnome-session-canberra sox ubuntu-soundsthen logging off/on

Did that make any differences ?
« Last Edit: June 29, 2018, 05:18:22 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #16 on: June 29, 2018, 06:04:29 pm »
Okay, I won't worry about it.  Probably just suffering from FOMO (fear of missing out)  :(

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Turn On/Off System Sounds
« Reply #17 on: June 29, 2018, 06:10:03 pm »
Did you try the fix in my last post ?

It's weird .. on one of my PC's (23bit Peppermint 9). like you very few system sounds were working (just the one you mentioned when backspacing a text filed until it was empty) .. I installed sox and still only the one system sound .. then I installed gnome-session-canberra .. logged off/on and they all started to work.

Purged gnome-session-canberra .. and they stayed working, even after a reboot .. go figure :-\
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #18 on: June 29, 2018, 06:40:46 pm »
Tried the fix on your last post.    Didn't fix.

Laptop has the same as only sound when backspacing end of box, but no sound when trying to delete or empty trash.

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #19 on: June 29, 2018, 06:46:44 pm »
Did you try the fix in my last post ?

It's weird .. on one of my PC's (23bit Peppermint 9). like you very few system sounds were working (just the one you mentioned when backspacing a text filed until it was empty) .. I installed sox and still only the one system sound .. then I installed gnome-session-canberra .. logged off/on and they all started to work.

Purged gnome-session-canberra .. and they stayed working, even after a reboot .. go figure :-\

When you mention Purged  gnome-session-canberra , did you do a command to purge?  I didn't do that.

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #20 on: June 29, 2018, 06:57:41 pm »
Don't know if it makes a difference or not, but I'm on 64 bit.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Turn On/Off System Sounds
« Reply #21 on: June 29, 2018, 07:20:30 pm »
The odd thing is, once they start to work, no amount of undoing what you just did stops them from working again :-\
(wonder if caching is somehow playing a role)

So figuring out what the fix was is proving to be difficult .. I'm going to have to reinstall a fresh copy of PM9 and make changes one at a time until I 'suss' what's going on.

No I doubt it's anything to do with  64bit .. they just worked on my 64bit machines so this is turning out to be some kinda weird voodoo majick
« Last Edit: June 29, 2018, 07:22:35 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #22 on: June 29, 2018, 07:25:59 pm »
Okay. 

I appreciate your attempts.  But like I said in an earlier post, not that important.  As, I can easily visually see when the "delete" prompt appears or when the trash gets emptied.  But it sounds like you are similar to me in that wanting to know why something works or does not work.


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Turn On/Off System Sounds
« Reply #23 on: June 29, 2018, 07:33:12 pm »
Can you try this for me...

run:
Code: [Select]
sudo apt-get install libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0 gnome-session-canberra soxthen:
Code: [Select]
sudo xed /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modulesand make sure the file reads:-
Code: [Select]
# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
GTK_MODULES="canberra-gtk-module"
else
GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES
then run:
Code: [Select]
sudo xed /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modulesand make the file read
Code: [Select]
# This file is sourced by Xsession(5), not executed.

if [ -z "$GTK_MODULES" ] ; then
GTK_MODULES="canberra-gtk-module"
else
GTK_MODULES="$GTK_MODULES:canberra-gtk-module"
fi

export GTK_MODULES
Then log off/on before testing.

I'm DEFINITELY the type that wants to know why it doesn't work .. because it reflects badly on Peppermint when something we include doesn't work ;)



After testing this, if you wanna give up, just delete
Code: [Select]
sudo rm -v /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modulesand
Code: [Select]
sudo rm -v /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
« Last Edit: June 30, 2018, 07:43:06 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #24 on: June 29, 2018, 08:12:02 pm »
OK. I will try tomorrow and get back to you.

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #25 on: June 30, 2018, 05:44:16 am »
I ran the steps suggested.   Didn't seem to have any effect.

Here is copy of terminal session:

wally@wally-Latitude-D620 ~ $ sudo apt-get install lincanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra0 gnome-session-canberra sox
[sudo] password for wally:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package lincanberra-gtk-module
wally@wally-Latitude-D620 ~ $ sudo xed /etc/X11/Xsession.d/52libcanberra-gtk-module_add-to-gtk-modules
wally@wally-Latitude-D620 ~ $ sudo xed /etc/X11/Xsession.d/52libcanberra-gtk3-module_add-to-gtk-modules
wally@wally-Latitude-D620 ~ $

After each xed command, a screen popped up and I copied, pasted and save the GTK code you listed.

I don't my trying more test to try to figure out why no system sounds for me.
« Last Edit: June 30, 2018, 06:05:11 am by MyOwnPepper »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2200
  • Karma: 458
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Turn On/Off System Sounds
« Reply #26 on: June 30, 2018, 06:58:48 am »
That was a typo, it should be "libcanberra-gtk-module" not lin...

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Turn On/Off System Sounds
« Reply #27 on: June 30, 2018, 07:43:25 am »
fixed above. :-[
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #28 on: June 30, 2018, 08:58:34 am »
That was a typo, it should be "libcanberra-gtk-module" not lin...

Thanks for spotting that.

Offline MyOwnPepper

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 9
Re: Turn On/Off System Sounds
« Reply #29 on: June 30, 2018, 09:00:46 am »
The suggested test  fixed my sound issue  8).

A "PLUNK" never sounded so fine  :D.   Thanks!
« Last Edit: June 30, 2018, 09:13:18 am by MyOwnPepper »