Choose style:

Author Topic: RetroPie Peppermint OS 8 Support  (Read 541 times)

0 Members and 1 Guest are viewing this topic.

Offline dro3m

  • Jr. Member
  • **
  • Posts: 27
  • Karma: -1
  • StormTrooper
    • View Profile
  • Peppermint version(s): Peppermint OS 8
RetroPie Peppermint OS 8 Support
« on: June 13, 2018, 04:07:10 pm »
Craving for some Pokemon Gold? What about some good ol' Doom? Well RetroPie may be the answer.

Well, your almost done installing, now you just need to run the setup script, type in the command
and....
OH COME OOOOOOOOOOOOOOOON! :-[

Code: [Select]
Distributor ID:	Peppermint
Description: Peppermint 8 Eight
Release: 8
Codename: xenial

That make no since does it? Peppermint is Debian/Ubuntu based, and RetroPie can run on that right?

Well I have a fix for you! Go to Home -> RetroPie-Setup -> scriptmodules and open system.sh in your favorite text editor
Scrool a little bit until your see the line
Code: [Select]
*)
(ln 151) above that paste this code:

Code: [Select]
        Peppermint)
            if compareVersions "$__os_release" lt 6; then
                error="You need Peppermint OS 6 or newer"
            elif compareVersions "$__os_release" lt 8; then
                __os_ubuntu_ver="14.04"
            else
                __os_ubuntu_ver="16.04"
            fi
            __os_debian_ver="8"
            ;;

Make sure to keep it in line with the rest of the code. Save and rerun the script. Enjoy!

Disclaimer: This code will only work on Peppermint OS 6 or newer, this will not fix any other distros. I am not responsible for your lost game save or waste of time. Feel free to contact me. Do not ask anything about RetroPie on this forum except the following code.

RetroPie:
https://retropie.org.uk/

« Last Edit: June 13, 2018, 04:12:40 pm by dro3m »
dro3m

My signature needs more eye candy, but the admins took out all the fun stuff.

Offline 00ninja

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
    • View Profile
  • Peppermint version(s): Peppermint 8 Respin2 (x64)
Re: RetroPie Peppermint OS 8 Support
« Reply #1 on: June 13, 2018, 04:22:09 pm »
I found the same issue a few months back and added the same fix. Works great and allows RetroPie Setup Script to run.....but I had an issue when it attempted to build 2 cores using P8 or P8 r2. One is an N64 core (lr-mupen64plus)the other is a PSX core (lr-pcsx-rearmed). It was a dependancy problem but after running the script on Linux Mint, and transferring the newly built cores into Peppermint, all is well.
« Last Edit: June 13, 2018, 04:24:08 pm by 00ninja »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: RetroPie Peppermint OS 8 Support
« Reply #2 on: June 13, 2018, 06:00:55 pm »
Nice, if they update that script for 18.04 I may submit a pull request with this fix (or a modified 18.04 version of it).

Another option would have been to edit /etc/lsb-release to read the same as the Ubuntu version .. run the script .. then un-edit /etc/lsb-release .. but the above fix is better.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline dro3m

  • Jr. Member
  • **
  • Posts: 27
  • Karma: -1
  • StormTrooper
    • View Profile
  • Peppermint version(s): Peppermint OS 8
Re: RetroPie Peppermint OS 8 Support
« Reply #3 on: June 13, 2018, 06:43:53 pm »
Nice, if they update that script for 18.04 I may submit a pull request with this fix (or a modified 18.04 version of it).

Another option would have been to edit /etc/lsb-release to read the same as the Ubuntu version .. run the script .. then un-edit /etc/lsb-release .. but the above fix is better.

No worry, RetroPie has been installed and tested on Lubuntu 18.04 by me. No script modifications required. It really just depends on the version of Debian its based on. Right now 8 and 9. 10 (Codename Buster) has recently under gone development. I also like to note that RetroPie has a hard time detecting detecting Debian versions, that's why i made some code to fix that.
dro3m

My signature needs more eye candy, but the admins took out all the fun stuff.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21671
  • Karma: 2436
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: RetroPie Peppermint OS 8 Support
« Reply #4 on: June 13, 2018, 06:46:00 pm »
Nice, if I remember I'll submit a pull request after PM9 is released and I've tested it then :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec