Choose style:

Author Topic: Two issues with Firefox  (Read 1522 times)

0 Members and 1 Guest are viewing this topic.

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Two issues with Firefox
« on: June 13, 2018, 02:15:37 am »
I have two issues with Firefox.
I have also reported this to Mozilla/Firefox, but they cannot find the cause, so maybe it is a Peppermint issue rather than a Firefox issue.

I run Swedish localized versions of both Peppermint 7 and 8.
Peppermint 7 on a laptop and Peppermint 8 on two different desktops.

Issue #1:
Firefox suddenly crash without any good reason, just by visiting a web page.

Issue #2:
When updating Firefox, the Swedish UI disappear. I.e. all menues will be in English, even though the Swedish language pack is installed.
I have figured out a work-around, by downloading the Swedish Firefox from https://www.mozilla.org/sv-SE/firefox/all/
extracting it to a folder, copying all of its contents (as root), and paste/overwrite it in the folder usr/lib/firefox.
Then Firefox is in Swedish, until next update, because the issue repeats itself at next update, and the same work-around solves it again.

I run Manjaro Linux on another laptop without these issues. That is why it might be a Peppermint issue rather than a Firefox issue.

/ Hans Gatu

 

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1747
  • Karma: 243
    • View Profile
Re: Two issues with Firefox
« Reply #1 on: June 13, 2018, 03:14:52 am »
You could launch firefox from the terminal and check for any error messages upon crash.
At least this could give us something to start with?
Just say NO to flatpak and snap!!

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24788
  • Karma: 2732
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Two issues with Firefox
« Reply #2 on: June 13, 2018, 08:31:14 am »
Can you test something for me ?

Open a terminal and run:
Code: [Select]
sudo pluma /etc/linuxmint/adjustments/15-mintsystem-desktop.overwrite
REMOVE these 3 lines
Code: [Select]
/usr/lib/peppermint/adjustments/ddg.xml /usr/lib/firefox/distribution/searchplugins/locale/en-US/ddg.xml
/usr/lib/peppermint/adjustments/ddg.xml /usr/lib/firefox/distribution/searchplugins/locale/en-GB/ddg.xml
/usr/lib/peppermint/adjustments/distribution.ini /usr/lib/firefox/distribution/distribution.ini
SAVE the file, and exit the text editor.

Now reinstall the version of Firefox frfom the default repositories:
Code: [Select]
sudo apt-get install --reinstall firefox
and let us know if the problem still occurs ?

If that works it'd be helpful if you're up for a bit of other testing to figure out which of those 3 files is causing the problem (?)

[EDIT]

BTW, welcome to the forum :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Two issues with Firefox
« Reply #3 on: June 13, 2018, 03:44:46 pm »
Can you test something for me ?

Open a terminal and run:
Code: [Select]
sudo pluma /etc/linuxmint/adjustments/15-mintsystem-desktop.overwrite
REMOVE these 3 lines
Code: [Select]
/usr/lib/peppermint/adjustments/ddg.xml /usr/lib/firefox/distribution/searchplugins/locale/en-US/ddg.xml
/usr/lib/peppermint/adjustments/ddg.xml /usr/lib/firefox/distribution/searchplugins/locale/en-GB/ddg.xml
/usr/lib/peppermint/adjustments/distribution.ini /usr/lib/firefox/distribution/distribution.ini
SAVE the file, and exit the text editor.

Now reinstall the version of Firefox frfom the default repositories:
Code: [Select]
sudo apt-get install --reinstall firefox
and let us know if the problem still occurs ?

If that works it'd be helpful if you're up for a bit of other testing to figure out which of those 3 files is causing the problem (?)

[EDIT]

BTW, welcome to the forum :)

Thanks for the welcome :)

Well, I followed this procedure (removed all three lines) and again I ended up with an English UI.
I had to do the work-around again to get the Swedish UI back.

/ Hans Gatu

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Two issues with Firefox
« Reply #4 on: June 14, 2018, 03:59:54 pm »
You could launch firefox from the terminal and check for any error messages upon crash.
At least this could give us something to start with?

OK.
I visited this page:    https://www.tv4.se/program
And this is a copy of what was in the terminal:

Click to Open
~ $ firefox
[Parent 21391, Gecko_IOThread] WARNING: pipe error (154): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21551] not implemented: PPB_FileRef;1.2
[fresh 21551] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21551] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21551] not implemented: PPB_BrokerTrusted;0.3
[fresh 21551] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x5C000A,name=PPluginModule::Msg_PPluginInstanceConstructor) Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (160): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21563] not implemented: PPB_FileRef;1.2
[fresh 21563] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21563] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21563] not implemented: PPB_BrokerTrusted;0.3
[fresh 21563] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (165): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21575] not implemented: PPB_FileRef;1.2
[fresh 21575] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21575] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21575] not implemented: PPB_BrokerTrusted;0.3
[fresh 21575] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x5C000A,name=PPluginModule::Msg_PPluginInstanceConstructor) Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (166): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21587] not implemented: PPB_FileRef;1.2
[fresh 21587] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21587] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21587] not implemented: PPB_BrokerTrusted;0.3
[fresh 21587] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (165): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21599] not implemented: PPB_FileRef;1.2
[fresh 21599] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21599] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21599] not implemented: PPB_BrokerTrusted;0.3
[fresh 21599] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x5C000A,name=PPluginModule::Msg_PPluginInstanceConstructor) Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (165): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21611] not implemented: PPB_FileRef;1.2
[fresh 21611] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21611] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21611] not implemented: PPB_BrokerTrusted;0.3
[fresh 21611] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[GFX1]: Invalid reference count release-1
[Parent 21391, Gecko_IOThread] WARNING: pipe error (185): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21624] not implemented: PPB_FileRef;1.2
[fresh 21624] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21624] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21624] not implemented: PPB_BrokerTrusted;0.3
[fresh 21624] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x5C000A,name=PPluginModule::Msg_PPluginInstanceConstructor) Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (188): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21637] not implemented: PPB_FileRef;1.2
[fresh 21637] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21637] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21637] not implemented: PPB_BrokerTrusted;0.3
[fresh 21637] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (191): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21649] not implemented: PPB_FileRef;1.2
[fresh 21649] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21649] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21649] not implemented: PPB_BrokerTrusted;0.3
[fresh 21649] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (191): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21661] not implemented: PPB_FileRef;1.2
[fresh 21661] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21661] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21661] not implemented: PPB_BrokerTrusted;0.3
[fresh 21661] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (192): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21673] not implemented: PPB_FileRef;1.2
[fresh 21673] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21673] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21673] not implemented: PPB_BrokerTrusted;0.3
[fresh 21673] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (195): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21685] not implemented: PPB_FileRef;1.2
[fresh 21685] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21685] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21685] not implemented: PPB_BrokerTrusted;0.3
[fresh 21685] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (196): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353
NOT SANDBOXED
[fresh 21697] not implemented: PPB_FileRef;1.2
[fresh 21697] not implemented: PPB_OpenGLES2VertexArrayObject;1.0
[fresh 21697] not implemented: PPB_OpenGLES2DrawBuffers(Dev);1.0
[fresh 21697] not implemented: PPB_BrokerTrusted;0.3
[fresh 21697] [PPB] {zilch} ppb_network_monitor_update_network_list
sh: 1: gdb: not found

###!!! [Parent][MessageChannel::Call] Error: Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x5C000A,name=PPluginModule::Msg_PPluginInstanceConstructor) Channel error: cannot send/recv

[Parent 21391, Gecko_IOThread] WARNING: pipe error (57): Förbindelse borttagen av partnern: file /builds/worker/workspace/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 353

###!!! [Parent][MessageChannel] Error: (msgtype=0x480017,name=PHttpChannel::Msg_DeleteSelf) Channel error: cannot send/recv


###!!! [Parent][MessageChannel] Error: (msgtype=0x15007F,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv





And here is a recording of a similar crash, visiting another site, with a previous version of Firefox:

/ Hans Gatu

[close]
« Last Edit: June 14, 2018, 04:10:23 pm by _HG_ »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 24788
  • Karma: 2732
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Two issues with Firefox
« Reply #5 on: June 14, 2018, 04:32:01 pm »
Does disabling hardware acceleration in Firefox make any difference ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1747
  • Karma: 243
    • View Profile
Re: Two issues with Firefox
« Reply #6 on: June 14, 2018, 06:05:40 pm »
Hej Hans!
Does this only happen on pages with sound/video?

Hörs!

Skickat från min SM-G900F via Tapatalk

Just say NO to flatpak and snap!!

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Two issues with Firefox
« Reply #7 on: June 15, 2018, 01:33:40 am »
Hej Hans!
Does this only happen on pages with sound/video?

Hörs!

Skickat från min SM-G900F via Tapatalk



I don't know.
The screen clip is  www.tradera.com
It has happened on  www.eBay.com  and  swedbank.se  and several more.

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Two issues with Firefox
« Reply #8 on: June 15, 2018, 01:39:41 am »
Now I have got into new problems.

Yesterday evening I changed to a widescreen monitor.
I used to have a 4:3 monitor.
It worked fine, yesterday.
This morning, after logging in to Peppermint, the monitor goes to sleep, or turns off.
I can't see anything now.
Is there a way to reset the monitor settings in Peppermint, from the boot DVD ?

/ Hans Gatu

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1747
  • Karma: 243
    • View Profile
Re: Two issues with Firefox
« Reply #9 on: June 15, 2018, 02:00:49 am »
I use Firefox on 4 different laptops without any issues? Although, my systems are not in Swedish.
Are your systems fully updated?

Please create another thread for your other issue. Otherwise, it will easily get a bit messy for other to find the solutions.

Tack!

Skickat från min SM-G900F via Tapatalk

Just say NO to flatpak and snap!!

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Two issues with Firefox
« Reply #10 on: June 15, 2018, 02:07:34 am »
Yes, I always update, as soon as there are updates available.
So, it is updated. Unless there are new updates today that I can't see because of the new monitor problems.


The monitor settings problem is now posted here:
https://forum.peppermintos.com/index.php?topic=7031.new#new


/ Hans Gatu
« Last Edit: June 15, 2018, 02:13:48 am by _HG_ »

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1747
  • Karma: 243
    • View Profile
Re: Two issues with Firefox
« Reply #11 on: June 15, 2018, 02:52:38 am »
Thanks!
Back on topic...
Are you having this firefox issue on all the three systems or just one of them?

Skickat från min SM-G900F via Tapatalk

Just say NO to flatpak and snap!!

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Two issues with Firefox
« Reply #12 on: June 15, 2018, 03:12:54 am »
Both crash and localization problems on all Peppermint systems (i.e. all three systems).

/ Hans Gatu

Offline pin

  • Trusted User
  • Veteran
  • *****
  • Posts: 1747
  • Karma: 243
    • View Profile
Re: Two issues with Firefox
« Reply #13 on: June 15, 2018, 07:49:04 am »
This is a bit strange to be honest...
My machines: PM7 on a laptop locals set to English - No issues
                          Void Linux musl-libC - No issues (there are no locals on musl-libC, that's only English)
My daughter's machine: Bodhi Linux, based on Ubuntu 16.04, so the same as PM7, locales set to French both on the PC and firefox - No issues (firefox update just a couple of days ago)

???
Just say NO to flatpak and snap!!

Offline _HG_

  • nOOb
  • *
  • Posts: 18
  • Karma: -3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 and 8
Re: Two issues with Firefox
« Reply #14 on: July 11, 2018, 02:50:04 pm »
I upgraded to Firefox 61.0.1 just now.
The localization problem occured again.
I had to apply the work around again to get the Swedish UI back.

/ Hans Gatu