Choose style:

Author Topic: Redshift gui will not auto start (SOLVED)  (Read 4577 times)

0 Members and 1 Guest are viewing this topic.

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Redshift gui will not auto start (SOLVED)
« on: July 22, 2014, 08:09:31 pm »
redshift gui is working perfectly the only issue is everytime i reboot i have to load it up.
is there a way to make it autostart in the tray panel?
« Last Edit: July 22, 2014, 09:28:29 pm by iamesperambient »
http://iamesper.bandcamp.com
boring drone music from NJ

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Redshift gui will not auto start
« Reply #1 on: July 22, 2014, 08:18:58 pm »
Can you post the output from:
Code: [Select]
dpkg -l | grep redshift
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start
« Reply #2 on: July 22, 2014, 08:23:31 pm »
ok so what do i do i post this in the terminal ? and than what?
http://iamesper.bandcamp.com
boring drone music from NJ

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Redshift gui will not auto start
« Reply #3 on: July 22, 2014, 08:30:17 pm »
Run the above command in the terminal .. then post back here whatever is returned in the terminal (iee.the output from running that command).
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start
« Reply #4 on: July 22, 2014, 08:32:13 pm »
iamesper@justin-Latitude-D630 ~ $ dpkg -l | grep redshift
ii  plasma-widget-redshift                     0.6.1-0ubuntu1                        i386         Plasma widget for Redshift
rc  redshift-gtk                               1.8-0ubuntu6                          all          Adjusts the color temperature of your screen with GTK+ integration
ii  redshiftgui                                0.2.1                                 i386         Monitor color adjustment tool.
iamesper@justin-Latitude-D630 ~ $


this is what returned
http://iamesper.bandcamp.com
boring drone music from NJ

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Redshift gui will not auto start
« Reply #5 on: July 22, 2014, 08:43:38 pm »
This is Peppermint 5 right ?

if so run .. fist exit redshift (if it's running) .. then run:
Code: [Select]
sudo apt purge redshiftgui plasma-widget-redshift 
then
Code: [Select]
sudo apt-get autoremove
and hit "y" when prompted
then
Code: [Select]
sudo apt install gtk-redshift
Now start Redshift from:-

menu > Accessories > Redshift

Now click the icon in the system tray (by the clock), and make sure there's a tick next to "Autostart" .. if there isn't click "Autostart" and a tick will appear.

Now reboot to test it autostarts.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start
« Reply #6 on: July 22, 2014, 08:51:46 pm »
it def auto started but there is no preview and will this slowly shift aka be off turning the day and turn itself on at night?
from what i see here there is only the option to toogle it on and off or suspend for 30 mins, one hour or 2 hours.
I'm happy at least its there at the bottom to quickly turn off and on though. I suppose this version does not have
that option?
http://iamesper.bandcamp.com
boring drone music from NJ

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start
« Reply #7 on: July 22, 2014, 08:52:36 pm »
i suppose i would need to set it up with my coordinates some how through the terminal in order for it to shift?
http://iamesper.bandcamp.com
boring drone music from NJ

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Redshift gui will not auto start
« Reply #8 on: July 22, 2014, 08:58:15 pm »
From what I gather it automatically detects your general location by IP address, then sets the amount of redshift by time in that location.

That said I've never used it, so youll have to tell me tomorrow :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start
« Reply #9 on: July 22, 2014, 09:00:56 pm »
ok thanks will do ill let you know if it doesn't work ill either go back to the GUI version and just load it up everytime
or just toogle it on at night at least it works and my eyes don't hurt being up late trying to learn linux :P thanks again!~
http://iamesper.bandcamp.com
boring drone music from NJ

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Redshift gui will not auto start
« Reply #10 on: July 22, 2014, 09:02:28 pm »
We could probably get the gui version to autostart easily enough if you wish
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start
« Reply #11 on: July 22, 2014, 09:04:30 pm »
that would be even better as it seems the gui version is a little more closer to f.lux which at this point i can't even use a computer at night with out it :/ and its so pretty its like a sunrise on your monitor :P
http://iamesper.bandcamp.com
boring drone music from NJ

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Redshift gui will not auto start
« Reply #12 on: July 22, 2014, 09:14:29 pm »
OK disable redshift, then exit it.

then run:
Code: [Select]
sudo apt purge gtk-redshift redshift-gtk redshift
then
Code: [Select]
sudo apt autoremove
and hit "y" when ppromted
then download and install the redshiftgui .deb from sourceforge and install it the way you did before.

Once installed, run:
Code: [Select]
cp -v /usr/share/applications/redshiftgui.desktop ~/.config/autostart/redshiftgui.desktop
and reboot to test
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start
« Reply #13 on: July 22, 2014, 09:20:27 pm »
thanks let me go ahead and try this out.....hopefully it works.
http://iamesper.bandcamp.com
boring drone music from NJ

Offline iamesperambient

  • Veteran
  • ****
  • Posts: 1269
  • Karma: 89
  • a totally awesome dude
    • View Profile
    • i AM esper (drone ambient music)
  • Peppermint version(s): Peppermint 8 64 bit
Re: Redshift gui will not auto start (SOLVED)
« Reply #14 on: July 22, 2014, 09:28:49 pm »
Thank you SOOOO much it worked :) !!!!!!!
http://iamesper.bandcamp.com
boring drone music from NJ