Choose style:

Author Topic: "a start job is running" {SOLVED}  (Read 946 times)

0 Members and 1 Guest are viewing this topic.

Offline Rita G.

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
"a start job is running" {SOLVED}
« on: May 21, 2018, 07:42:36 pm »
boot sequence interrupted by:
"a start job is running for dev-disk blah blah blah etc."
. . and adds 90 seconds to boot time Can someone please help me with this?.
« Last Edit: May 24, 2018, 07:19:41 am by Rita G. »

Offline JoeSh

  • Member
  • ***
  • Posts: 106
  • Karma: 8
  • Peppermint does the trick
    • View Profile
  • Peppermint version(s): 6 and 7 (32bit) 10 (64bit)
Re: "a start job is running"
« Reply #1 on: May 21, 2018, 08:00:06 pm »
Hey Rita G,

It may be your swap file. Try gparted. Right click on your swap partition and select swapon. It might do the job.

 :-\

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: "a start job is running"
« Reply #2 on: May 21, 2018, 08:16:09 pm »
Hey Rita G,

It may be your swap file. Try gparted. Right click on your swap partition and select swapon. It might do the job.

 :-\

Unless you've already done so, you'll need to first install GParted.  Open a terminal window with the following keystrokes:

Ctrl+Alt+t

Enter (Copy & Paste) the following command into the terminal window and hit enter:
Code: [Select]
sudo apt update && sudo apt install gparted
Enter your user password when asked, (remember, passwords are entered invisibly).  Hit enter again.  After the download has completed, you'll find GParted by either entering the first few letters into the menu search box, or by navigating to:

Menu > System > GParted

If you have any problems, get back to us  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Rita G.

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: "a start job is running"
« Reply #3 on: May 21, 2018, 08:48:03 pm »
It may be your swap file. Try gparted. Right click on your swap partition and select swapon. It might do the job.
 :-\
No good. I did that 3 times and it will not save the change. keep getting the "job start" during boot.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: "a start job is running"
« Reply #4 on: May 22, 2018, 02:16:36 am »
It may be your swap file. Try gparted. Right click on your swap partition and select swapon. It might do the job.
 :-\
No good. I did that 3 times and it will not save the change. keep getting the "job start" during boot.

In a terminal window, run (Copy & Paste) the following commands in sequence.  Post the outputs back to the forum:
Code: [Select]
cat /etc/fstab
Code: [Select]
sudo blkid
and for good measure  ;):
Code: [Select]
inxi -Fz
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25300
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: "a start job is running"
« Reply #5 on: May 22, 2018, 12:45:40 pm »
Can I add one more command to Andy's list above .. please also include the output from:
Code: [Select]
sudo fdisk -l
I believe I'm thinking along the same line as Andy, in that it sounds like the UUID of your swap partition has changed since the creation of fstab .. so the boot sequence is halted whilst the system attempts to mount a non existent partition .. you're then effectively at the mercy of the failure timeout (which IIRC is 90 seconds).
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: "a start job is running"
« Reply #6 on: May 22, 2018, 07:14:13 pm »
Can I add one more command to Andy's list above .. please also include the output from:
Code: [Select]
sudo fdisk -l
I believe I'm thinking along the same line as Andy, in that it sounds like the UUID of your swap partition has changed since the creation of fstab .. so the boot sequence is halted whilst the system attempts to mount a non existent partition .. you're then effectively at the mercy of the failure timeout (which IIRC is 90 seconds).

That's exactly where I'm going  ;).  If this is the problem, it's really easy to fix  :).  Yeah definitely include:
Code: [Select]
sudo fdisk -l
I forgot to ask for it - bad Andy, bad Andy  :-[!
« Last Edit: May 22, 2018, 07:17:37 pm by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Rita G.

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: "a start job is running"
« Reply #7 on: May 22, 2018, 10:04:16 pm »
output
$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=4ba8e9fb-d35e-47ae-95ed-326ad578801f /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda2 during installation
UUID=0fb55611-0d5c-424c-b4ca-98b190691850 none            swap    sw              0 

$ sudo blkid
[sudo] password for :
/dev/sda1: LABEL="System Reserved" UUID="181E1E871E1E5DD6" TYPE="ntfs" PARTUUID="7b859415-01"
/dev/sda2: UUID="D6821F6D821F50FB" TYPE="ntfs" PARTUUID="7b859415-02"
/dev/sdb1: UUID="4ba8e9fb-d35e-47ae-95ed-326ad578801f" TYPE="ext4" PARTUUID="000909ab-01"
/dev/sdb2: UUID="7d7ff30b-084d-4c6d-a07b-c816cff8d91f" TYPE="swap" PARTUUID="000909ab-02"

$ inxi -Fz
System:    Host: oDel Kernel: 4.13.0-41-generic x86_64 (64 bit) Desktop: N/A
           Distro: Peppermint Eight
Machine:   Mobo: ASUSTeK model: Maximus IV GENE-Z v: Rev 1.xx
           Bios: American Megatrends v: 3603 date: 11/09/2012
CPU:       Quad core Intel Core i7-2600K (-HT-MCP-) cache: 8192 KB
           clock speeds: max: 5900 MHz 1: 1611 MHz 2: 1833 MHz 3: 2250 MHz
           4: 1701 MHz 5: 2661 MHz 6: 2414 MHz 7: 2382 MHz 8: 2946 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Card-2: NVIDIA GK104 [GeForce GTX 760]
           Display Server: X.Org 1.19.5 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.95hz
           GLX Renderer: Gallium 0.4 on NVE4 GLX Version: 3.0 Mesa 17.0.2
Audio:     Card-1 NVIDIA GK104 HDMI Audio Controller driver: snd_hda_intel
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-41-generic
Network:   Card: Intel 82579V Gigabit Network Connection driver: e1000e
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 240.1GB (8.7% used)
           ID-1: /dev/sda model: TOSHIBA size: 120.0GB
           ID-2: /dev/sdb model: SSD2SC120G1LC763 size: 120.0GB
Partition: ID-1: / size: 44G used: 20G (48%) fs: ext4 dev: /dev/sdb1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 36.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 205 Uptime: 11:55 Memory: 706.5/3841.6MB
           Client: Shell (bash) inxi: 2.2.35

$ sudo fdisk -l
Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x7b859415

Device     Boot   Start       End   Sectors   Size Id Type
/dev/sda1  *       2048   1126399   1124352   549M  7 HPFS/NTFS/exFAT
/dev/sda2       1126400 234438655 233312256 111.3G  7 HPFS/NTFS/exFAT


Disk /dev/sdb: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000909ab

Device     Boot    Start       End  Sectors  Size Id Type
/dev/sdb1  *        2048  92839935 92837888 44.3G 83 Linux
/dev/sdb2       92839936 101228543  8388608    4G 82 Linux swap / Solaris
[close]
« Last Edit: May 22, 2018, 10:58:34 pm by mac, Reason: encapsulate »

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 2998
  • Karma: 560
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: "a start job is running"
« Reply #8 on: May 23, 2018, 01:27:03 am »
Hi Rita G.,

AndyInMokum and PCNetSpec were right.  Your swap partition UUID is incorrect in fstab.  So edit fstab with

Code: [Select]
sudo xed /etc/fstab
enter your password

and when the file opens replace the lines at the bottom
Quote
# swap was on /dev/sda2 during installation
UUID=0fb55611-0d5c-424c-b4ca-98b190691850 none            swap    sw              0 

with
Quote
# swap was on /dev/sdb2 during installation
UUID=7d7ff30b-084d-4c6d-a07b-c816cff8d91f none            swap    sw              0

save the file reboot and it will no longer be looking for an invalid partition UUID

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P9/10 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline Rita G.

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: "a start job is running" {SOLVED}
« Reply #9 on: May 24, 2018, 07:18:27 am »
THANK YOU ALL!
that was driving me nuts and i was ready to jump out a window!  :D

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: "a start job is running" {SOLVED}
« Reply #10 on: May 24, 2018, 07:28:09 am »
THANK YOU ALL!
that was driving me nuts and i was ready to jump out a window!  :D

It's our pleasure, it's good to know you're up and running again  ;).  Thanks for marking the topic as [SOLVED].  No jumping out of windows is allowed, unless it's a basement one :))!!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25300
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: "a start job is running" {SOLVED}
« Reply #11 on: May 24, 2018, 07:33:37 am »
Great news :)

[EDIT]

And I don't mean the jumping out the window thing :))
« Last Edit: May 24, 2018, 07:35:28 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec