Choose style:

Author Topic: Booting Problem [Image inside]  (Read 979 times)

0 Members and 1 Guest are viewing this topic.

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1703
  • Karma: 288
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Booting Problem [Image inside]
« Reply #15 on: May 18, 2018, 09:37:32 am »
But I'd love to know what was the issue and what did we do the resolved it.

An inquiring mind eh  8)

Yes, the first ones were mounting your installed Peppermint partition and some key directories that are needed.

The chroot temporarily changes the root directory being operated on so that it becomes this installed Peppermint system and not the live USB.

Then when you edit the GRUB config file (you're right, GRUB is the bootloader) you're adding a kernel boot parameter, which is a special instruction for the Linux kernel to allow it to boot on your particular hardware.

Hope that made some kind of sense  ;)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22015
  • Karma: 2468
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: Booting Problem [Image inside]
« Reply #16 on: May 18, 2018, 04:02:39 pm »
would be good to know what the issues was and what we did to fix it.

Okay the bug and solution is listed here:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1724639

What the commands did:-
Code: [Select]
sudo mount /dev/sda1 /mnt
mounted the root partition of the hard drive install into the /mnt directory of the Live session.
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
Mounted some other directories there too
Code: [Select]
sudo chroot /mnt
changed the root directory from / in the live session to /mnt .. as /mnt now contains the root directory from the hard drive .. so any changes from this point onwards are made to the hard drive, and not the live session
Code: [Select]
nano /etc/default/grub
opened /etc/default/grub for editiing .. though really because of the previous chroot command, you're now really opening /mnt/etc/default/grub (and hence the version on the HDD and not the one from the USB stick
Code: [Select]
GRUB_GFXPAYLOAD_LINUX=text
Apply the fix mentioned in the bug report .. which is forcing the kernel to boot in text mode.
Code: [Select]
update-grub
updates the GRUB configuration so the changes are actually applied to the GRUB bootloader.

HTH :)

For a not very clear, but mildly entertaining explanation of "GRUB_GFXPAYLOAD_LINUX" see here:
http://www.gnu.org/software/grub/manual/grub/html_node/Simple-configuration.html#Simple-configuration
« Last Edit: May 18, 2018, 04:49:16 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline tbyoda

  • nOOb
  • *
  • Posts: 1
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8 Respin-2
Re: Booting Problem [Image inside]
« Reply #17 on: May 21, 2018, 01:37:49 am »
I've been that busy lately I've lost my train of thought and can't remember why I asked for that output :-[

I have noticed this is an N270 with intel 945G graphics chip .. so I'm wondering if this is that weird bug that affects netbooks with 1024x600 screens.

What exactly happens when you boot normally (after installation) .. is the screen all garbled ?

[EDIT]

Okay remembered :) .. try this....

Boot to the Peppermint 8 LiveUSB, open a terminal and run these commands in sequence:
Code: [Select]
sudo mount /dev/sda1 /mnt
(btw, that's a number 1 NOT a lower case L ;))

then:
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then:
Code: [Select]
sudo chroot /mnt
then:
Code: [Select]
nano /etc/default/grub
In nano, scroll to the bottom using down arrow key.

Add a NEW line at the bottom that reads:-
Code: [Select]
GRUB_GFXPAYLOAD_LINUX=text
then hit Ctrl+X .. then Y .. then Enter (to save and exit nano).

Back in the terminal, run:
Code: [Select]
update-grub
when that completes, hit Ctrl+D (to exit the chroot environment).

Now reboot to the HDD to test.



Hint - It may be easier to boot the LiveUSB, connect to the internet, visit this page, then you can copy/paste the commands into the terminal ;)
Thanks so much for this post, worked like a champ!

Rob


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22015
  • Karma: 2468
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: Booting Problem [Image inside]
« Reply #18 on: May 21, 2018, 07:18:24 pm »
You're most welcome Rob, glad it helped...

Oh, and welcome to the forum :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec