Choose style:

Author Topic: Works fine from flash drive BUT not after installed. [SOLVED - With Solution]  (Read 1422 times)

0 Members and 1 Guest are viewing this topic.

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #15 on: April 11, 2018, 02:37:56 pm »
Getting it from the installed version is not much of a problem but I can't plug in the two flash drives I have. USB ports are too close together to do them.

And then have to edit out everything other than what I posted already.

Does anyone have a clue as to what I need to do to fix the graphics issue?

Hate for her to throw away a workable laptop and buy one with Windows on it.

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #16 on: April 11, 2018, 02:41:10 pm »
I need to get the laptop working by Friday or she will just go buy a new one saturday.


Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21242
  • Karma: 2391
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Works fine from flash drive BUT not after installed.
« Reply #17 on: April 11, 2018, 02:57:22 pm »
Ignore my last post, you've already posted the info I was after .. somehow we've gotta stop the fbdev driver from being loaded, so it drops back to vesa.

looking....
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21242
  • Karma: 2391
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Works fine from flash drive BUT not after installed.
« Reply #18 on: April 11, 2018, 03:06:04 pm »
let's try something here:

Open a terminal and run:
Code: [Select]
sudo xed /etc/default/grub
find the line that reads:
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
SAVE the file and exit the text editor.

Back in the terminal run:
Code: [Select]
sudo update-grub
now REBOOT.

Once rebooted, post the output from:
Code: [Select]
inxi -G
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #19 on: April 11, 2018, 03:15:33 pm »
fbdev is still active
vesa is unloaded
will try it again

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #20 on: April 11, 2018, 03:16:53 pm »
nomodeset is in there as per your instructions.

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #21 on: April 11, 2018, 03:41:21 pm »
if fbdev was renamed or deleted, what will happen? Will linux default to vesa and then force me to reinstall fbdev?

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #22 on: April 11, 2018, 03:48:42 pm »
appending a kernel parameter at boot: vga=791

The vga parameter sets the framebuffer to VESA mode 791 (1024x768 16bit).

Will this work and how do I do that?

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #23 on: April 11, 2018, 03:57:02 pm »
Ok I added that parameter right after nomodeset. Saved, updated grub, rebooted, and it is FIXED!


Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21242
  • Karma: 2391
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Works fine from flash drive BUT not after installed.
« Reply #24 on: April 11, 2018, 04:16:44 pm »
Nice :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #25 on: April 11, 2018, 04:20:36 pm »
Btw I tried logging in as insane. It said 'please deposit 25 cents for the first 3 minutes....'
Go figure.

The problem is still an installer problem though IMHO.
And there is no way to easily fix the problem from a typical user perspective.

Perhaps add a suggestion to the developers regarding this problem?

Several other Linux versions need that fix as well.


Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21242
  • Karma: 2391
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Works fine from flash drive BUT not after installed.
« Reply #26 on: April 11, 2018, 04:27:43 pm »
It's more a problem with the VIA chipset and the S3 graphics driver being rubbish (and ridiculously old and no longer maintained) in Linux .. but that's what happens when the manufacturer doesn't open source their driver and there's not enough call for the community to bother creating/maintaining their own ;)

It's simple .. where manufacturers don't help and/or support Linux and open source, they should expect their hardware to be inferior in Linux.
« Last Edit: April 11, 2018, 04:31:37 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crazysquirrel

  • Jr. Member
  • **
  • Posts: 74
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8 - 32 bit
Re: Works fine from flash drive BUT not after installed.
« Reply #27 on: April 11, 2018, 04:29:45 pm »
Well with your help and some from the ubuntu site it got fixed!

Thank you!

You can mark the thread closed if desired.

Just wish there was a 32 bit version of opera....

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21242
  • Karma: 2391
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Works fine from flash drive BUT not after installed.
« Reply #28 on: April 11, 2018, 04:33:55 pm »
It's for you to mark topics (SOLVED) when you consider them so my mate ;)

You can mark your topic (SOLVED) by editing the FIRST posting in the topic and changing:-

Subject: Works fine from flash drive BUT not after installed. (SOLVED)

TIA :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 21242
  • Karma: 2391
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin & 9 Alpha
Re: Works fine from flash drive BUT not after installed. [SOLVED]
« Reply #29 on: April 11, 2018, 04:39:09 pm »
Thanks for marking the topic solved, and for providing your solution so it can benefit others :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec