Choose style:

Author Topic: Wireless connection  (Read 2404 times)

0 Members and 1 Guest are viewing this topic.

Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Wireless connection
« on: March 26, 2018, 11:39:16 pm »
I have Peppermint 8 respin 2 installed on an intel compute stick  stck1a32wfc.  The internal wireless adapter is Realtek RTL8723BS Wireless LAN 802.11n SDIO Network Adapter - neither pci or usb.  I cannot get this to work.  "# iw dev" returns "Interface wlan0/ifindex 2/wdev 0x1/addr 28:c2:dd:60:60:c5/type managed"
"ip link show wlan0" returns "2. wlan0. <BROADCAST,MULTICAST>mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000"
"ip link set wlan0 up" returns "RTNETLINK answers: Operation not permitted"

I have been unable to get any further so have had to resurt to a dlink usb adapter to get on the air.  It would be nice to get the internal adapter working.  Help please!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26257
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wireless connection
« Reply #1 on: March 27, 2018, 07:29:32 am »
How did you install Peppermint on the ComputeStick ? .. was it a Linuxium build ?

Can you post the output from:
Code: [Select]
sudo lshw -C network
and
Code: [Select]
lspci -vnn | grep -i net
and
Code: [Select]
iwconfig
and
Code: [Select]
ifconfig
and
Code: [Select]
iwlist scan
and
Code: [Select]
rfkill list
and
Code: [Select]
dmesg | grep firmware
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wireless connection
« Reply #2 on: March 27, 2018, 04:31:30 pm »
Many thanks for the help.  No, it was the standard download from Peppermint.  I have put the output that you asked for into a file "forum-reply" but cannot figure out how to attach it so I have just copied it below

Code: [Select]
john@john-STCK1A32WFC ~ $ sudo su
[sudo] password for john:
root@john-STCK1A32WFC /home/john # lshw -C network
  *-network:0             
       description: Wireless interface
       physical id: 1
       bus info: usb@1:1.1.4
       logical name: wlx1c5f2b9b5789
       serial: 1c:5f:2b:9b:57:89
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=4.15.10 firmware=0.29 ip=192.168.0.102 link=yes multicast=yes wireless=IEEE 802.11
  *-network:1 DISABLED
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 28:c2:dd:60:60:c5
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs multicast=yes wireless=unassociated
Code: [Select]
root@john-STCK1A32WFC /home/john # lspci -vnn | grep -i net
Code: [Select]
root@john-STCK1A32WFC /home/john # iwconfig
wlx1c5f2b9b5789  IEEE 802.11  ESSID:"TP-LINK_382C2C" 
          Mode:Managed  Frequency:2.452 GHz  Access Point: A0:F3:C1:38:2C:2C   
          Bit Rate=180 Mb/s   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-39 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:135   Missed beacon:0

wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.
Code: [Select]
root@john-STCK1A32WFC /home/john # ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:160 errors:0 dropped:0 overruns:0 frame:0
          TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13970 (13.9 KB)  TX bytes:13970 (13.9 KB)

wlx1c5f2b9b5789 Link encap:Ethernet  HWaddr 1c:5f:2b:9b:57:89 
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::1a3d:ee15:f17c:9884/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2832 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1895 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2709972 (2.7 MB)  TX bytes:212143 (212.1 KB)

Code: [Select]
root@john-STCK1A32WFC /home/john # iwlist scan
wlx1c5f2b9b5789  Scan completed :
          Cell 01 - Address: A0:F3:C1:38:2C:2C
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=70/70  Signal level=-37 dBm 
                    Encryption key:on
                    ESSID:"TP-LINK_382C2C"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000002cd0fbc621
                    Extra: Last beacon: 8ms ago
                    IE: Unknown: 000E54502D4C494E4B5F333832433243
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030109
                    IE: Unknown: 2A0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1AEF1103FFFF0000000000000000000000000000000406E6E70D00
                    IE: Unknown: 331AEF1103FFFF0000000000000000000000000000000406E6E70D00
                    IE: Unknown: 3D1609071300000000000000000000000000000000000000
                    IE: Unknown: 341609071300000000000000000000000000000000000000
                    IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD9E0050F204104A0001101044000102103B00010310470010000102030405060708090A0B0C0D0E0F1021000754502D4C494E4B10230009544C2D4D523334323010240003312E3010420003312E301054000800060050F20400011011001E576972656C657373204E2033472F344720526F75746572204D5233343230100800020086103C000101104900140024E26002000101600000020001600100020001
          Cell 02 - Address: 32:CD:A7:3E:D1:49
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=53/70  Signal level=-57 dBm 
                    Encryption key:on
                    ESSID:"DIRECT-irM2070 Series"
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000001d1f159a57
                    Extra: Last beacon: 8ms ago
                    IE: Unknown: 00154449524543542D69724D3230373020536572696573
                    IE: Unknown: 01088C1218243048606C
                    IE: Unknown: 030109
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD09001018020100040000
                    IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
                    IE: Unknown: DD050050F20500
                    IE: Unknown: DD800050F204104A0001101044000102103B0001031047001016A65700007C1000BB4932CDA73ED1491021000842726F6164636F6D10230006536F66744150102400013010420001301054000800060050F20400011011000C4D3230373020536572696573100800020008103C0001011049000E00372A0001200106FFFFFFFFFFFF

wlan0     No scan results

lo        Interface doesn't support scanning.

Code: [Select]
root@john-STCK1A32WFC /home/john # rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
2: phy1: Wireless LAN
Soft blocked: no
Hard blocked: no
root@john-STCK1A32WFC /home/john # dmesg | grep firmware
[   25.931855] platform regulatory.0: Direct firmware load for regulatory.db failed with error -2
[   42.683415] rtl8723bs mmc0:0001:1: Direct firmware load for rtlwifi/rtl8723bs_nic.bin failed with error -2
[   42.683420] Request firmware failed with error 0xfffffffe
[   47.780259] ieee80211 phy1: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
[   48.076572] ieee80211 phy1: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29
root@john-STCK1A32WFC /home/john # exit
exit
Again many thanks.

« Last Edit: March 27, 2018, 08:22:19 pm by AndyInMokum, Reason: Encapsulating output with [code] »

Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wireless connection
« Reply #3 on: March 27, 2018, 07:05:52 pm »
My apologies, the output that I sent was actually from a home build of kernel 4.15.  I forgot that I had modified it.  The output from the Peppermint kernel 4.13 follows.

Code: [Select]
john@john-STCK1A32WFC ~ $ sudo su
[sudo] password for john:
root@john-STCK1A32WFC /home/john # lshw -C network
  *-network:0 DISABLED   
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 28:c2:dd:60:60:c5
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs multicast=yes wireless=unassociated
  *-network:1
       description: Wireless interface
       physical id: 2
       bus info: usb@1:1.1.4
       logical name: wlx1c5f2b9b5789
       serial: 1c:5f:2b:9b:57:89
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=4.13.0-37-generic firmware=0.29 ip=192.168.0.102 link=yes multicast=yes wireless=IEEE 802.11
Code: [Select]
root@john-STCK1A32WFC /home/john # lspci -vnn | grep -i net
Code: [Select]
root@john-STCK1A32WFC /home/john # iwconfig
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

wlx1c5f2b9b5789  IEEE 802.11  ESSID:"TP-LINK_382C2C" 
          Mode:Managed  Frequency:2.452 GHz  Access Point: A0:F3:C1:38:2C:2C   
          Bit Rate=180 Mb/s   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-37 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:115   Missed beacon:0

Code: [Select]
root@john-STCK1A32WFC /home/john # ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:143 errors:0 dropped:0 overruns:0 frame:0
          TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:13127 (13.1 KB)  TX bytes:13127 (13.1 KB)

wlx1c5f2b9b5789 Link encap:Ethernet  HWaddr 1c:5f:2b:9b:57:89 
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::1a3d:ee15:f17c:9884/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:818 errors:0 dropped:0 overruns:0 frame:0
          TX packets:791 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:371492 (371.4 KB)  TX bytes:112316 (112.3 KB)

Code: [Select]
root@john-STCK1A32WFC /home/john # iwlist scan
wlan0     No scan results

lo        Interface doesn't support scanning.

wlx1c5f2b9b5789  Scan completed :
          Cell 01 - Address: A0:F3:C1:38:2C:2C
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=70/70  Signal level=-37 dBm 
                    Encryption key:on
                    ESSID:"TP-LINK_382C2C"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000002ed92adf2c
                    Extra: Last beacon: 64ms ago
                    IE: Unknown: 000E54502D4C494E4B5F333832433243
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030109
                    IE: Unknown: 2A0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1AEF1103FFFF0000000000000000000000000000000406E6E70D00
                    IE: Unknown: 331AEF1103FFFF0000000000000000000000000000000406E6E70D00
                    IE: Unknown: 3D1609071300000000000000000000000000000000000000
                    IE: Unknown: 341609071300000000000000000000000000000000000000
                    IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD9E0050F204104A0001101044000102103B00010310470010000102030405060708090A0B0C0D0E0F1021000754502D4C494E4B10230009544C2D4D523334323010240003312E3010420003312E301054000800060050F20400011011001E576972656C657373204E2033472F344720526F75746572204D5233343230100800020086103C000101104900140024E26002000101600000020001600100020001
          Cell 02 - Address: 32:CD:A7:3E:D1:49
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=57/70  Signal level=-53 dBm 
                    Encryption key:on
                    ESSID:"DIRECT-irM2070 Series"
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000001f26a2de74
                    Extra: Last beacon: 64ms ago
                    IE: Unknown: 00154449524543542D69724D3230373020536572696573
                    IE: Unknown: 01088C1218243048606C
                    IE: Unknown: 030109
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD09001018020100040000
                    IE: Unknown: DD180050F2020101830003A4000027A4000042435E0062322F00
                    IE: Unknown: DD050050F20500
                    IE: Unknown: DD800050F204104A0001101044000102103B0001031047001016A65700007C1000BB4932CDA73ED1491021000842726F6164636F6D10230006536F66744150102400013010420001301054000800060050F20400011011000C4D3230373020536572696573100800020008103C0001011049000E00372A0001200106FFFFFFFFFFFF

Code: [Select]
root@john-STCK1A32WFC /home/john # rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy1: Wireless LAN
Soft blocked: no
Hard blocked: no
Code: [Select]
root@john-STCK1A32WFC /home/john # dmesg | grep firmware
[   40.400900] rtl8723bs mmc0:0001:1: Direct firmware load for rtlwifi/rtl8723bs_nic.bin failed with error -2
[   40.400905] Request firmware failed with error 0xfffffffe
[   51.438422] ieee80211 phy1: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
[   51.585541] ieee80211 phy1: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29
root@john-STCK1A32WFC /home/john # exit
exit
From my untrained perspective,I can't see any significant difference but maybe there is to the initiated.

« Last Edit: March 27, 2018, 08:25:42 pm by AndyInMokum, Reason: Encapsulating output with [code] »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Wireless connection
« Reply #4 on: March 27, 2018, 09:08:29 pm »
HI polly, how’s it going :)?  I see you've been registered since last year and this is your first post  :o.  I have to say a big welcome to the Peppermint  Forum, what took you so long :))

For future reference, could you please remember to encapsulate all terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  If you’re a Chromium Browser and/or a Google Chrome user, please don't combine these functions.  For some reason they don’t work well together with these browsers.  Only use one or the other  ;).  These forum functions preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to check how it'll look in the forum.  This time, I've done it for you - many thanks  ;).

I see you're dropping down to root user.  I have to strongly recommend you don't do this, UNLESS IT IS ABSOLUTELY NECESSARY.  It's a very bad and potentially dangerous habit you're developing!!   You're leaving yourself exposed to all kinds of very serious problems, ranging from user error, to malicious input from wandering hands  :-XPeppermint utilises sudo to minimize the problems caused by dropping to root.  For example, you don't want to be using root when making edits, or changes to the contents of your /home folder.  You'll end up giving root ownership of your configuration files and have all kinds of problems with permissions.  Using sudo, you'll be asked if you want to continue as reminder warning to what your doing.  As root you won't receive any kind of warning or signal.  It assumes you want to execute everything you enter.  It's absolutely brutal  :'(.  When entering commands into the terminal, please enter them as asked, or better still, copy & paste them.  It'll minimize mistakes that can cause huge problems.  Please remember, even though the volunteers here in the forum are really very competent.  They're also humans and can also make mistakes.  These mistakes may cause serious damage to your system, if you've dropped to root  ;).
« Last Edit: March 27, 2018, 09:24:14 pm by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26257
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wireless connection
« Reply #5 on: March 27, 2018, 09:42:48 pm »
As Andy suggests .. don't drop to a root prompt with "sudo su" unless you absolutely need to (which is pretty much never), not only is is a security risk and bad practice, but it could also screw up the config files for some graphical applications.

A root prompt might also not give the same output as a regular prompt .. certainly if a command contained "~/" you'd actually be working in the wrong directory.



Try this with an active internet connection...

Open a terminal (do NOT change to a root prompt) and run the following commands in sequence:
Code: [Select]
sudo apt-get install git
then
Code: [Select]
mkdir ~/rtl8723bs
then
Code: [Select]
cd ~/rtl8723bs
then
Code: [Select]
git clone https://github.com/hadess/rtl8723bs.git
then
Code: [Select]
cd ~/rtl8723bs/rtl8723bs
then
Code: [Select]
sudo make install
then
Code: [Select]
sudo depmod -a
now REBOOT.

Does the internal wireless work now ?

If not, post the output from:
Code: [Select]
sudo lshw -C network
and
Code: [Select]
dmesg | grep firmware
again
« Last Edit: March 27, 2018, 09:52:20 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wireless connection
« Reply #6 on: March 28, 2018, 10:39:58 pm »
Thank you for reminding me of the correct usage of sudo.  I have been using Kali Linux recently and as it only creates a root user on installation, I have become slack in the use of sudo in Ubuntu based distributions.

I had already inserted the module r8723bs.ko into the 4.13.0-37 kernel and made it permanent, so I removed it before installing from github.   At least, that is what I believe I did. The output that you asked for follows below and i hope that I have managed to format it correctly.

Code: [Select]
john@john-STCK1A32WFC ~ $ sudo lshw -C network
[sudo] password for john:
  *-network:0             
       description: Wireless interface
       physical id: 1
       bus info: usb@1:1.1.4
       logical name: wlx1c5f2b9b5789
       serial: 1c:5f:2b:9b:57:89
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=4.13.0-37-generic firmware=0.29 ip=192.168.0.102 link=yes multicast=yes wireless=IEEE 802.11
  *-network:1
       description: Wireless interface
       physical id: 2
       logical name: wlan0
       serial: 28:c2:dd:60:60:c5
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs multicast=yes wireless=unassociated
john@john-STCK1A32WFC ~ $ dmesg | grep firmware
[   47.193774] ieee80211 phy1: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
[   47.273660] ieee80211 phy1: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.29
john@john-STCK1A32WFC ~ $

I still cannot get connected with wlan0?

Andy asked why it had taken me so long to post something.  I never feel confidant that I am asking the right question, hence i tend to fiddle around until I find someone else with the same problem and try to understand their answers.  I seem to be perpetually in linux101 and as fast as I learn something new, something old gets forgotten - enough waffle.


Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Wireless connection
« Reply #7 on: March 29, 2018, 12:21:38 am »
I figured it had to be something like that.  Kali and Puppy Linux will get you into that habit.  It's understandable why with Kali  ;D.

Please use the forum as you need it.  It's as much part of the distro as the distro itself  ;).  All question are relevant and we'll figure everything out.  That's why we're here.  You can see we don't bite.  We might occasionally growl slightly, never bite though :D.
« Last Edit: March 29, 2018, 01:02:13 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26257
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wireless connection
« Reply #8 on: March 29, 2018, 09:39:24 am »
Do you know how to blacklist the rt2800usb driver, and modprobe rtl8723bs instead ?

The github instructions only installed the missing firmware, not the driver itself .. which you already had.
« Last Edit: March 29, 2018, 09:41:05 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wireless connection
« Reply #9 on: March 29, 2018, 10:10:20 pm »
Partial success--
No, I don't know how to blacklist the rt2800usb driver, my method has been to pull out the device before booting.  Thanks for the info. on what the github instructions did, that makes things a lot clearer (in my head) about what is going on.
In the meantime, thinking that all my tinkering had upset something,  I reinstalled Peppermint and updated/upgraded it, then applied the github instructions.
Lo and behold, wlan0 woke up and connected.  I was then able to pull out the dlink adapter (rt2800usb) and still connect.  The github instructions must also have installed the missing firmware on the previous kernel 4.13.0-32 because it now works as well.  So I thought everything must be fixed but not so, as occasionally, the link disconnects and the only way that I can get it back up is by rebooting the computer.  That must have something to do with the blacklisting etc?
I would be grateful for your further advice.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26257
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wireless connection
« Reply #10 on: March 30, 2018, 08:34:29 am »
What's the output from:
Code: [Select]
lsmod | grep 8723
and
Code: [Select]
sudo lshw -C network
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wireless connection
« Reply #11 on: March 30, 2018, 05:34:25 pm »
As follows:
Code: [Select]
john@john-STCK1A32WFC ~ $ lsmod | grep 8723
r8723bs               610304  0
cfg80211              614400  1 r8723bs
john@john-STCK1A32WFC ~ $ sudo lshw -C network
[sudo] password for john:
  *-network               
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 28:c2:dd:60:60:c5
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs ip=192.168.0.101 multicast=yes wireless=IEEE 802.11bgn
john@john-STCK1A32WF

When the link was down, the output from the latter command was

Code: [Select]
john@john-STCK1A32WFC ~ $ sudo lshw -C network
[sudo] password for john:
  *-network               
       description: Wireless interface
       physical id: 1
       logical name: wlan0
       serial: 28:c2:dd:60:60:c5
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723bs multicast=yes wireless=unassociated
john@john-STCK1A32WFC ~ $

I should mention that after the link had dropped twice in the space of half an hour, the computer then ran without incident for the remainder of the day.


Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wireless connection
« Reply #12 on: April 03, 2018, 11:47:07 pm »
I think that this problem should be marked as 'solved'.  The wifi link has dropped out a few times since I wrote last but I think it can be put down to the stick computer getting too hot.  I live in a hot place.

Thank you so much for solving this problem for me - for transforming a  useless adapter into a working one and for increasing my knowledge vastly.

I can now add peppermint linux to my list of distributions which work 'out of the box'.  It is only a short list for this tricky beast.

Again, many thanks
polly

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Wireless connection
« Reply #13 on: April 04, 2018, 01:28:26 am »
Hi polly, before we mark this up as [SOLVED], I've a idea.  I had a similar problem with the WiFi dropping out all the time.  The following steps resolved it on the two machines I was having problems.   

I see you've already run:
Code: [Select]
iwconfig
There was a line in the output that read:
Code: [Select]
Power Management:on
We need to get that to read off.  Run, (Copy & Paste) the following command in the terminal window:
Code: [Select]
gksudo xed /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
In the text file that opens, you'll see:
Code: [Select]
[connection]
wifi.powersave = 3
Change the value to 2.  Save, (Ctrl+s) and quit, (Ctrl+q) the text editor.  Reboot your machine and check the change by running, (Copy & Paste):
Code: [Select]
iwconfig
There should be a line:
Code: [Select]
Power Management:off
This indicates the WiFi Power Manager is now disabled.  Test the WiFi by playing the waiting game   ;D.  Hopefully the WiFi will stay on  ;)

You can also set the Network Manager to ignore IPv6.  To do that, Right Click on the WiFi panel icon.  From the Popup Menu, select:

Edit Connections...

Make sure your WiFi connection is highlighted and click on Edit in the right side column.  In the new window, from the tabs, select:

IPv6

In the sub-heading:

Method

Select from the drop down menu:

Ignore

Click on Save followed by Close.   Log out and back in.  If you only use WiFi, you can delete the default Ethernet account.  Having that sometimes confuses the Network Manager  >:(.  If you feel the issue had been resolved, could you please mark the topic as [SOLVED] in the subject line of the original post.  I hope this helps  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline polly

  • nOOb
  • *
  • Posts: 19
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wireless connection
« Reply #14 on: April 04, 2018, 06:41:04 pm »
Hi Andy.  Now here is a bit of a puzzle.  As booted, I ran
Code: [Select]
john@john-STCK1A32WFC ~ $ iwconfig
wlan0     IEEE 802.11bgn  ESSID:"TP-LINK_382C2C"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.432 GHz  Access Point: A0:F3:C1:38:2C:2C   
          Bit Rate:150 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=100/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

and then
Code: [Select]
john@john-STCK1A32WFC ~ $ gksudo xed /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
and got in the file
Code: [Select]
[connection]
wifi.powersave = 3

Some other action has turned power management off before I had the chance.
I shall keep on playing the waiting game.