Choose style:

Author Topic: ALT key conflict  (Read 940 times)

0 Members and 1 Guest are viewing this topic.

Offline Teage

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
ALT key conflict
« on: March 15, 2018, 07:14:31 am »
Hi guys/gals, I'm trying to disable my ALT key and use the SUPER key instead. I need ALT for Blender and Synfig. I used to do this by editing rc.xml on crunchbang. Is there a similar file on Peppermint? I tried the control center but all I have found are keyboard shortcuts and such but not actual key bindings. I have found an xfwm4.xml but does not seem to be what I need. Any help would be greatly appreciated. Thank you..

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: ALT key conflict
« Reply #1 on: March 15, 2018, 10:41:22 am »
Do you mean you're trying to remove ALT from any keybindings ?

Code: [Select]
~/.config/peppermint-control-center/xbindkeys.conf
is where keybindings are stored

[EDIT]

This may be of interest
https://forum.peppermintos.com/index.php/topic,6699.msg67996.html#msg67996

[EDIT2]

Or am I completely misunderstanding what you're trying to do ?
« Last Edit: March 15, 2018, 10:44:51 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1999
  • Karma: 344
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: ALT key conflict
« Reply #2 on: March 15, 2018, 10:49:49 am »
Do you just want to remap Super to function as Alt?

Offline Teage

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: ALT key conflict
« Reply #3 on: March 15, 2018, 10:57:02 am »
Alt + left click moves the window by default but that is no good when using certain programs that use the alt key for various tasks. I want to remove alt and if possible replace with the super key instead. . I just do not see the binding for ALT+L in keyboard shortcuts from the control center. I do however see another binding for move window ALT+F8 but that is not the right one. I need to disable ALT+L mouse click. Thanks.

Offline Teage

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: ALT key conflict
« Reply #4 on: March 15, 2018, 10:58:35 am »
Do you just want to remap Super to function as Alt?


............Yes I don't see why that wouldn't work. As long as it frees up the ALT key that would be great.

Offline Teage

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: ALT key conflict
« Reply #5 on: March 15, 2018, 11:04:44 am »
Do you mean you're trying to remove ALT from any keybindings ?

Code: [Select]
~/.config/peppermint-control-center/xbindkeys.conf
is where keybindings are stored

[EDIT]

This may be of interest
https://forum.peppermintos.com/index.php/topic,6699.msg67996.html#msg67996

[EDIT2]

Or am I completely misunderstanding what you're trying to do ?

...I'm going to try your suggestion. I will let you know how goes. thank ya!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: ALT key conflict
« Reply #6 on: March 15, 2018, 11:39:43 am »
Okay you might want to take a look at the system-wide xfce keybindings at:-
Code: [Select]
xed /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
and if exists the user specific copy at:-
Code: [Select]
xed ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
both of which contain the custom properties keybindings .. such as:-
Code: [Select]
<property name="<Alt>F8" type="string" value="resize_window_key"/>
which you might want to change to say
Code: [Select]
<property name="<Super>F8" type="string" value="resize_window_key"/>
or just disable it with
Code: [Select]
<property name="<Alt>F8" type="empty"/>
« Last Edit: March 15, 2018, 11:49:25 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec