Choose style:

Author Topic: VPN requires my login password for each new session.  (Read 502 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4785
  • Karma: 999
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
VPN requires my login password for each new session.
« on: March 12, 2018, 02:45:43 am »
Hi all, how's it going?  Here's my inxi -Fz:
Code: [Select]
andy@andy-Latitude-D430 ~ $ inxi -Fz
System:    Host: andy-Latitude-D430 Kernel: 4.13.0-36-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: Dell (portable) product: Latitude D430
           Mobo: Dell model: 0XW631 Bios: Dell v: A09 date: 01/04/2010
CPU:       Dual core Intel Core2 U7600 (-MCP-) cache: 2048 KB
           clock speeds: max: 1200 MHz 1: 1200 MHz 2: 800 MHz
Graphics:  Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller
           Display Server: X.Org 1.19.5 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x800@59.98hz
           GLX Renderer: Mesa DRI Intel 945GM GLX Version: 1.4 Mesa 17.0.2
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
Network:   Card-1: Broadcom Limited NetXtreme BCM5752 Gigabit Ethernet PCI Express
           driver: tg3
           IF: enp9s0 state: down mac: <filter>
           Card-2: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlp12s0 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (49.0% used)
           ID-1: /dev/sda model: CHN_mSATA02M_256 size: 256.1GB
           ID-2: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 30G used: 13G (44%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 66.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 171 Uptime: 8:41 Memory: 834.0/1984.5MB
           Client: Shell (bash) inxi: 2.2.35
andy@andy-Latitude-D430 ~ $
I'm having a problem with my VPN service needing my login keyring password with nearly every new session of Peppermint.  I've tried creating new keyrings by renaming/deleting the current ones:
Code: [Select]
cp -rv ~/.local/share/keyrings ~/.local/share/keyrings.old
or
Code: [Select]
rm -rv ~/.local/share/keyrings
On accessing the VPN, I receive the expected: Unlock Login Keyring request.  After a couple or so reboots, the message starts to reappear.  It's got me baffled  :-\.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22389
  • Karma: 2500
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: VPN requires my login password for each new session.
« Reply #1 on: March 12, 2018, 11:16:48 am »
What are you entering as the "login keyring" password when you delete the keyring and start afresh ?

I'm going to guess you're entering either your Peppermint password or your VPN password ? .. if you use autologin for Peppermint, you should leave the keyring BLANK when you first create it.

Having a BLANK keyring password is the ONLY way to not be prompted for a keyring password on systems that autologin .. because the login password was never entered ;)
« Last Edit: March 12, 2018, 11:19:03 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline anselm

  • Jr. Member
  • **
  • Posts: 34
  • Karma: 11
  • New Forum User
    • View Profile
  • Peppermint version(s): 8.5(64 bit)
Re: VPN requires my login password for each new session.
« Reply #2 on: March 12, 2018, 08:17:41 pm »
I'm having this problem also, very sporadic.
I don' use auto login to login into peppermint. I have pia manger set to auto login.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4785
  • Karma: 999
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: VPN requires my login password for each new session.
« Reply #3 on: March 12, 2018, 08:51:16 pm »
What are you entering as the "login keyring" password when you delete the keyring and start afresh ?

I'm going to guess you're entering either your Peppermint password or your VPN password ? .. if you use autologin for Peppermint, you should leave the keyring BLANK when you first create it.

Having a BLANK keyring password is the ONLY way to not be prompted for a keyring password on systems that autologin .. because the login password was never entered ;)

No I don't auto login to Peppermint.  I know which login prompt you'r talking about.  It's the one that complains bitterly if you leave it blank.  I don't get that one.  I wish I did.  I'd leave it blank and click okay.  This is the one that pops up when I try to start the VPN:

Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22389
  • Karma: 2500
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: VPN requires my login password for each new session.
« Reply #4 on: March 13, 2018, 07:29:51 am »
Which VPN do you use, so I can test their client .. or are you just using networkmanager ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4785
  • Karma: 999
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: VPN requires my login password for each new session.
« Reply #5 on: March 13, 2018, 09:19:38 am »
Which VPN do you use, so I can test their client .. or are you just using networkmanager ?

I'm using VPN.HT: https://vpn.ht/.  It has no client and uses OpenVPN installed to the Network Manager.  Here's a link to the starters guide: VPN.HT STARTER GUIDE  I installed the version for GNOME:
Code: [Select]
sudo apt-get install network-manager-openvpn-gnome
It uses crt.crt files as CA Certificate.  The rest is adding your account details into the network manager and choosing either the default VPN location, (somewhere in California), or generating an alternative location vpn.ht file from the tool on their website: https://vpn.ht/servers.  The VPN works flawlessly.  It's only the keyrings seem to get corrupted somehow  :-\?
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 22389
  • Karma: 2500
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R and 9
Re: VPN requires my login password for each new session.
« Reply #6 on: March 13, 2018, 10:47:39 am »
Have you tried disabling the gnome-keyring-daemon by unticking these 3 services:-

Certificate and Key Storage
SSH Key Agent
Secret Storage Service


In Default applications for LXSession (Autostart tab)

Then rebooting.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4785
  • Karma: 999
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: VPN requires my login password for each new session.
« Reply #7 on: March 13, 2018, 02:45:15 pm »
Have you tried disabling the gnome-keyring-daemon by unticking these 3 services:-

Certificate and Key Storage
SSH Key Agent
Secret Storage Service


In Default applications for LXSession (Autostart tab)

Then rebooting.

No I haven't, however on checking, they're all disabled by default.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.