Choose style:

Author Topic: hp-check and printer problem[SOLVED]  (Read 1370 times)

0 Members and 1 Guest are viewing this topic.

Offline arash

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
hp-check and printer problem[SOLVED]
« on: March 07, 2018, 11:44:15 am »
recently i started to use use my hp laserjest 1020 printer and that was not working i opened terminal and inserted hp-check to see if there was a problem whit my drivers and etc and this was hp-check output
Code: [Select]
Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible
error: 'libdbus-1-dev' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'openssl' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libjpeg8-dev' package is missing/incompatible
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp-mibs-downloader' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'libtool' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible
error: 'avahi-utils' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Total Errors: 16
Total Warnings: 0

and after that i decided to install this packages manually but this was the problem when i used to install them
for example the first package in erors
Code: [Select]
sudo apt install libcups2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcups2 is already the newest version (2.1.3-4ubuntu0.4).
libcups2 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
so what is the problem :( :( :(
« Last Edit: March 08, 2018, 10:21:33 am by arash »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25451
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: hp-check and printer problem
« Reply #1 on: March 07, 2018, 03:58:47 pm »
Run:
Code: [Select]
sudo apt-get install python-dev libcups2-dev cups-bsd cups-client libtool libtool-bin libcupsimage2-dev libjpeg-dev openssl libsnmp-dev snmp-mibs-downloader python-qt4-dbus gtk2-engines-pixbuf python-qt4 libsane-dev python3-pyqt4 gtk2-engines-pixbuf python3-dev avahi-utils gtk2-engines-pixbuf xsane xsane-common python3-dbus.mainloop.qt python3-notify2  libusb-1.0.0-dev libjpeg8-dev
then
Code: [Select]
hp-check
« Last Edit: March 07, 2018, 04:05:38 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arash

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: hp-check and printer problem
« Reply #2 on: March 07, 2018, 11:19:23 pm »
thanks now all packages are good but printer still is not working i have this warning from hp-check
Code: [Select]
Hewlett-Packard-HP-LaserJet-1020
--------------------------------
Type: Unknown
Device URI: usb://HP/LaserJet%201020?serial=JL0G22T
PPD: /etc/cups/ppd/Hewlett-Packard-HP-LaserJet-1020.ppd
warning: Failed to read /etc/cups/ppd/Hewlett-Packard-HP-LaserJet-1020.ppd ppd file
PPD Description:
Printer status: printer Hewlett-Packard-HP-LaserJet-1020 is idle.  enabled since ‫پنجشنبه ۰۸ مارس ۱۸، ۰۷:۵۷:۰۵‬
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.
and this warning to
Code: [Select]
HPLIP-Version: HPLIP 3.16.3
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  8 version
and this is another warning
Code: [Select]
warning: peppermint distro is not found in AUTH_TYPES
warning: linuxmint-8 version is not supported. Using linuxmint-17.3 versions dependencies to verify and install...
help please
« Last Edit: March 08, 2018, 04:49:33 am by arash »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25451
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: hp-check and printer problem
« Reply #3 on: March 08, 2018, 08:13:04 am »
Have you tried deleting all printers in

Code: [Select]
Menu > Preferences > Printers

Then installing
Code: [Select]
sudo apt-get install hplip-gui
then configuring your printer via the HPLIP Toolbox you'll now find in the menu ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arash

  • nOOb
  • *
  • Posts: 9
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: hp-check and printer problem
« Reply #4 on: March 08, 2018, 10:21:06 am »
thank you are number one now every thing works fine

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25451
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: hp-check and printer problem[SOLVED]
« Reply #5 on: March 08, 2018, 11:26:58 am »
Great news, happy to hear you got it working...

And thanks for marking the topic (SOLVED) :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec