Choose style:

Author Topic: numlock (SOLVED)  (Read 3265 times)

0 Members and 1 Guest are viewing this topic.

Offline richardmaurice

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 4
numlock (SOLVED)
« on: July 16, 2014, 07:32:20 am »
Hi,
I have just installed Peppermint 5, previously used ubuntu but wanted something more cloud based. I am a  newbie and don't know very much about computers at all. When I start my computer, the numlock on my keyboard is not on. Having done a little research I have (I think) found that I need numlockx. So went onto software manager searched for it and found it - 2 versions, one just numlockx , one is i386. Bein unsure as to which one to use, I tried one and then the other, neither worked. I then went onto Synaptic package manager again the same 2 choices, tried them both still not working.  Any ideas ? Please ! !
« Last Edit: July 20, 2014, 03:21:26 pm by PCNetSpec, Reason: Marked as (SOLVED) »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: numlock
« Reply #1 on: July 18, 2014, 03:33:30 pm »
First let's uninstall / reinstall numlockx
Code: [Select]
sudo apt remove numlockx*
then
Code: [Select]
sudo apt install numlockx
Now run:
Code: [Select]
sudo gedit /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
it should read something like:
Code: [Select]
[SeatDefaults]
greeter-session=lightdm-gtk-greeter
add a new line at the bottom so it now reads:-
Code: [Select]
[SeatDefaults]
greeter-session=lightdm-gtk-greeter
greeter-setup-script=/usr/bin/numlockx on
SAVE the file .. reboot to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline richardmaurice

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 4
Re: numlock
« Reply #2 on: July 19, 2014, 07:37:17 am »
Hi, thanks for the help but it didn't work  :-\ I uninstalled and re-installed with no problem. When I came to the 'sudo gedit /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf' the terminal put up this message:
** (gedit:2135): WARNING **: Could not load Gedit repository: Typelib file for namespace 'GtkSource', version '3.0' not found
It then paused for a moment before opening the gedit  file. So I added the text as a separate line , saved, and then closed everything down and rebooted. Still no numlock at start up ( I can do it manually no problems). So I went back to  gedit /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf and the extra line was there, saved no problems - just the numlockx is not working.
 

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: numlock
« Reply #3 on: July 19, 2014, 09:53:39 am »
OK, remove that line from /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf'.

Now do you want numlockx to be enabled system wide (all user accounts) at the time your desktop starts
(will still be off at the login screen)

If so, run
Code: [Select]
sudo gedit /etc/default/numlockx

And change the line:-

NUMLOCK=auto

to

NUMLOCK=on

SAVE the file, then log offf/on to test.

--
« Last Edit: July 19, 2014, 10:13:20 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline richardmaurice

  • nOOb
  • *
  • Posts: 11
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 4
Re: numlock
« Reply #4 on: July 20, 2014, 02:49:45 pm »
That did the trick - now working fine. Many thanks for your help
« Last Edit: July 20, 2014, 03:20:42 pm by PCNetSpec »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: numlock
« Reply #5 on: July 20, 2014, 03:00:06 pm »
You're most welcome :)

Can I ask that you mark the FIRST posting in this topic as (SOLVED) not the last one .. or the title doesn't change to (SOLVED) in the forum menus.

Thanks in advance.

[EDIT]

I've done this one for you ;)
« Last Edit: July 20, 2014, 03:20:16 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec