Choose style:

Author Topic: UEFI boot ... or not [SOLVED]  (Read 893 times)

0 Members and 1 Guest are viewing this topic.

Offline Tea

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
UEFI boot ... or not [SOLVED]
« on: February 02, 2018, 03:19:37 pm »
I installed Pep 8 to my uefi Win 10 laptop as dual boot (secure boot off) all worked well and I was happily as the proverbial, for several days.
However I checked some settings in the bios but did not change anything and now peppermint wont boot  and automatically boots windows.  :-\  I can F12 into the Hardware boot menu and select Ubuntu and grub starts and continues on to boot PEP8... 

Machine:   System: TOSHIBA (portable) product: SATELLITE C50-A-19T v: PSCG6E-08F01CEN
           Mobo: Intel model: PT10F v: Type2 - Board Version
           Bios: Insyde v: 1.40 date: 04/22/2014

steve@Lappydo ~ $ sudo fdisk -l
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 8A17FA0B-1E3C-11E3-BDCF-D6876A21C194

Device         Start       End   Sectors   Size Type
/dev/sda1       2048   2099199   2097152     1G Windows recovery environment
/dev/sda2    2099200   2566143    466944   228M EFI System
/dev/sda3    2566144 206164950 203598807  97.1G Microsoft basic data
/dev/sda4  644661248 976773119 332111872 158.4G Microsoft basic data
/dev/sda5  206166016 636528639 430362624 205.2G Linux filesystem
/dev/sda6  636528640 644661247   8132608   3.9G Linux swap

steve@Lappydo ~ $ efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0004,0001,2003,2001,2002
Boot0001* Ubuntu
Boot0002* EFI Network 0 for IPv6 (0C-54-A5-1C-EE-4A)
Boot0003* EFI Network 0 for IPv4 (0C-54-A5-1C-EE-4A)
Boot0004* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

I tried sudo efibootmgr -o 2001,2002,0001,0004 does not work - grub is not loaded and the machine defaults to windows. Next time I loaded PEP, efibootmgr gave the same as above not updated.

Any ideas please on how to get grub to start as default.
« Last Edit: February 03, 2018, 01:45:50 pm by Tea »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: UEFI boot ... or not
« Reply #1 on: February 02, 2018, 04:52:29 pm »
Is there anything in the UEFI firmware settings that locks the boot order .. or sets the boot order ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Tea

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: UEFI boot ... or not
« Reply #2 on: February 03, 2018, 08:54:12 am »
no nothing

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1959
  • Karma: 341
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: UEFI boot ... or not
« Reply #3 on: February 03, 2018, 09:35:02 am »
I've read that you have to turn off Fast Boot to get some Satellites to boot in the order you want.

Also, don't all BIOSes have a menu like this?



Offline Tea

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: UEFI boot ... or not
« Reply #4 on: February 03, 2018, 11:30:58 am »
Fast boot is OFF/Disabled  - Yes my bios is very similar prob the same - there is no option to boot a partition in the bois  just the normal  boot list same as yours.  You should see System BIOS version as 1.4
« Last Edit: February 03, 2018, 11:33:40 am by Tea »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: UEFI boot ... or not
« Reply #5 on: February 03, 2018, 11:43:40 am »
When you save the UEFI boot order, does it actually get saved ? .. ie. after saving the new boot order (but before rebooting), does:
Code: [Select]
efibootmgr -v
show the new boot order or still the old one ?


or does it get saved, but get overwritten on next boot ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Tea

  • nOOb
  • *
  • Posts: 12
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: UEFI boot ... or not
« Reply #6 on: February 03, 2018, 01:44:54 pm »
OK after a bit of trial and error sudo efibootmgr -o 0001,0000 seems to have fixed the problem. I suspect I wasn't actually saving the efibootmgr but using the shorter command and confirming with sudo efibootmgr -v has fixed it.

Thanks for all your help.

steve@Lappydo ~ $ efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,0001,2003,2001,2002
Boot0000* Windows Boot Manager
Boot0001* Ubuntu
Boot0002* EFI Network 0 for IPv6 (0C-54-A5-1C-EE-4A)
Boot0003* EFI Network 0 for IPv4 (0C-54-A5-1C-EE-4A)
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

steve@Lappydo ~ $ sudo efibootmgr -o 0001,0000
[sudo] password for steve:
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager
Boot0001* Ubuntu
Boot0002* EFI Network 0 for IPv6 (0C-54-A5-1C-EE-4A)
Boot0003* EFI Network 0 for IPv4 (0C-54-A5-1C-EE-4A)
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

steve@Lappydo ~ $ sudo efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0001,0000
Boot0000* Windows Boot Manager   HD(2,GPT,7c6374f1-042f-44bc-921e-f3473d14dfb5,0x200800,0x72000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Ubuntu   HD(2,GPT,7c6374f1-042f-44bc-921e-f3473d14dfb5,0x200800,0x72000)/File(\EFI\ubuntu\grubx64.efi)RC
Boot0002* EFI Network 0 for IPv6 (0C-54-A5-1C-EE-4A)    PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)/MAC(0c54a51cee4a,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0003* EFI Network 0 for IPv4 (0C-54-A5-1C-EE-4A)    PciRoot(0x0)/Pci(0x1c,0x2)/Pci(0x0,0x0)/MAC(0c54a51cee4a,0)/IPv4(0.0.0.0:0<->0.0.0.0:0,0,0)RC
Boot2001* EFI USB Device   RC
Boot2002* EFI DVD/CDROM   RC
Boot2003* EFI Network   RC


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: UEFI boot ... or not [SOLVED]
« Reply #7 on: February 03, 2018, 02:40:18 pm »
Nice, glad you got it sorted, and thanks for marking the topic (SOLVED) :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec