Author Topic: Desktop Issue After Boot (Solved)  (Read 9423 times)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Desktop Issue After Boot
« Reply #45 on: February 08, 2018, 04:26:00 am »
Okay to remove the HWE and go back to the default 16.04 kernel (4.4.0) run these commands in sequence:
(these commands are rather long so will scroll off the page to the right .. be sure to get the entire command .. also DO NOT reboot until told to do so)
Code: [Select]
sudo apt-get install linux-generic linux-signed-generic xserver-xorg xserver-xorg-core xserver-xorg-legacy xserver-xorg-video-all xserver-xorg-video-intel xserver-xorg-video-qxl xserver-xorg-input-all libgl1-mesa-dri:i386 libgl1-mesa-glx:i386then if that command finishes without error:
Code: [Select]
sudo apt-get remove --purge linux-headers-4.13.0-32 linux-headers-4.13.0-32-generic linux-image-4.13.0-32-generic linux-image-extra-4.13.0-32-generic linux-signed-generic-hwe-16.04 linux-signed-image-4.13.0-32-generic linux-signed-image-generic-hwe-16.04if those two commands ran without error .. REBOOT.

Once rebooted, check you're running the 4.4.0 kernel with:
Code: [Select]
uname -aIf you are, go to:-

Menu > System Tools > Synaptic Package Manager

In Synaptic, on the left hand column select the "Status" button .. select the "Not Installed (residual config)" category .. then mark all displayed packages as "Mark for Complete Removal", and click the "Apply" button.

Once those packages are gone, close Synaptic.

Back in the terminal run:
Code: [Select]
sudo apt-get install --reinstall linux-generic linux-signed-generic xserver-xorg xserver-xorg-core xserver-xorg-legacy xserver-xorg-video-all xserver-xorg-video-intel xserver-xorg-video-qxl xserver-xorg-input-all libgl1-mesa-dri:i386 libgl1-mesa-glx:i386this will replace any config files removed previously with the correct ones.

Okay, all done, so test your computer for the issues you've been having.

If you're having no problems, post the output (if any) from:
Code: [Select]
dpkg -l | grep hwe-16.04and
Code: [Select]
dpkg -l | grep 4.13.0so we can see if anything was left behind that shouldn't have been.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Desktop Issue After Boot
« Reply #46 on: February 08, 2018, 05:07:27 am »
Just a reminder, that output is from a clean install with just the usual update upgrade and dist upgrade done once. The earlier modification to the grub has not been done.
Should I put that on this install as it did nothing to help?
Which graphics card do you want me to work with before doing as you requested?
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Desktop Issue After Boot
« Reply #47 on: February 08, 2018, 06:01:20 am »
Don't change GRUB yet

and whichever graphics card you wish .. I no longer think that's the root of the issue.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Desktop Issue After Boot
« Reply #48 on: February 08, 2018, 09:02:03 am »
I removed the Nvidia card.
Followed all your instructions.
Shutdown and let it sit for over 2 hours.
When I fired it up  :) :D ;D :P
So tomorrow if all goes well I can mark this solved. Thank you so much for all your effort.
Can you link to whatever showed you this solution? I would love to read more about it.

dpkg+uname
[close]
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Desktop Issue After Boot
« Reply #49 on: February 08, 2018, 09:35:47 am »
Okay the output shows there's nothing to clean up.

Can you link to whatever showed you this solution? I would love to read more about it.

Sorry but there's no link .. I just noticed that you said the 4.9 kernel worked in Debian, so I wondered if there was some kind of kernel regression in the 4.13 (and possibly later) kernel series, and/or a regression in the later version of the xorg stack which is also updated by hwe-16.04. Now considering the default (non-HWE) kernel for Ubuntu 16.04 (so therefore Peppermint 7 and 8 ) is the 4.4 series, I figured lets test that kernel and xorg stack because they'll continue to get security updates automagically.

Basically we undid the changes applied by the "Hardware Enablement" track for 16.04 (hwe-16.04) as used in Peppermint 8 Respin (and Ubuntu 16.04.3, or distros based on it). So you now have Peppermint 8 built on Ubuntu 16.04 instead of 16.04.3

Sadly this "guess" at what might fix the problem doesn't identify what the actual kernel regression is, or what hardware you have that's triggering the regression :( .. but I guess it's better than nothing ?
« Last Edit: February 08, 2018, 09:43:31 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Desktop Issue After Boot
« Reply #50 on: February 09, 2018, 06:29:08 am »
So it seems as though my OP is solved. I have tried it three time and it starts as one would expect.
But with one problem solved another has popped up. This motherboard has wireless built in and it won't connect. Looking in the forum under networking I found this post that looks like what I am experiencing.   https://forum.peppermintos.com/index.php/topic,5980.0.html

The solution though looks like what I removed. The spoiler shows inxi, iwconfig,and nmcli.

Spoiler (click here to view / hide)
[close]

A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Desktop Issue After Boot
« Reply #51 on: February 09, 2018, 07:01:19 am »
Can you post the output from:
Code: [Select]
lsusband
Code: [Select]
lspci -vnn | grep -i netand
Code: [Select]
iwlist scanand
Code: [Select]
rfkill list
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Desktop Issue After Boot
« Reply #52 on: February 09, 2018, 08:10:50 am »
lsusb
[close]

lspci
[close]

iwlist
[close]

rfkill
[close]
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Desktop Issue After Boot
« Reply #53 on: February 09, 2018, 09:13:00 am »
Okay now we have a problem.

That network adapter insn't supported until kernel 4.6.

We could easily install that (or the 4.8) kernel but it will NOT get security updates, nor will it be patched against the Meltdown and Spectre vulnerabilities.

So looks like your decision is between an unpatched and static kernel .. or getting a new wireless adapter :(

Just as a matter on interest, can you post the output from:
Code: [Select]
dmesg | grep iwl
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Desktop Issue After Boot
« Reply #54 on: February 09, 2018, 09:20:14 am »
dmesg | grep iwl returns nothing.
FYI Debian network work after I added some firmware.  I found this but don't understand where they got the file from. OpenElectric?
« Last Edit: February 09, 2018, 09:36:45 am by Ralph »
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Desktop Issue After Boot
« Reply #55 on: February 09, 2018, 11:53:02 am »
The firmware on its own won't help, if it would, that last command I asked you to run would have spit out that the driver couldn't find the firmware. The problem is the kernel doesn't even contain the driver :(
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Desktop Issue After Boot
« Reply #56 on: February 09, 2018, 12:06:37 pm »
Once again thank you for all you have done. Maybe by the time Peppermint 9 comes out these issues with Coffee Lake and Intels 3168 ac wireless will be addressed. Anyway the ball is in my court.

How would you like me to post the results?  The original post was solved after all. But??? :-\
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Desktop Issue After Boot
« Reply #57 on: February 09, 2018, 12:18:29 pm »
Just leave the topic open my mate, and let it slide into obscurity .. I'm sure if anyone has the same issue just searching for coffee lake will find it for them .. if not and they post, we'll know the answer now anyway :)

Quote from: Ralph
Once again thank you for all you have done.

You're most welcome Ralph :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Desktop Issue After Boot
« Reply #58 on: August 21, 2018, 07:03:57 am »
Since this goes way back and I thought I'd share what has happen since then. Because I could not use wifi with the solution I got here I thought I would keep looking for another distro that would work better. To make a long story short I settled on Solus Gnome. I tried the Budgie but just didn't like it. I don't know why but SG just worked. The issues I had just disappeared. Solus isn't bad but it's not Peppermint.
This week I installed Peppermint 9 and so far all those issues discussed priviously have not materialised. I really like Peppermint and I'm very pleased to be back using it on this machine.
A little knowledge is dangerous, I'm proof of it.

Offline scifidude79

  • Hero
  • *****
  • Posts: 4029
  • Karma: 870
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Desktop Issue After Boot
« Reply #59 on: August 21, 2018, 07:08:22 am »
Hey, thanks for the update. Have a karma point for remembering this place and returning to Peppermint.  :D