Choose style:

Author Topic: [Solved] Typing "su" at $ prompt does not work...  (Read 559 times)

0 Members and 1 Guest are viewing this topic.

Offline Rob

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • Gradually leaving LinuxMint for PepperMint...
    • View Profile
    • Google Voice for Canadians
  • Peppermint version(s): 8
[Solved] Typing "su" at $ prompt does not work...
« on: January 31, 2018, 12:18:47 pm »
Hello:

rob@rob-ThinkPad-T520 ~ $ su
Password:
su: Authentication failure
rob@rob-ThinkPad-T520 ~ $

As far as I know, I set up only one password during the install and that was for user "rob".

Is there a default pw for user "root"?

Thanks,

rob.
« Last Edit: January 31, 2018, 12:34:06 pm by Rob »
"Commit a random act of kindness. "

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1948
  • Karma: 336
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Typing "su" at $ prompt does not work...
« Reply #1 on: January 31, 2018, 12:24:50 pm »
The recommended method is to use sudo to precede your commands. That way you'll be asked for your own user password.

Offline Rob

  • nOOb
  • *
  • Posts: 23
  • Karma: 0
  • Gradually leaving LinuxMint for PepperMint...
    • View Profile
    • Google Voice for Canadians
  • Peppermint version(s): 8
Re: Typing "su" at $ prompt does not work...
« Reply #2 on: January 31, 2018, 12:33:36 pm »
OK, thank you. :)

sudo su
« Last Edit: January 31, 2018, 12:35:33 pm by Rob »
"Commit a random act of kindness. "

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25491
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: [Solved] Typing "su" at $ prompt does not work...
« Reply #3 on: January 31, 2018, 02:10:30 pm »
Or for a root terminal:
Code: [Select]
sudo -s
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec