Choose style:

Author Topic: startup daemon (SOLVED)  (Read 19283 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: startup daemon
« Reply #15 on: July 22, 2014, 05:55:30 pm »
Run:
Code: [Select]
sudo apt install screen
then REBOOT.

With any luck, the Plexconnect daemon will autostart.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #16 on: July 22, 2014, 06:07:46 pm »
Ok this is where my other issue has come and bitten me


Code: [Select]

plex@plex ~ $ sudo apt install screen
[sudo] password for plex:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package screen


Maybe a rebuild is in order and start over and see if it works. I have tried to run the test to determine the best server for me and the test starts and eventually times out saying that no suitable download server was found check my internet connection. I know my internet connection is fine as I can surf and im posting from the Peppermint machine to here.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: startup daemon
« Reply #17 on: July 22, 2014, 06:09:42 pm »
Is this Peppermint 4 ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #18 on: July 22, 2014, 06:11:07 pm »
Version 3 an oldie now im guessing seeing 5 is out

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: startup daemon
« Reply #19 on: July 22, 2014, 06:15:05 pm »
Hmm .. the repos for 3 should still be live.

Are there any errors from:
Code: [Select]
sudo apt-get update
?



Are you sure this isn't Peppermint 4 ? .. your profile suggests you're running the 3.8 kernel series as in Peppermint 4  :-\

What's the output from:
Code: [Select]
cat /etc/lsb-release
« Last Edit: July 22, 2014, 06:18:19 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #20 on: July 22, 2014, 06:17:54 pm »
A few

Code: [Select]
plex@plex ~ $ sudo apt-get update
Hit http://plex.r.worldssl.net lucid Release.gpg
Hit http://plex.r.worldssl.net lucid Release               
Hit http://plex.r.worldssl.net lucid/main i386 Packages                       
Ign http://archive.ubuntu.com raring Release.gpg
Hit http://ppa.launchpad.net raring Release.gpg
Ign http://archive.ubuntu.com raring-updates Release.gpg
Hit http://ppa.launchpad.net raring Release   
Ign http://archive.ubuntu.com raring-backports Release.gpg           
Ign http://archive.ubuntu.com raring-security Release.gpg
Hit http://ppa.launchpad.net raring/main i386 Packages
Ign http://archive.ubuntu.com raring Release   
Ign http://archive.ubuntu.com raring-updates Release                 
Ign http://archive.ubuntu.com raring-backports Release               
Ign http://archive.ubuntu.com raring-security Release
Ign http://ppa.launchpad.net raring/main Translation-en_NZ           
Ign http://ppa.launchpad.net raring/main Translation-en             
Ign http://plex.r.worldssl.net lucid/main Translation-en_NZ
Ign http://plex.r.worldssl.net lucid/main Translation-en
Err http://archive.ubuntu.com raring/main Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring/restricted Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring/universe Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring/multiverse Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring/main i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring/restricted i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring/universe i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring/multiverse i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Ign http://archive.ubuntu.com raring/main Translation-en_NZ
Ign http://archive.ubuntu.com raring/main Translation-en
Ign http://archive.ubuntu.com raring/multiverse Translation-en_NZ
Ign http://archive.ubuntu.com raring/multiverse Translation-en
Ign http://archive.ubuntu.com raring/restricted Translation-en_NZ
Ign http://archive.ubuntu.com raring/restricted Translation-en
Ign http://archive.ubuntu.com raring/universe Translation-en_NZ
Ign http://archive.ubuntu.com raring/universe Translation-en
Err http://archive.ubuntu.com raring-updates/main Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-updates/restricted Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-updates/universe Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-updates/multiverse Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-updates/main i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-updates/restricted i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-updates/universe i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-updates/multiverse i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Ign http://archive.ubuntu.com raring-updates/main Translation-en_NZ
Ign http://archive.ubuntu.com raring-updates/main Translation-en
Ign http://archive.ubuntu.com raring-updates/multiverse Translation-en_NZ
Ign http://archive.ubuntu.com raring-updates/multiverse Translation-en
Ign http://archive.ubuntu.com raring-updates/restricted Translation-en_NZ
Ign http://archive.ubuntu.com raring-updates/restricted Translation-en
Ign http://archive.ubuntu.com raring-updates/universe Translation-en_NZ
Ign http://archive.ubuntu.com raring-updates/universe Translation-en
Err http://archive.ubuntu.com raring-backports/main Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-backports/restricted Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-backports/universe Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-backports/multiverse Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-backports/main i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-backports/restricted i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-backports/universe i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-backports/multiverse i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Ign http://archive.ubuntu.com raring-backports/main Translation-en_NZ
Ign http://archive.ubuntu.com raring-backports/main Translation-en
Ign http://archive.ubuntu.com raring-backports/multiverse Translation-en_NZ
Ign http://archive.ubuntu.com raring-backports/multiverse Translation-en
Ign http://archive.ubuntu.com raring-backports/restricted Translation-en_NZ
Ign http://archive.ubuntu.com raring-backports/restricted Translation-en
Ign http://archive.ubuntu.com raring-backports/universe Translation-en_NZ
Ign http://archive.ubuntu.com raring-backports/universe Translation-en
Err http://archive.ubuntu.com raring-security/main Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-security/restricted Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-security/universe Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-security/multiverse Sources
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-security/main i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-security/restricted i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-security/universe i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Err http://archive.ubuntu.com raring-security/multiverse i386 Packages
  404  Not Found [IP: 91.189.91.15 80]
Ign http://archive.ubuntu.com raring-security/main Translation-en_NZ
Ign http://archive.ubuntu.com raring-security/main Translation-en
Ign http://archive.ubuntu.com raring-security/multiverse Translation-en_NZ
Ign http://archive.ubuntu.com raring-security/multiverse Translation-en
Ign http://archive.ubuntu.com raring-security/restricted Translation-en_NZ
Ign http://archive.ubuntu.com raring-security/restricted Translation-en
Ign http://archive.ubuntu.com raring-security/universe Translation-en_NZ
Ign http://archive.ubuntu.com raring-security/universe Translation-en
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/main/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/restricted/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/universe/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/multiverse/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/universe/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/main/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/restricted/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/universe/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/multiverse/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/main/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/universe/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-updates/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/main/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/restricted/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/universe/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/multiverse/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/main/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/universe/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-backports/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/main/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/restricted/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/universe/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/multiverse/source/Sources  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/main/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/restricted/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/universe/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/raring-security/multiverse/binary-i386/Packages  404  Not Found [IP: 91.189.91.15 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
plex@plex ~ $

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: startup daemon
« Reply #21 on: July 22, 2014, 06:24:30 pm »
OK, that's definitely Peppermint 4 not 3.

The raring repos are now dead, so you have 2 options here

a) start again with Peppermint 5 (or 3)

b) we can try to download screen and install it from the web.

"b"will probably be quite easy .. but you're going to have problems installing ANY software from now on in Peppermint 4 .. so which do you want to do ?



If you want to install screen from the web in Peppermint 4, post the output from:
Code: [Select]
uname -a
« Last Edit: July 22, 2014, 06:26:11 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #22 on: July 22, 2014, 06:34:29 pm »
Palm to forehead now I feel like a tool lol

I'll go ahead and do the upgrade to 5, I was planning it after we had done this but may as well do it now.

I will do everything the same as I have done so far and get to the point of attempting the screen install.

Might take me a bit as I have to do up the usb on another machine seeing I can't install UNetbootin on here unless there is another way I am not familiar with.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: startup daemon
« Reply #23 on: July 22, 2014, 06:39:10 pm »
Okey dokey ... I'm pretty sure it just needs "screen" to work :)

good luck, and if you get stuck gimme a shout.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #24 on: July 22, 2014, 10:32:34 pm »
Up and running on 5 now

Still no joy on reboot, think that screen installed properly

Code: [Select]
plex@plex ~ $ dpkg -l | grep screen
ii  libts-0.0-0:i386                           1.0-12                               i386         touch screen library
ii  mtr-tiny                                   0.85-2                               i386         Full screen ncurses traceroute tool
ii  screen                                     4.1.0~20120320gitdb59704-9           i386         terminal multiplexer with VT100/ANSI terminal emulation
ii  scrot                                      0.8-13                               i386         command line screen capture utility
ii  tsconf                                     1.0-12                               all          touch screen library common files

I did find one issue I had with a sym link but that is fixed and I can now also start by typing

Code: [Select]
sudo service plexconnect start

I am going through trying to make sure that everything else is the same as it was prior to the upgrade.
[/code]

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: startup daemon
« Reply #25 on: July 23, 2014, 10:30:58 am »
What's the output from
Code: [Select]
ls /etc/rc*.d
again ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #26 on: July 23, 2014, 03:18:27 pm »
Code: [Select]
plex@plex ~ $ ls /etc/rc*.d
/etc/rc0.d:
K10unattended-upgrades  K20rsync           S20sendsigs      S40umountfs
K20hddtemp              K20screen-cleanup  S30urandom       S60umountroot
K20plexconnect          README             S31umountnfs.sh  S90halt

/etc/rc1.d:
K20hddtemp      K20rsync           K77ntp  S30killprocs  S70pppd-dns
K20plexconnect  K20screen-cleanup  README  S70dns-clean  S90single

/etc/rc2.d:
README          S20rsync           S70dns-clean    S99ondemand
S20hddtemp      S20screen-cleanup  S70pppd-dns     S99rc.local
S20plexconnect  S23ntp             S99grub-common

/etc/rc3.d:
README          S20rsync           S70dns-clean    S99ondemand
S20hddtemp      S20screen-cleanup  S70pppd-dns     S99rc.local
S20plexconnect  S23ntp             S99grub-common

/etc/rc4.d:
README          S20rsync           S70dns-clean    S99ondemand
S20hddtemp      S20screen-cleanup  S70pppd-dns     S99rc.local
S20plexconnect  S23ntp             S99grub-common

/etc/rc5.d:
README          S20rsync           S70dns-clean    S99ondemand
S20hddtemp      S20screen-cleanup  S70pppd-dns     S99rc.local
S20plexconnect  S23ntp             S99grub-common

/etc/rc6.d:
K10unattended-upgrades  K20rsync           S20sendsigs      S40umountfs
K20hddtemp              K20screen-cleanup  S30urandom       S60umountroot
K20plexconnect          README             S31umountnfs.sh  S90reboot

/etc/rcS.d:
README  S37apparmor  S47lm-sensors  S51mintsystem  S55urandom  S70x11-common
plex@plex ~ $

We are getting somewhere the plexconnect log is getting something written to it on start up

Code: [Select]
07:09:20 PlexConnect: started: 07:09:20
07:09:20 PlexConnect: Version: 0.3.1+
07:09:20 PlexConnect: Python: 2.7.6 (default, Mar 22 2014, 22:59:38)
[GCC 4.8.2]
07:09:20 PlexConnect: Host OS: linux2
Its just not starting, before I would only get log entries from issuing a
Code: [Select]
 ./PlexConnect.bash start

Log after invoking
Code: [Select]
 sudo service plexconnect start 


Code: [Select]
07:16:16 PlexConnect: started: 07:16:16
07:16:16 PlexConnect: Version: 0.3.1+
07:16:16 PlexConnect: Python: 2.7.6 (default, Mar 22 2014, 22:59:38)
[GCC 4.8.2]
07:16:16 PlexConnect: Host OS: linux2
07:16:16 PlexConnect: IP_self: 192.168.1.10
07:16:16 DNSServer: started: 07:16:16
07:16:16 DNSServer: ***
07:16:16 DNSServer: DNSServer: Serving DNS on 192.168.1.10 port 53.
07:16:16 DNSServer: ***
07:16:16 WebServer: started: 07:16:16
07:16:16 WebServer: ***
07:16:16 WebServer: WebServer: Serving HTTP on 192.168.1.10 port 80.
07:16:16 WebServer: ***
07:16:16 WebServer: started: 07:16:16
07:16:16 WebServer: ***
07:16:16 WebServer: WebServer: Serving HTTPS on 192.168.1.10 port 443.
07:16:16 WebServer: ***


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: startup daemon
« Reply #27 on: July 23, 2014, 03:30:56 pm »
Does running
Code: [Select]
/usr/local/lib/PlexConnect/PlexConnect-master/PlexConnect.py
or
Code: [Select]
sudo /usr/local/lib/PlexConnect/PlexConnect-master/PlexConnect.py
start plexconnect ?
« Last Edit: July 23, 2014, 03:58:26 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #28 on: July 23, 2014, 03:42:16 pm »
Code: [Select]
plex@plex ~ $ sudo service plexconnect status
[sudo] password for plex:
PlexConnect is not running

Offline kiwi_guy

  • Jr. Member
  • **
  • Posts: 29
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 3.8.0-35-generic
Re: startup daemon
« Reply #29 on: July 24, 2014, 03:56:25 pm »
Code: [Select]
plex@plex ~ $ /usr/local/lib/PlexConnect-master/PlexConnect.py07:50:20 PlexConnect: ***
07:50:20 PlexConnect: PlexConnect
07:50:20 PlexConnect: Press CTRL-C to shut down.
07:50:20 PlexConnect: ***
Traceback (most recent call last):
  File "/usr/local/lib/PlexConnect-master/PlexConnect.py", line 171, in <module>
    running = startup()
  File "/usr/local/lib/PlexConnect-master/PlexConnect.py", line 66, in startup
    dinit('PlexConnect', param, True)  # init logging, new file, main process
  File "/usr/local/lib/PlexConnect-master/Debug.py", line 47, in dinit
    f = open(g_logfile, 'w')
IOError: [Errno 13] Permission denied: '/usr/local/lib/PlexConnect-master/./PlexConnect.log'
plex@plex ~ $ sudo /usr/local/lib/PlexConnect-master/PlexConnect.py
07:50:39 PlexConnect: ***
07:50:39 PlexConnect: PlexConnect
07:50:39 PlexConnect: Press CTRL-C to shut down.
07:50:39 PlexConnect: ***
07:50:39 PlexConnect: started: 07:50:39
07:50:39 PlexConnect: Version: 0.3.1+
07:50:39 PlexConnect: Python: 2.7.6 (default, Mar 22 2014, 22:59:38)
[GCC 4.8.2]
07:50:39 PlexConnect: Host OS: linux2
07:50:39 PlexConnect: IP_self: 192.168.1.10
07:50:39 DNSServer: started: 07:50:39
07:50:39 DNSServer: ***
07:50:39 DNSServer: DNSServer: Serving DNS on 192.168.1.10 port 53.
07:50:39 DNSServer: intercept: ['trailers.apple.com'] => 192.168.1.10
07:50:39 DNSServer: restrain: ['mesu.apple.com', 'appldnld.apple.com', 'appldnld.apple.com.edgesuite.net'] => 127.0.0.1
07:50:39 DNSServer: forward other to higher level DNS: 8.8.8.8
07:50:39 DNSServer: ***
07:50:39 WebServer: started: 07:50:39
07:50:39 WebServer: ***
07:50:39 WebServer: WebServer: Serving HTTP on 192.168.1.10 port 80.
07:50:39 WebServer: ***
07:50:39 WebServer: started: 07:50:39
07:50:39 WebServer: ***
07:50:39 WebServer: WebServer: Serving HTTPS on 192.168.1.10 port 443.
07:50:39 WebServer: ***

plex@plex ~ $ sudo service plexconnect status
PlexConnect is not running


It looks like it does but checking the status in another terminal said it wasn't.