Choose style:

Author Topic: Allowing automatic flash content in Chrome/Chromium >= 62 (fixes SSB's)  (Read 590 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 19621
  • Karma: 2234
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin (64bit)
In Chrome / Chromium 62 (and greater) Google saw fit to remove the ability to always play flash content without being asked first. This broke SSB's that display flash content because the user never gets prompted whether they want to allow flash content or not.

The solution is to whitelist all http and https sites in Chrome/Chromium allowing automatic playing of flash content without being prompted.

So open Chromium/Chrome.

In the address bar enter:
chrome://settings/content/flash
and hit Enter.

On the "Allow" line, click the "ADD" button.

set the site as:-
http://*
and click the "ADD" button

On the "Allow" line, click the "ADD" button again

set the site as:-
https://*
and click the "ADD" button.

Also make sure the switch at the top of that page is set to "Ask first (recommended)" and NOT "Block sites from running flash".

(click image to enlarge)

you can now check this worked by closing ALL running web browser instances then testing if the:-
Menu > Graphics > Editor by Pixlr
SSB works .. if it does, you're all done.
« Last Edit: January 13, 2018, 04:34:39 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 19621
  • Karma: 2234
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 Respin (64bit)
Re: Allowing automatic flash content in Chrome/Chromium >= 62 (fixes SSB's)
« Reply #1 on: January 13, 2018, 04:48:09 pm »
If the above on it's own doesn't get flash working in Chromium, check whether you have the adobe-flashplugin installed and NOT flashplugin-installer

You can do this by going to:-
Menu > Preferences > Software & Updates

Select the "Other Software" tab.

And make sure there is a tick next to

Canonical Partners

Enter your password, if prompted.

Once the box is ticked, click the "Close" button, followed by the "Reload" button if offered.

Now open a terminal and run:
Code: [Select]
sudo apt-get update
then
Code: [Select]
sudo apt-get install adobe-flashplugin
and accept the changes.

Now close ALL running web browser instances and check if
Menu > Internet > Editor by Pixlr
works
« Last Edit: January 13, 2018, 04:52:01 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec