Choose style:

Author Topic: No spdif peppermint os 5 amd 64 [SOLVED]  (Read 3572 times)

0 Members and 1 Guest are viewing this topic.

Offline advinsta

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermnit os 5 amd64
No spdif peppermint os 5 amd 64 [SOLVED]
« on: July 11, 2014, 03:18:47 am »
Hi,

I love peppermint os 5 it looks and runs great.
But i'm unable to get the sound working.
I read some no sound topics and did some research, below my system specs and what i found:

OS = Peppermint OS
Video = ATI RADEON 5770
Motherboard = ASROCK FM2A88M EXTREME4+

I am using the Radeon card for video input to my Samsung TV.
I want to use the onboard SPDIF output for audio.

At the moment in the lower right corner i see the ' speaker'  icon
its the pulseaudio mixer.
It will only show the HDMI sound of the videocard.

I have also installed the ALSA mixer and it does show my SPDIF sound.
Unfortunately im unable to produce any sound from eithe my tv speaker or my
Receiver.
Any help would be appreciated
Excuse my bad english, its not my native language.

I already did the output thing:
http://www.alsa-project.org/db/?f=adb0f8cc217f1f471b3e731834a53f9398557c6a



regards,

Advinsta

.






« Last Edit: July 12, 2014, 04:54:59 am by advinsta »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25708
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: No spdif peppermint os 5 amd 64
« Reply #1 on: July 11, 2014, 03:26:52 am »
What's the output from:
Code: [Select]
aplay -L
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline advinsta

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermnit os 5 amd64
Re: No spdif peppermint os 5 amd 64
« Reply #2 on: July 11, 2014, 03:29:44 am »
What's the output from:
Code: [Select]
aplay -L

thnx for the quick response!!

output as follows:
Spoiler (click here to view / hide)
$ aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
sysdefault:CARD=SB
    HDA ATI SB, VT1708S Analog
    Default Audio Device
front:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    Front speakers
surround40:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Digital
    HDMI Audio Output
dmix:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    Direct sample mixing device
dmix:CARD=SB,DEV=3
    HDA ATI SB, VT1708S Digital
    Direct sample mixing device
dsnoop:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    Direct sample snooping device
dsnoop:CARD=SB,DEV=3
    HDA ATI SB, VT1708S Digital
    Direct sample snooping device
hw:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    Direct hardware device without any conversions
hw:CARD=SB,DEV=3
    HDA ATI SB, VT1708S Digital
    Direct hardware device without any conversions
plughw:CARD=SB,DEV=0
    HDA ATI SB, VT1708S Analog
    Hardware device with all software conversions
plughw:CARD=SB,DEV=3
    HDA ATI SB, VT1708S Digital
    Hardware device with all software conversions
hdmi:CARD=HDMI,DEV=0
    HDA ATI HDMI, HDMI 0
    HDMI Audio Output
dmix:CARD=HDMI,DEV=3
    HDA ATI HDMI, HDMI 0
    Direct sample mixing device
dsnoop:CARD=HDMI,DEV=3
    HDA ATI HDMI, HDMI 0
    Direct sample snooping device
hw:CARD=HDMI,DEV=3
    HDA ATI HDMI, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=HDMI,DEV=3
    HDA ATI HDMI, HDMI 0
    Hardware device with all software conversions
[close]
« Last Edit: July 11, 2014, 04:45:43 am by PCNetSpec, Reason: Added spoiler tags for long output »

Offline advinsta

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermnit os 5 amd64
Re: No spdif peppermint os 5 amd 64
« Reply #3 on: July 11, 2014, 03:56:58 am »
Really weird... dunno what happend but now i do have SPID Audio.
I didn't even reboot or anything...

I will reboot now and see if i still have sound.
thnx for the help.
 

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25708
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: No spdif peppermint os 5 amd 64
« Reply #4 on: July 11, 2014, 04:13:40 am »
How strange  :-\
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline advinsta

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermnit os 5 amd64
Re: No spdif peppermint os 5 amd 64
« Reply #5 on: July 11, 2014, 04:25:28 am »
How strange  :-\

Turns out it will only play analog sound trough SPDIF.
Installed XBMC, selected digital output, and then no sound.
When put on analog it will play the sound, although the source sound is dd5.1

Any thoughts?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25708
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: No spdif peppermint os 5 amd 64
« Reply #6 on: July 11, 2014, 04:35:41 am »
If you run this in a terminal:
Code: [Select]
alsamixer
are there any switches (muted) for digital (IEC958)
?
« Last Edit: July 11, 2014, 04:47:53 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline advinsta

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermnit os 5 amd64
Re: No spdif peppermint os 5 amd 64
« Reply #7 on: July 11, 2014, 05:07:39 am »
If you run this in a terminal:
Code: [Select]
alsamixer
are there any switches (muted) for digital (IEC958)
?
I dont see a IEC958 anywhere but.
i got 2 spdif options in the mixer, one is called spid (not muted)
other is called spdif default pcm, this one was muted, so i unmuted it.

on the left top side i see the following:

Card: HDA ATI SB
Chip: VIA VT1708S
when pressing F2 (system information)i see the following:

/proc/asound/versions
/proc/asound/cards
/proc/asound/devices
/proc/asound/timers
/proc/asound/pcm

under cards i see:
┌──────────────────────────── AlsaMixer v1.0.27.2 ─────────────────────────────┐
│ Card: HDA ATI SB                                     F1:  Help               │
│ Chip: VIA VT1708S                                    F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: 0,00]                         Esc: Exit               │
│                                                                              │
│     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│ ┌─── Select File ────┐│  │     │▒▒│     │▒▒│      │
│     │▒▒│ ┌───────────────── /proc/asound/cards ──────────────────┐ │▒▒│      →
│     │▒▒│ │ 0 [SB             ]: HDA-Intel - HDA ATI SB           │ │▒▒│      →
│     │▒▒│ │                      HDA ATI SB at 0xfeaf4000 irq 16  │ │▒▒│      →
│     │▒▒│ │ 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI         │ │▒▒│      →
│     │▒▒│ │                      HDA ATI HDMI at 0xfebf8000 irq 44│ │▒▒│      →
│     │▒▒│ └───────────────────────────────────────────────────────┘ │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     ├──┤     ┌──┐     └──┘     ├──┤     ├──┤     └──┘     ├──┤     ├──┤      │
│     │OO│     │MM│              │OO│     │MM│              │OO│     │OO│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│     100             100<>100 100<>100   0<>0     0<>0   100<>100   100       │


under devices i see:
┌──────────────────────────── AlsaMixer v1.0.27.2 ─────────────────────────────┐
│ Card: HDA ATI SB                                     F1:  Help               │
│ Chip: VIA VT1708S                                    F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: 0,00]                         Esc: Exit               │
│                                                                              │
│     ┌──┐           ┌─────── /proc/asound/devices ───────┐ ┌──┐     ┌──┐      │
│     │▒▒│           │  1:        : sequencer             │ │▒▒│     │▒▒│      │
│     │▒▒│           │  2: [ 0- 3]: digital audio playback│ │▒▒│     │▒▒│      │
│     │▒▒│           │  3: [ 0- 0]: digital audio playback│ │▒▒│     │▒▒│      →
│     │▒▒│           │  4: [ 0- 0]: digital audio capture │ │▒▒│     │▒▒│      →
│     │▒▒│           │  5: [ 0- 0]: hardware dependent    │ │▒▒│     │▒▒│      →
│     │▒▒│           │  6: [ 0]   : control               │ │▒▒│     │▒▒│      →
│     │▒▒│           │  7: [ 1- 3]: digital audio playback│ │▒▒│     │▒▒│      →
│     │▒▒│           │  8: [ 1- 0]: hardware dependent    │ │▒▒│     │▒▒│      →
│     │▒▒│           │  9: [ 1]   : control               │ │▒▒│     │▒▒│      →
│     │▒▒│           │ 33:        : timer                 │ │▒▒│     │▒▒│      │
│     │▒▒│           └────────────────────────────────────┘ │▒▒│     │▒▒│      │
│     ├──┤     ┌──┐     └──┘     ├──┤     ├──┤     └──┘     ├──┤     ├──┤      │
│     │OO│     │MM│              │OO│     │MM│              │OO│     │OO│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│     100             100<>100 100<>100   0<>0     0<>0   100<>100   100       │


under pcm i see:
┌──────────────────────────── AlsaMixer v1.0.27.2 ─────────────────────────────┐
│ Card: HDA ATI SB                                     F1:  Help               │
│ Chip: VIA VT1708S                                    F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: 0,00]                         Esc: Exit               │
│                                                                              │
│     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│ ┌─── Select File ────┐│  │     │▒▒│     │▒▒│      │
│     │┌────────────────────── /proc/asound/pcm ───────────────────────┐│      →
│     ││00-00: VT1708S Analog : VT1708S Analog : playback 1 : capture 1││      →
│     ││00-03: VT1708S Digital : VT1708S Digital : playback 1          ││      →
│     ││01-03: HDMI 0 : HDMI 0 : playback 1                            ││      →
│     │└───────────────────────────────────────────────────────────────┘│      →
│     │▒▒│              │▒▒│ └────────────────────┘│  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     ├──┤     ┌──┐     └──┘     ├──┤     ├──┤     └──┘     ├──┤     ├──┤      │
│     │OO│     │MM│              │OO│     │MM│              │OO│     │OO│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│     100             100<>100 100<>100   0<>0     0<>0   100<>100   100       │
│  < Master >Headphon   PCM     Front   Front Mi Front Mi Surround  Center     │
└──────────────────────────────────────────────────────────────────────────────┘


hope this helps?



Offline advinsta

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermnit os 5 amd64
Re: No spdif peppermint os 5 amd 64
« Reply #8 on: July 11, 2014, 07:56:18 am »
Got it all sorted now, for future reference or anybody with the same issue.
(Howto get DTS & DD5.1 working with PeppermintOS 5 combined with ATI HD 5700 video card connected
Via HDMI to tv and for sound, onboard SPDIF connected to AV Receiver with an ASROCK FM2A88M Extreme4+ motherboard.

Settings in Peppermint 5

Alsamixer is as follows:

┌──────────────────────────── AlsaMixer v1.0.27.2 ─────────────────────────────┐
│ Card: HDA ATI SB                                                                                                                    F1:  Help               │
│ Chip: VIA VT1708S                                                                                                    F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All                                                                F6:  Select sound card  │
│ Item: Master [dB gain: 0,00]                                                                                                Esc: Exit               │
│                                                                                                                                                                                    │
│     ┌──┐              ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│              │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     ├──┤     ┌──┐ └──┘     ├──┤     ├──┤    ──┘     ├──┤     ├──┤      │
│     │MM│  │MM│              │MM│     │MM│              │MM│     │MM│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│     100             100<>100 100<>100   0<>0     0<>0   100<>100   100       │
│  < Master >Headphon   PCM     Front   Front Mi Front Mi Surround  Center     │
└──────────────────────────────────────────────────────────────────────────────┘

Pulse audio setup as follows:

PLAY-TAB
Remains unchanged

RECORD-TAB
Remains unchanged

OUTPUT DEVICES-TAB
PORT= HDMI Display port (this is actually the SPDIF port, dont let the name fool you!)
Under advanced enable:
PCM, DTS, AC3, MPEG (depends on your AV receiver)
disabled
EAC3

INPUT DEVICES-TAB
Remains unchanged/Empty

CONFIGURATION-TAB
Juniper HDMI Audio (Radeon HD5700 series)
Profile = off

Internal Sound (this is actually the onboard spdif port, dont let the name fool you!)
Profile = Digital Stereo (HDMI) Output.

XBMC Setup as follows:

go to SYSTEM > SETTINGS > SYSTEM
Settings level on ADVANCED

then go to SYSTEM > SETTINGS > SYSTEM > Audio output
change the following settings:
Audio output device = Internal Sound Digital Stereo (HDMI)/ Displayport (pulse audio)
Output configuration = Optimized (you can put other settings here - AV Receiver specific)
Limit smapling rate = 192.0 (you can put other settings here - AV Receiver specific)
Stereo upmix = Enabled
Normalize levels on downmix = disabled
Resample quality = High (you can put other settings here - AV Receiver specific)
Keep audio alive = 1 Minute
Enable passtrough = enabled
Dolby digital (AC3) capable receiver = on (you can put other settings here - AV Receiver specific)
- Enable dolby digital transcoding = on
DTS capable receiver = on

with these above settings i got it working.
When selecting a movie in XBMC with DTS my receiver jumps to DTS input
When selecting a movie in XBMC with DD5.1 my receiver jumps to DD5.1 input.

Just going to reboot and test a few times.
If it still works i will mark the thread as solved....



« Last Edit: July 11, 2014, 08:26:56 am by advinsta »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25708
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: No spdif peppermint os 5 amd 64
« Reply #9 on: July 11, 2014, 09:03:41 am »
Nice .. and thanks for taking the time to write up your findings :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline advinsta

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermnit os 5 amd64
Re: No spdif peppermint os 5 amd 64
« Reply #10 on: July 12, 2014, 04:54:27 am »
The above settings in my previous post seem to work fine!

Did a few reboots, pc off for a whole night and all still works.
Ill mark the topic as solved

thank you for all your help!!

@ Moderator, topic can be closed...
« Last Edit: July 12, 2014, 04:56:27 am by advinsta »