Choose style:

Author Topic: "Shader model 3 must be supported" (SOLVED)  (Read 2411 times)

0 Members and 2 Guests are viewing this topic.

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
"Shader model 3 must be supported" (SOLVED)
« on: December 19, 2017, 04:17:46 pm »
Trying out peppermint 8.  Im using Playonlinux to play Path of Exile.  When i put it on opengl, i get this error message.  If i turn on glsl i do not get this error, but its bad fps.

I selected Nvidia 384.98 in the additional drivers. 

Do i need to install something else?

Thanks
« Last Edit: December 20, 2017, 07:55:13 pm by chadwix »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "Shader model 3 must be supported"
« Reply #1 on: December 19, 2017, 05:20:41 pm »
What's the output from:
Code: [Select]
inxi -Fz
« Last Edit: December 19, 2017, 05:31:44 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: "Shader model 3 must be supported"
« Reply #2 on: December 19, 2017, 05:29:09 pm »
CPU:       Quad core Intel Core i7-2600K (-HT-MCP-) cache: 8192 KB
           clock speeds: max: 3800 MHz 1: 3499 MHz 2: 3499 MHz 3: 3499 MHz
           4: 3499 MHz 5: 3499 MHz 6: 3499 MHz 7: 3499 MHz 8: 3499 MHz
           CPU Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush
           cmov constant_tsc cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est
           flexpriority fpu fxsr ht ida lahf_lm lm mca mce mmx msr mtrr
           nonstop_tsc nx pae pat pbe pcid pclmulqdq pdcm pebs pge pln pni
           popcnt pse pse36 pts rdtscp sep ss sse sse2 sse4_1 sse4_2 ssse3 tm
           tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid xsave
           xsaveopt xtopology xtpr

When i open my nvidia settings panel, there are no options

Thanks

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "Shader model 3 must be supported"
« Reply #3 on: December 19, 2017, 05:30:40 pm »
That output was wrong .. remember, Linux commands ARE case sensitive, so please post the output from
Code: [Select]
inxi -Fz
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: "Shader model 3 must be supported"
« Reply #4 on: December 19, 2017, 06:10:26 pm »
Code: [Select]
System:    Host: chad-desktop Kernel: 4.10.0-42-generic i686 (32 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   Mobo: Intel model: DZ68BC v: AAG30742-401
           Bios: Intel v: BCZ6810H.86A.0021.2011.0831.1555 date: 08/31/2011
CPU:       Quad core Intel Core i7-2600K (-HT-MCP-) cache: 8192 KB
           clock speeds: max: 3800 MHz 1: 3499 MHz 2: 3500 MHz 3: 3499 MHz
           4: 3499 MHz 5: 3500 MHz 6: 3499 MHz 7: 3499 MHz 8: 3499 MHz
Graphics:  Card: NVIDIA GK104 [GeForce GTX 760]
           Display Server: X.Org 1.19.3 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on NVE4 GLX Version: 3.0 Mesa 17.0.2
Audio:     Card-1 NVIDIA GK104 HDMI Audio Controller driver: snd_hda_intel
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network:   Card: Intel 82579V Gigabit Network Connection driver: e1000e
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2120.4GB (2.1% used)
           ID-1: USB /dev/sda model: Expansion size: 2000.4GB
           ID-2: /dev/sdb model: KINGSTON_SH100S3 size: 120.0GB
Partition: ID-1: / size: 95G used: 27G (30%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 17.15GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 224 Uptime: 59 min Memory: 3236.0/16180.2MB
           Client: Shell (bash) inxi: 2.2.35

Ohh, nice command, dont think ive used that one yet.

Thanks again

Strange, im using nvidia 3.87 in other drivers, but shows the opensource one

https://s9.postimg.org/74aw8calb/Screenshot_2017-12-19_18_11_28.png


"Host: chad-desktop Kernel: 4.10.0-42-generic i686 (32 bit)"

Did i accidently install 32bit version?  I could of swore it was 64
« Last Edit: December 19, 2017, 09:32:33 pm by PCNetSpec, Reason: surrounded output with code tags »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "Shader model 3 must be supported"
« Reply #5 on: December 19, 2017, 09:31:32 pm »
can you post the output from
Code: [Select]
ubuntu-drivers list
and
Code: [Select]
ubuntu-drivers devices
and
Code: [Select]
dpkg -l | grep nvidia
and how exactly did you install the 387 drivers ?



And how open to the idea of starting again from scratch are you ? .. you seem to have installed 32bit Peppermint and you'd be MUCH better off with the 64bit version.
« Last Edit: December 19, 2017, 09:35:32 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: "Shader model 3 must be supported"
« Reply #6 on: December 19, 2017, 10:07:27 pm »
Code: [Select]
$ ubuntu-drivers list
nvidia-340
nvidia-387
nvidia-384
nvidia-381
intel-microcode

Code: [Select]
$ ubuntu-drivers devices
== cpu-microcode.py ==
driver   : intel-microcode - distro non-free

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
model    : GK104 [GeForce GTX 760]
modalias : pci:v000010DEd00001187sv00003842sd00002765bc03sc00i00
vendor   : NVIDIA Corporation
driver   : xserver-xorg-video-nouveau - distro free builtin
driver   : nvidia-381 - third-party free
driver   : nvidia-387 - third-party free recommended
driver   : nvidia-384 - third-party free
driver   : nvidia-340 - third-party free

Code: [Select]
dpkg -l | grep nvidia
rc  nvidia-384                                 384.98-0ubuntu0~gpu16.04.1                                  i386         NVIDIA binary driver - version 384.98
rc  nvidia-387                                 387.34-0ubuntu0~gpu16.04.2                                  i386         NVIDIA binary driver - version 387.34
rc  nvidia-opencl-icd-384                      384.98-0ubuntu0~gpu16.04.1                                  i386         NVIDIA OpenCL ICD
rc  nvidia-opencl-icd-387                      387.34-0ubuntu0~gpu16.04.2                                  i386         NVIDIA OpenCL ICD
ii  nvidia-prime                               0.8.2                                                       i386         Tools to enable NVIDIA's Prime
ii  nvidia-settings                            387.22-0ubuntu0~gpu16.04.1                                  i386         Tool for configuring the NVIDIA graphics driver

Ya, ill wipe out and put on 64 bit tonight or tomorrow.  Its a very fast install (great job on that), i was messing with my buddys old comp, forgot to make new drive it looks.  No need for 32bit on i7.

Thanks again for your help

I may have got them typing in the terminal, i think they showed up in additional drivers after i did that.  But wasnt working before.  Everything else is a great, just need to turn on my video card for my video game
« Last Edit: December 20, 2017, 08:02:28 am by PCNetSpec, Reason: enclosed output in CODE tags »

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5438
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: "Shader model 3 must be supported"
« Reply #7 on: December 20, 2017, 12:02:05 am »
Nice!

I evidently haven't checked my nVidia drivers for awhile - assumed they were magically taking care of themselves.

Turned out, I was actually running 'nvidia-384'  ::)

All fixed ...

Code: [Select]
╭─vindsl@Boogaloo-5 ~  
╰─➤  ubuntu-drivers list
nvidia-381
nvidia-387
nvidia-384
intel-microcode

╭─vindsl@Boogaloo-5 ~ 
╰─➤  ubuntu-drivers devices
== cpu-microcode.py ==
driver   : intel-microcode - distro non-free

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd0000128Bsv00003842sd00002712bc03sc00i00
vendor   : NVIDIA Corporation
driver   : nvidia-381 - third-party free
driver   : nvidia-384 - third-party free
driver   : xserver-xorg-video-nouveau - distro free builtin
driver   : nvidia-387 - third-party free recommended

╭─vindsl@Boogaloo-5 ~ 
╰─➤  dpkg -l | grep nvidia
ii  nvidia-387                                  387.34-0ubuntu0~gpu16.04.2                   amd64        NVIDIA binary driver - version 387.34
ii  nvidia-opencl-icd-387                       387.34-0ubuntu0~gpu16.04.2                   amd64        NVIDIA OpenCL ICD
ii  nvidia-settings                             387.22-0ubuntu0~gpu16.04.1                   amd64        Tool for configuring the NVIDIA graphics driver

Carry on  :)
« Last Edit: December 20, 2017, 01:31:54 am by VinDSL, Reason: Addendum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "Shader model 3 must be supported"
« Reply #8 on: December 20, 2017, 07:56:16 am »
Cool, give us a shout if you have the same problem with the 64bit version and we'll figure it out.

Currently you seem to have nvidia-settings and nvidia-prime installed, but not the drivers themselves.

You could install the drivers by running:
Code: [Select]
sudo apt-get install --reinstall nvidia-387 nvidia-opencl-icd-387
but I still think you'd be better off reinstalling with the 64bit Peppermint 8 Respin first
« Last Edit: December 20, 2017, 07:59:46 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: "Shader model 3 must be supported"
« Reply #9 on: December 20, 2017, 02:48:30 pm »
It reinstalled but no change.  For some reason it refuses to let go of the nouveau driver. 

Display Server: X.Org 1.19.3 drivers: nouveau (unloaded: fbdev,vesa)

No matter what i do this line never changes

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: "Shader model 3 must be supported"
« Reply #10 on: December 20, 2017, 03:42:15 pm »
64 bit is installed and video driver is working

I got my big fonts back though.  Something happens with 4k monitors.  I select 1920*1080, reboot and its back in 4k.  Do it again and my icons are still at 4k size.  Had same thing on peppermint 7.  Its like peppermint foces me to use my max monitor res (i hate 4k though for computer stuff)

One is 4k, one is 1080p.  Both are messed up now

https://postimg.org/gallery/22f4ozpuk/

Thanks


System:    Host: chad-desktop Kernel: 4.10.0-42-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   Mobo: Intel model: DZ68BC v: AAG30742-401
           Bios: Intel v: BCZ6810H.86A.0021.2011.0831.1555 date: 08/31/2011
CPU:       Quad core Intel Core i7-2600K (-HT-MCP-) cache: 8192 KB
           clock speeds: max: 3800 MHz 1: 1671 MHz 2: 1762 MHz 3: 1622 MHz
           4: 1848 MHz 5: 1600 MHz 6: 1892 MHz 7: 1626 MHz 8: 1659 MHz
Graphics:  Card: NVIDIA GK104 [GeForce GTX 760]
           Display Server: X.Org 1.19.3 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 760/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.90
Audio:     Card-1 NVIDIA GK104 HDMI Audio Controller driver: snd_hda_intel
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-42-generic
Network:   Card: Intel 82579V Gigabit Network Connection driver: e1000e
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2120.4GB (64.1% used)
           ID-1: /dev/sda model: KINGSTON_SH100S3 size: 120.0GB
           ID-2: USB /dev/sdb model: Expansion size: 2000.4GB
Partition: ID-1: / size: 95G used: 8.5G (10%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 17.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 44.0C mobo: N/A gpu: 54C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 227 Uptime: 23 min Memory: 1248.5/16021.7MB
           Client: Shell (bash) inxi: 2.2.35

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "Shader model 3 must be supported"
« Reply #11 on: December 20, 2017, 04:35:19 pm »
What's the output from:
Code: [Select]
cat /etc/X11/xorg.conf
?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: "Shader model 3 must be supported"
« Reply #12 on: December 20, 2017, 05:14:38 pm »
chad@chad-desktop ~ $ cat /etc/X11/xorg.conf
cat: /etc/X11/xorg.conf: No such file or directory

My game is playing better in pep8 and 64  bit runs so much smoother.  Only one problem left :)

Thanks again


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26267
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "Shader model 3 must be supported"
« Reply #13 on: December 20, 2017, 05:41:42 pm »
Okay run:
Code: [Select]
sudo nvidia-xconfig
and now post the output from:
Code: [Select]
cat /etc/X11/xorg.conf
you might at this point want to log off and on again to see if your graphics have gone screwy or not.

If they have, simply rename the xorg.conf file
Code: [Select]
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken
then log off/on again
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline chadwix

  • Jr. Member
  • **
  • Posts: 87
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 7 64bit
Re: "Shader model 3 must be supported"
« Reply #14 on: December 20, 2017, 05:50:25 pm »
Code: [Select]
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.90  (buildmeister@swio-display-x86-rhel47-05)  Tue Sep 19 18:13:03 PDT 2017

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

No change.  Everything works fine, just icons and txt got big.  I'll just turn my fonts down to size 8.  Looks fine that way.

https://s9.postimg.org/czwk6r17z/Screenshot_2017-12-20_17_59_39.png

Thanks again
« Last Edit: December 20, 2017, 07:35:11 pm by PCNetSpec »