Choose style:

Author Topic: Cannot hear bluetooth audio through paired headset  (Read 3891 times)

0 Members and 1 Guest are viewing this topic.

Offline sdgengineer

  • Jr. Member
  • **
  • Posts: 76
  • Karma: 3
  • Forum User
    • View Profile
    • Scott Gardner PE
  • Peppermint version(s): 1, 3, 4, 5, 6, 8, 9
Cannot hear bluetooth audio through paired headset
« on: July 07, 2014, 09:35:52 pm »
Hello

This is probably an easy kill, but I have not figured it out yet... I bought a Blue tooth USB adapter, Plugged it in, and the bluetooth manager in Preferences found it.  I can Pair to my blue tooth headset (I get the beep) but I cannot hear audio coming from the computer. I know the heaqdset is good, because I t connects fine to a Bluetooth enabled tablet.

How do I set the default audio output device?  (I want the audio to go to my bluetooth adapter vice the internal speakers or output jack.  I haven't found the option on the menu to configure input and output devices

Thanks

SDGengineer
No Job is impossible for the  person who doesn't have to do it!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Cannot hear bluetooth audio through paired headset
« Reply #1 on: July 08, 2014, 04:35:59 am »
The following instructions assume you're running Peppermint FIVE .. if you're using any other version STOP NOW and say which version.

OK, the version of blueman in 14.04 is totally screwed .. but luckily David Henningsson (diwic) has fixed it and put it in a PPA.

I've copied it to another PPA so if he decides to kill his PPA I've still got it

First install pulseaudio-module-bluetooth
Code: [Select]
sudo apt install pulseaudio-module-bluetooth

Now, add the PPA with
Code: [Select]
sudo add-apt-repository ppa:mark-pcnetspec/peppermint-blueman
then update
Code: [Select]
sudo apt update
then
Code: [Select]
sudo apt upgrade
Now REBOOT

run
Code: [Select]
sudo gedit /etc/bluetooth/audio.conf

make the [General] section read:-
Code: [Select]
# This section contains options which are not specific to any
# particular interface
[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true
SAVE the file and exit gedit.

Now with the Bluetooth Manager CLOSED .. restart the bluetooth service:
Code: [Select]
sudo service bluetooth restart

Now start the bluetooth manager .. right-click your (already paired) headphones and select "Audio Sink" and you should see "success" in the bottom left.

Fire up
menu > Sound & Video > PulseAudio Volume Control > Configuration (tab)

You should see your headphones listed .. in the drop menu select "High Fidelity Playback (A2DP)"
(in fact on my system it was listed twice, with the top one set to OFF, and the bottom one ALREADY set to "Hight Fidelity Playback (A2DP)" .. so I didn't need to do anything)

Test your headphones



Solution for Peppermint 4 here:
http://linuxforums.org.uk/index.php?topic=11831.msg94580#msg94580
« Last Edit: July 08, 2014, 04:45:23 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kendall

  • Developer
  • Member
  • *****
  • Posts: 535
  • Karma: 75
  • Peppermint Dev
    • View Profile
    • http://kendallweaver.com
Re: Cannot hear bluetooth audio through paired headset
« Reply #2 on: July 08, 2014, 10:34:17 am »
Should we try and correct this in a respin?
Co-Founder and CTO of Peppermint. Developer, Photographer, and spicy food lover.

Peppermint is powered by VPS.NET Cloud Servers.

Offline sdgengineer

  • Jr. Member
  • **
  • Posts: 76
  • Karma: 3
  • Forum User
    • View Profile
    • Scott Gardner PE
  • Peppermint version(s): 1, 3, 4, 5, 6, 8, 9
Re: Cannot hear bluetooth audio through paired headset
« Reply #3 on: July 08, 2014, 06:41:16 pm »
The following instructions assume you're running Peppermint FIVE .. if you're using any other version STOP NOW and say which version.

I apologize I should have told you I am running Peppermint 4. 
  I may be a newbie, but I should have stated that upfront.

OK, the version of blueman in 14.04 is totally screwed .. but luckily David Henningsson (diwic) has fixed it and put it in a PPA.

I've copied it to another PPA so if he decides to kill his PPA I've still got it

First install pulseaudio-module-bluetooth
Code: [Select]
sudo apt install pulseaudio-module-bluetooth

Now, add the PPA with
Code: [Select]
sudo add-apt-repository ppa:mark-pcnetspec/peppermint-blueman
then update
Code: [Select]
sudo apt update
then
Code: [Select]
sudo apt upgrade
Now REBOOT

run
Code: [Select]
sudo gedit /etc/bluetooth/audio.conf

make the [General] section read:-
Code: [Select]
# This section contains options which are not specific to any
# particular interface
[General]

# Switch to master role for incoming connections (defaults to true)
#Master=true
SAVE the file and exit gedit.

Now with the Bluetooth Manager CLOSED .. restart the bluetooth service:
Code: [Select]
sudo service bluetooth restart

Now start the bluetooth manager .. right-click your (already paired) headphones and select "Audio Sink" and you should see "success" in the bottom left.

Fire up
menu > Sound & Video > PulseAudio Volume Control > Configuration (tab)

You should see your headphones listed .. in the drop menu select "High Fidelity Playback (A2DP)"
(in fact on my system it was listed twice, with the top one set to OFF, and the bottom one ALREADY set to "Hight Fidelity Playback (A2DP)" .. so I didn't need to do anything)

Test your headphones



Solution for Peppermint 4 here:
http://linuxforums.org.uk/index.php?topic=11831.msg94580#msg94580
No Job is impossible for the  person who doesn't have to do it!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Cannot hear bluetooth audio through paired headset
« Reply #4 on: July 08, 2014, 07:15:20 pm »
See the link at the end of my previous post .. that should sort out bluetooth A2DP in Peppermint 4

here it is again:
http://linuxforums.org.uk/index.php?topic=11831.msg94580#msg94580
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline sdgengineer

  • Jr. Member
  • **
  • Posts: 76
  • Karma: 3
  • Forum User
    • View Profile
    • Scott Gardner PE
  • Peppermint version(s): 1, 3, 4, 5, 6, 8, 9
Re: Cannot hear bluetooth audio through paired headset
« Reply #5 on: July 08, 2014, 09:42:37 pm »
See the link at the end of my previous post .. that should sort out bluetooth A2DP in Peppermint 4

here it is again:
http://linuxforums.org.uk/index.php?topic=11831.msg94580#msg94580

Thanks

I tried this, but was unable to get it to connect...perhaps I have a bad Bluetooth adapter.  I thought I had a bigger problem.  Neither VLC or Gnomeplayer would play video.  They do play audio, but I have tried removing all the pulse audio packages and seeing if that will help.

After reinstalling the player packages.  I finally rebooted the computer and I am back to where I started.  I will continue this after I get a new bluetooth adapter

Thanks for your help..

SDG

No Job is impossible for the  person who doesn't have to do it!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Cannot hear bluetooth audio through paired headset
« Reply #6 on: July 08, 2014, 09:53:47 pm »
Have you considered moving to Peppermint 5 first .. in case it's not the bluetooth adapter.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crshortt

  • nOOb
  • *
  • Posts: 6
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: Cannot hear bluetooth audio through paired headset
« Reply #7 on: September 12, 2014, 07:08:27 pm »
Took me a minute, but this solved my exact same problem. I had to go to your link to find the final step (that being to go back to the Playback tab in the Volume Control and selecting my headphones for the active application), but all is great now!
« Last Edit: September 12, 2014, 07:44:49 pm by crshortt »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Cannot hear bluetooth audio through paired headset
« Reply #8 on: September 12, 2014, 07:51:35 pm »
Cool .. glad it helped :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline _tuter

  • Jr. Member
  • **
  • Posts: 92
  • Karma: 11
  • 18 yrs old - Distro Hopper - Peppermint Lover
    • View Profile
  • Peppermint version(s): Peppermint OS 6!!
Re: Cannot hear bluetooth audio through paired headset
« Reply #9 on: July 25, 2015, 10:57:35 pm »
Does anyone know if these instructions will also work on Pep OS 6?
:) _tuter :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Cannot hear bluetooth audio through paired headset
« Reply #10 on: July 27, 2015, 07:56:01 pm »
Dunno, and I haven't got any bluetooth headphones any more to test it with .. but why not give it a shot

The Peppermint 5 instructions, NOT the Peppermint 4 ones
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline configX

  • Jr. Member
  • **
  • Posts: 45
  • Karma: 17
  • New Forum User
    • View Profile
  • Peppermint version(s): Six
Re: Cannot hear bluetooth audio through paired headset
« Reply #11 on: August 04, 2015, 08:01:59 pm »
I also found that running this in terminal works too:
Code: [Select]
pactl load-module module-bluetooth-discover