Author Topic: Guayadeque missing plugins(solved)  (Read 9360 times)

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Guayadeque missing plugins(solved)
« on: July 06, 2014, 02:06:37 pm »
I installed P5 where I once had P4 a few days ago.
The default music player guayadeque will not play my .wma music files.
Synaptic Package Manager says it should in the discription.
When I try to play a file I get and error message telling me I'm missing a plugin, but doesn't say what plugins I need.
Guayadeque will play an audio CD and a MP3.
Can anyone help? I am really new to this. None of the links to guayadeque support forum seem to work off their Help tab.
« Last Edit: July 07, 2014, 01:29:40 pm by Ralph »
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins
« Reply #1 on: July 06, 2014, 02:42:15 pm »
I could be wrong here, but I doubt if you'll fix this...

From what I gather it needs gstreamer-ffmpeg which seems to have been dropped from 14.04  :-\

You'd be better off just installing VLC and using that as your media player .. VLC can play just about everyting.
Code: [Select]
sudo apt install vlc
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins
« Reply #2 on: July 06, 2014, 03:13:24 pm »
Thank you for the response.
Yes you are correct about VlC.
When I put in gstreamer ffmpeg into Synaptic Package Manager there are some choices.
Do you think any of those packages would work? I ask because I do not want to bork my system putting in something I shouldn't have.
A little knowledge is dangerous, I'm proof of it.

Offline rjm65

  • Veteran
  • ****
  • Posts: 1024
  • Karma: 313
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Guayadeque missing plugins
« Reply #3 on: July 06, 2014, 03:19:35 pm »
I use vlc on all my linux distros it seems to play everything i throw at it... I would trust in what mark said before about trying to get that other one to work because he knows his stuff...   ;)
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins
« Reply #4 on: July 06, 2014, 03:25:09 pm »
No, non of those will install gstreamer-ffmpeg .. they just mention "gstreamer" and "ffmpeg" in their descriptions.

Seriously .. choose another media player, or convert your wma files to mp3 ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins
« Reply #5 on: July 06, 2014, 03:34:17 pm »
I am going to do as you have suggested and thanks for the assistance.
I can not help but be confused as to why P5 would offer as their default music player something that can not fulfill its promises
If VLC is the answer why not just make that the default music player.
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins(unable to fix)
« Reply #6 on: July 06, 2014, 06:10:24 pm »
It's an upstream issue, so not much we can do about it

MPlayer (Media Player) which you also have by default can play WMA .. so WMA was covered, just not all in one player ;)
« Last Edit: July 06, 2014, 06:12:31 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins(unable to fix)
« Reply #7 on: July 07, 2014, 07:54:11 am »
So I'm just looking around the net at open source music players. One thing leads to another and under your own Software Manager I find Aqualung. Going to there website I find a FFmpeg project. http://ffmpeg.mplayerhq.hu/
By going to there download page I read this: Builds for 32-bit and 64-bit with kernel 3.2.x and above. Find it here: http://ffmpeg.mplayerhq.hu/download.html
Do you think, this might help out here or is it again just a waste of time.
A little knowledge is dangerous, I'm proof of it.

Offline kendall

  • Administrator
  • Member
  • *****
  • Posts: 656
  • Karma: 133
  • Co-Founder
    • View Profile
Re: Guayadeque missing plugins(unable to fix)
« Reply #8 on: July 07, 2014, 08:23:09 am »
This is definitely something that needs to be looked into for future releases and/or respins. During my pre-release testing I don't test .wma files as I don't use the format but the player advertises itself as supporting it so we need to at least try. Anyway, there's a newer upstream build of Guayadeque than is presently available in the repo so I need to look into packaging it or finding a PPA that already does so. Additionally I'll look into the license terms of the ffmpeg plugin linked above and see if a) it addresses the issue, and b) if we can legally distribute it in Peppermint.
Peppermint is powered by VPS.NET Cloud Servers.

Offline kendall

  • Administrator
  • Member
  • *****
  • Posts: 656
  • Karma: 133
  • Co-Founder
    • View Profile
Re: Guayadeque missing plugins(unable to fix)
« Reply #9 on: July 07, 2014, 08:50:11 am »
Alright, the specific fix to get .wma files working in Guayadeque is as follows:

Open a terminal and enter

Code: [Select]
sudo add-apt-repository ppa:mc3man/trusty-mediaAnd follow the on screen instructions to add the repository. After doing this enter

Code: [Select]
apt update
apt install ffmpeg gstreamer0.10-ffmpeg
Finally close and reopen all instances of Guayadeque and it should be good.

EDIT: We'll have a conversation amongst the Peppermint team to determine if we should include this by default in the future or if we should pursue another avenue such as using a different media player.

EDIT 2: I've been unable to duplicate the fix on an otherwise clean install of Peppermint Five so while the above fix worked on my system, it's not guaranteed to work on others. It's entirely possible that something I've done in the past couple of weeks was partially responsible for the fix as well. I'll continue to investigate the issue and an official tutorial will be posted if/when we come up with a proper solution to the issue. For the time being, it's probably best to either convert WMA files or use another media player such as VLC.
« Last Edit: July 07, 2014, 01:56:10 pm by kendall »
Peppermint is powered by VPS.NET Cloud Servers.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins(unable to fix)
« Reply #10 on: July 07, 2014, 11:36:29 am »
I installed gstreamer0.10-ffmpeg from that PPA last night whilst researching this topic .. made no difference for me, I still got the warnings about the missing gstreamer plugin (even after a reboot).

So if that PPA is fixing it, more must be getting installed than just gstreamer0.10-ffmpeg

I personally wouldn't recommend adding a PPA with the amount of packages that one contains .. but that's just me :)
« Last Edit: July 07, 2014, 11:44:25 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 131
  • Karma: 8
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins(solved)
« Reply #11 on: July 07, 2014, 01:54:39 pm »
What to do? Two different opinions. What do I have to loose? Not much. So I followed Kendall's advice and installed the ppa just to see if it would work. They say the definition of insanity is doing the same thing over and over an expecting a different result. Low and behold it worked for me. Yippee!!
FWIW here is the output in case you are interested.
Spoiler (click here to view / hide)
[close]
You will notice I made a typo at the first apt install ffmpeg gstreamer0.10-ffmpeg entry.
Thanks to all for all  your helpful support and advice. This is what I like about Peppermint.
A little knowledge is dangerous, I'm proof of it.

Offline kendall

  • Administrator
  • Member
  • *****
  • Posts: 656
  • Karma: 133
  • Co-Founder
    • View Profile
Re: Guayadeque missing plugins(solved)
« Reply #12 on: July 07, 2014, 02:04:01 pm »
Excellent. I'm glad it worked for you. Hopefully we'll be able to do a little more research on it and get an official tutorial up at some point in the near future.
Peppermint is powered by VPS.NET Cloud Servers.

Offline mc4man

  • Newly Subscribed
  • *
  • Posts: 1
  • Karma: 1
  • New Forum User
    • View Profile
Re: Guayadeque missing plugins(solved)
« Reply #13 on: October 19, 2014, 08:42:54 am »
Re: the trusty multimedia ppa which is mine.
You can pick & choose upgrades as desired instead of the whole ppa. (though I've tested everything fairly well.
I would in that case recommend using a package manager. There are some packages there, vlc for example, that occasionally require new packages so a terminal apt-get upgrade or apt-get install would not work correctly ( one would need to use apt-get dist-upgrade instead

I don't intend to put the gst-ffmpeg plugin in a standalone though anyone is free to do so.
As far as  Guayadeque the ppa has a new trusty build which amounts to the current latest svn 1893 & some minor improvements (0.3.7-1.1
Ck. the suggests for fuller codec support..
 

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5843
  • Karma: 1132
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Guayadeque missing plugins(solved)
« Reply #14 on: October 19, 2014, 10:33:32 am »
Welcome aboard, Doug.    8)