Choose style:

Author Topic: Guayadeque missing plugins(solved)  (Read 8834 times)

0 Members and 1 Guest are viewing this topic.

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Guayadeque missing plugins(solved)
« on: July 06, 2014, 05:06:37 pm »
I installed P5 where I once had P4 a few days ago.
The default music player guayadeque will not play my .wma music files.
Synaptic Package Manager says it should in the discription.
When I try to play a file I get and error message telling me I'm missing a plugin, but doesn't say what plugins I need.
Guayadeque will play an audio CD and a MP3.
Can anyone help? I am really new to this. None of the links to guayadeque support forum seem to work off their Help tab.
« Last Edit: July 07, 2014, 04:29:40 pm by Ralph »
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26266
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins
« Reply #1 on: July 06, 2014, 05:42:15 pm »
I could be wrong here, but I doubt if you'll fix this...

From what I gather it needs gstreamer-ffmpeg which seems to have been dropped from 14.04  :-\

You'd be better off just installing VLC and using that as your media player .. VLC can play just about everyting.
Code: [Select]
sudo apt install vlc
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins
« Reply #2 on: July 06, 2014, 06:13:24 pm »
Thank you for the response.
Yes you are correct about VlC.
When I put in gstreamer ffmpeg into Synaptic Package Manager there are some choices.
Do you think any of those packages would work? I ask because I do not want to bork my system putting in something I shouldn't have.
A little knowledge is dangerous, I'm proof of it.

Offline rjm65

  • Veteran
  • ****
  • Posts: 1004
  • Karma: 300
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Guayadeque missing plugins
« Reply #3 on: July 06, 2014, 06:19:35 pm »
I use vlc on all my linux distros it seems to play everything i throw at it... I would trust in what mark said before about trying to get that other one to work because he knows his stuff...   ;)
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26266
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins
« Reply #4 on: July 06, 2014, 06:25:09 pm »
No, non of those will install gstreamer-ffmpeg .. they just mention "gstreamer" and "ffmpeg" in their descriptions.

Seriously .. choose another media player, or convert your wma files to mp3 ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins
« Reply #5 on: July 06, 2014, 06:34:17 pm »
I am going to do as you have suggested and thanks for the assistance.
I can not help but be confused as to why P5 would offer as their default music player something that can not fulfill its promises
If VLC is the answer why not just make that the default music player.
A little knowledge is dangerous, I'm proof of it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26266
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins(unable to fix)
« Reply #6 on: July 06, 2014, 09:10:24 pm »
It's an upstream issue, so not much we can do about it

MPlayer (Media Player) which you also have by default can play WMA .. so WMA was covered, just not all in one player ;)
« Last Edit: July 06, 2014, 09:12:31 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins(unable to fix)
« Reply #7 on: July 07, 2014, 10:54:11 am »
So I'm just looking around the net at open source music players. One thing leads to another and under your own Software Manager I find Aqualung. Going to there website I find a FFmpeg project. http://ffmpeg.mplayerhq.hu/
By going to there download page I read this: Builds for 32-bit and 64-bit with kernel 3.2.x and above. Find it here: http://ffmpeg.mplayerhq.hu/download.html
Do you think, this might help out here or is it again just a waste of time.
A little knowledge is dangerous, I'm proof of it.

Offline kendall

  • Developer
  • Member
  • *****
  • Posts: 535
  • Karma: 75
  • Peppermint Dev
    • View Profile
    • http://kendallweaver.com
Re: Guayadeque missing plugins(unable to fix)
« Reply #8 on: July 07, 2014, 11:23:09 am »
This is definitely something that needs to be looked into for future releases and/or respins. During my pre-release testing I don't test .wma files as I don't use the format but the player advertises itself as supporting it so we need to at least try. Anyway, there's a newer upstream build of Guayadeque than is presently available in the repo so I need to look into packaging it or finding a PPA that already does so. Additionally I'll look into the license terms of the ffmpeg plugin linked above and see if a) it addresses the issue, and b) if we can legally distribute it in Peppermint.
Co-Founder and CTO of Peppermint. Developer, Photographer, and spicy food lover.

Peppermint is powered by VPS.NET Cloud Servers.

Offline kendall

  • Developer
  • Member
  • *****
  • Posts: 535
  • Karma: 75
  • Peppermint Dev
    • View Profile
    • http://kendallweaver.com
Re: Guayadeque missing plugins(unable to fix)
« Reply #9 on: July 07, 2014, 11:50:11 am »
Alright, the specific fix to get .wma files working in Guayadeque is as follows:

Open a terminal and enter

Code: [Select]
sudo add-apt-repository ppa:mc3man/trusty-media
And follow the on screen instructions to add the repository. After doing this enter

Code: [Select]
apt update
apt install ffmpeg gstreamer0.10-ffmpeg
Finally close and reopen all instances of Guayadeque and it should be good.

EDIT: We'll have a conversation amongst the Peppermint team to determine if we should include this by default in the future or if we should pursue another avenue such as using a different media player.

EDIT 2: I've been unable to duplicate the fix on an otherwise clean install of Peppermint Five so while the above fix worked on my system, it's not guaranteed to work on others. It's entirely possible that something I've done in the past couple of weeks was partially responsible for the fix as well. I'll continue to investigate the issue and an official tutorial will be posted if/when we come up with a proper solution to the issue. For the time being, it's probably best to either convert WMA files or use another media player such as VLC.
« Last Edit: July 07, 2014, 04:56:10 pm by kendall »
Co-Founder and CTO of Peppermint. Developer, Photographer, and spicy food lover.

Peppermint is powered by VPS.NET Cloud Servers.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26266
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Guayadeque missing plugins(unable to fix)
« Reply #10 on: July 07, 2014, 02:36:29 pm »
I installed gstreamer0.10-ffmpeg from that PPA last night whilst researching this topic .. made no difference for me, I still got the warnings about the missing gstreamer plugin (even after a reboot).

So if that PPA is fixing it, more must be getting installed than just gstreamer0.10-ffmpeg

I personally wouldn't recommend adding a PPA with the amount of packages that one contains .. but that's just me :)
« Last Edit: July 07, 2014, 02:44:25 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ralph

  • Member
  • ***
  • Posts: 130
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): I've used 4,5,6,7,8,9
Re: Guayadeque missing plugins(solved)
« Reply #11 on: July 07, 2014, 04:54:39 pm »
What to do? Two different opinions. What do I have to loose? Not much. So I followed Kendall's advice and installed the ppa just to see if it would work. They say the definition of insanity is doing the same thing over and over an expecting a different result. Low and behold it worked for me. Yippee!!
FWIW here is the output in case you are interested.
Spoiler (click here to view / hide)
z@cracker ~ $ sudo add-apt-repository ppa:mc3man/trusty-media
[sudo] password for buz:
Sorry, try again.
[sudo] password for buz:
 Upgraded, advanced or not normally available multimedia packages for Trusty

A few notes:
gstreamer0.10-ffmpeg - needed for some apps that still use gstreamer-0.10 & also provides h.264 in html5 decoding for firefox < 30.
Note that Firefox 30 will support h.264 in html5 thru gstreamer1.0-libav & should be available soon

Totem+grilo - it's quite possible this & RB+grilo will show in 14.04 by first point release, if so will probably remove. Also note some plugins work well, some don't at all, bit of a mess

rhythmbox+grilo - needs to be enabled in rhythmbox > tools > plugins
Plus install grilo-plugins if not already

mpv - described here, add. info links
https://launchpad.net/~mc3man/+archive/mpv-tests
The mpv build in this ppa uses quvi0.9, the above linked ppa quvi0.4

*Note* - Osc config options now go into ~/.mpv/lua-settings/osc.config
refer to manpage or pdf in /usr/share/doc/mpv

mplayer - described here, note mencoder is not inc. & likely will not be, you may be able to use repo mencoder..
https://launchpad.net/~mc3man/+archive/mplayer-test

fdkaac (fdkaac-encoder) - described here
https://launchpad.net/~mc3man/+archive/fdkaac-encoder

x264 - for use with ffmpeg from here, supports both 8 & 10 bit encoding

ffmpeg -
a static build for use of the binaries, installed to /opt/ffmpeg
binaries are symlinked in /usr/bin (ffmpeg, ffplay, ffprobe

For info on using libfdk_aac see here -
http://trac.ffmpeg.org/wiki/Encode/AAC

Can be used for both 8 & 10 bit x264 encoding with this ppa's libx264, default is 8
For 10 bit preload the 10 bit .so first in terminal, eg.,
export LD_PRELOAD=/usr/lib/x86_64-linux-gnu/x264-10bit/libx264.so.142
or
export LD_PRELOAD=/usr/lib/i386-linux-gnu/x264-10bit/libx264.so.142

libav - has fdkaac encoding enabled

yasm -
 has been patched to improve compiling x265

K9copy -
Mainly for ripping, as far as encoding there are better apps. If inclined to use for encoding then use mencoder as ffmpeg support is quite limited

I also recommend for gstreamer & vlc  users checking out this ppa for h265 support in gst & a vlc plugin (vlc-libde265
https://launchpad.net/~strukturag/+archive/libde265

For rhythmbox users a wide range of plugins can be found here -
https://launchpad.net/~fossfreedom/+archive/rhythmbox-plugins

An excellent  audio recorder is available here -
https://launchpad.net/~osmoma/+archive/audio-recorder

A good blender ppa is here -
 https://launchpad.net/~irie/+archive/blender

 More info: https://launchpad.net/~mc3man/+archive/trusty-media
Press [ENTER] to continue or ctrl-c to cancel adding it
apt update
gpg: keyring `/tmp/tmp72mxvc1y/secring.gpg' created
gpg: keyring `/tmp/tmp72mxvc1y/pubring.gpg' created
gpg: requesting key ED8E640A from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp72mxvc1y/trustdb.gpg: trustdb created
gpg: key ED8E640A: public key "Launchpad PPA for Doug McMahon" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
buz@cracker ~ $ apt install ffmpeg gstreamer0.1o-ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/multiverse i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/universe i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/restricted i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/main i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
E: Package 'ffmpeg' has no installation candidate
E: Unable to locate package gstreamer0.1o-ffmpeg
E: Couldn't find any package by regex 'gstreamer0.1o-ffmpeg'
buz@cracker ~ $ apt install ffmpeg gstreamer0.10-ffmeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'ffmpeg' has no installation candidate
E: Unable to locate package gstreamer0.10-ffmeg
E: Couldn't find any package by regex 'gstreamer0.10-ffmeg'
buz@cracker ~ $ apt update
Ign http://security.ubuntu.com trusty-security InRelease
Ign http://us.archive.ubuntu.com trusty InRelease                             
Hit http://security.ubuntu.com trusty-security Release.gpg                     
Ign http://us.archive.ubuntu.com trusty-updates InRelease                     
Ign http://extras.ubuntu.com trusty InRelease                                 
Hit http://security.ubuntu.com trusty-security Release                         
Ign http://us.archive.ubuntu.com trusty-backports InRelease         
Ign http://ppa.launchpad.net trusty InRelease                                 
Hit http://us.archive.ubuntu.com trusty Release.gpg                           
Get:1 http://extras.ubuntu.com trusty Release.gpg [72 B]                       
Get:2 http://us.archive.ubuntu.com trusty-updates Release.gpg [933 B]         
Ign http://ppa.launchpad.net trusty InRelease                                 
Hit http://security.ubuntu.com trusty-security/main Sources         
Hit http://us.archive.ubuntu.com trusty-backports Release.gpg       
Hit http://extras.ubuntu.com trusty Release                                   
Hit http://security.ubuntu.com trusty-security/restricted Sources             
Hit http://us.archive.ubuntu.com trusty Release                     
Ign http://ppa.launchpad.net trusty InRelease                                 
Hit http://security.ubuntu.com trusty-security/universe Sources               
Get:3 http://us.archive.ubuntu.com trusty-updates Release [58.5 kB]           
Hit http://extras.ubuntu.com trusty/main Sources                               
Hit http://security.ubuntu.com trusty-security/multiverse Sources             
Get:4 http://ppa.launchpad.net trusty Release.gpg [316 B]                     
Hit http://security.ubuntu.com trusty-security/main i386 Packages             
Hit http://extras.ubuntu.com trusty/main i386 Packages                         
Hit http://security.ubuntu.com trusty-security/restricted i386 Packages       
Hit http://ppa.launchpad.net trusty Release.gpg                               
Hit http://security.ubuntu.com trusty-security/universe i386 Packages         
Hit http://us.archive.ubuntu.com trusty-backports Release                     
Hit http://security.ubuntu.com trusty-security/multiverse i386 Packages       
Hit http://ppa.launchpad.net trusty Release.gpg                               
Hit http://us.archive.ubuntu.com trusty/main Sources                           
Hit http://us.archive.ubuntu.com trusty/restricted Sources                     
Get:5 http://ppa.launchpad.net trusty Release [14.0 kB]                       
Hit http://security.ubuntu.com trusty-security/main Translation-en             
Hit http://us.archive.ubuntu.com trusty/universe Sources                       
Hit http://us.archive.ubuntu.com trusty/multiverse Sources                     
Hit http://ppa.launchpad.net trusty Release                           
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en       
Hit http://us.archive.ubuntu.com trusty/main i386 Packages                     
Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages               
Hit http://ppa.launchpad.net trusty Release                                   
Hit http://security.ubuntu.com trusty-security/restricted Translation-en       
Hit http://us.archive.ubuntu.com trusty/universe i386 Packages                 
Get:6 http://ppa.launchpad.net trusty/main i386 Packages [40.6 kB]   
Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages               
Hit http://security.ubuntu.com trusty-security/universe Translation-en         
Hit http://us.archive.ubuntu.com trusty/main Translation-en                   
Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en             
Ign http://extras.ubuntu.com trusty/main Translation-en_US                     
Hit http://ppa.launchpad.net trusty/main i386 Packages               
Hit http://us.archive.ubuntu.com trusty/restricted Translation-en     
Ign http://extras.ubuntu.com trusty/main Translation-en               
Hit http://us.archive.ubuntu.com trusty/universe Translation-en       
Get:7 http://us.archive.ubuntu.com trusty-updates/main Sources [81.5 kB]
Hit http://ppa.launchpad.net trusty/main i386 Packages                       
Get:8 http://us.archive.ubuntu.com trusty-updates/restricted Sources [14 B]   
Get:9 http://us.archive.ubuntu.com trusty-updates/universe Sources [60.1 kB]   
Ign http://security.ubuntu.com trusty-security/main Translation-en_US         
Ign http://security.ubuntu.com trusty-security/multiverse Translation-en_US   
Get:10 http://us.archive.ubuntu.com trusty-updates/multiverse Sources [2,681 B]
Ign http://security.ubuntu.com trusty-security/restricted Translation-en_US   
Get:11 http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages [14 B]
Ign http://security.ubuntu.com trusty-security/universe Translation-en_US
Get:12 http://us.archive.ubuntu.com trusty-updates/main i386 Packages [212 kB]
Get:13 http://us.archive.ubuntu.com trusty-updates/universe i386 Packages [154 kB]
Get:14 http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages [7,569 B]
Get:15 http://us.archive.ubuntu.com trusty-updates/main Translation-en [98.2 kB]
Hit http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en     
Hit http://us.archive.ubuntu.com trusty-updates/restricted Translation-en     
Hit http://us.archive.ubuntu.com trusty-updates/universe Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/main Sources
Hit http://us.archive.ubuntu.com trusty-backports/restricted Sources
Hit http://us.archive.ubuntu.com trusty-backports/universe Sources
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Sources
Hit http://us.archive.ubuntu.com trusty-backports/main i386 Packages
Ign http://ppa.launchpad.net trusty/main Translation-en_US
Hit http://us.archive.ubuntu.com trusty-backports/restricted i386 Packages
Ign http://ppa.launchpad.net trusty/main Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages
Ign http://ppa.launchpad.net trusty/main Translation-en_US
Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-en_US
Hit http://us.archive.ubuntu.com trusty-backports/restricted Translation-en
Ign http://ppa.launchpad.net trusty/main Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/universe Translation-en
Ign http://us.archive.ubuntu.com trusty/main Translation-en_US                 
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US           
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US           
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US             
Ign http://us.archive.ubuntu.com trusty-updates/main Translation-en_US         
Ign http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en_US   
Ign http://us.archive.ubuntu.com trusty-updates/restricted Translation-en_US   
Ign http://us.archive.ubuntu.com trusty-updates/universe Translation-en_US     
Ign http://us.archive.ubuntu.com trusty-backports/main Translation-en_US       
Ign http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com trusty-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com trusty-backports/universe Translation-en_US   
Fetched 731 kB in 8s (86.6 kB/s)                                               
Reading package lists... Done
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/multiverse i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_multiverse_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/universe i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_universe_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/restricted i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_restricted_binary-i386_Packages)
W: Duplicate sources.list entry http://security.ubuntu.com/ubuntu/ trusty-security/main i386 Packages (/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_trusty-security_main_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
buz@cracker ~ $ apt install ffmpeg gstreamer0.10-ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libass5 libfdk-aac0 libsoxr0
The following NEW packages will be installed:
  ffmpeg gstreamer0.10-ffmpeg libass5 libfdk-aac0 libsoxr0
0 upgraded, 5 newly installed, 0 to remove and 9 not upgraded.
Need to get 26.4 MB of archives.
After this operation, 84.8 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty/universe libsoxr0 i386 0.1.1-1 [93.6 kB]
Get:2 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu/ trusty/main libfdk-aac0 i386 0.1.3.1 [321 kB]
Get:3 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu/ trusty/main libass5 i386 0.11.2~ppa1 [59.0 kB]
Get:4 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu/ trusty/main ffmpeg i386 7:2.2.4+git~trusty1 [23.3 MB]
Get:5 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu/ trusty/main gstreamer0.10-ffmpeg i386 0.10.13-5ubuntu1~trusty2 [2,585 kB]
Fetched 26.4 MB in 41s (636 kB/s)                                             
Selecting previously unselected package libfdk-aac0:i386.
(Reading database ... 162456 files and directories currently installed.)
Preparing to unpack .../libfdk-aac0_0.1.3.1_i386.deb ...
Unpacking libfdk-aac0:i386 (0.1.3.1) ...
Selecting previously unselected package libsoxr0:i386.
Preparing to unpack .../libsoxr0_0.1.1-1_i386.deb ...
Unpacking libsoxr0:i386 (0.1.1-1) ...
Selecting previously unselected package libass5:i386.
Preparing to unpack .../libass5_0.11.2~ppa1_i386.deb ...
Unpacking libass5:i386 (0.11.2~ppa1) ...
Selecting previously unselected package ffmpeg.
Preparing to unpack .../ffmpeg_7%3a2.2.4+git~trusty1_i386.deb ...
Unpacking ffmpeg (7:2.2.4+git~trusty1) ...
Selecting previously unselected package gstreamer0.10-ffmpeg:i386.
Preparing to unpack .../gstreamer0.10-ffmpeg_0.10.13-5ubuntu1~trusty2_i386.deb ...
Unpacking gstreamer0.10-ffmpeg:i386 (0.10.13-5ubuntu1~trusty2) ...
Setting up libfdk-aac0:i386 (0.1.3.1) ...
Setting up libsoxr0:i386 (0.1.1-1) ...
Setting up libass5:i386 (0.11.2~ppa1) ...
Setting up ffmpeg (7:2.2.4+git~trusty1) ...
Setting up gstreamer0.10-ffmpeg:i386 (0.10.13-5ubuntu1~trusty2) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...
buz@cracker ~ $
[close]
You will notice I made a typo at the first apt install ffmpeg gstreamer0.10-ffmpeg entry.
Thanks to all for all  your helpful support and advice. This is what I like about Peppermint.
A little knowledge is dangerous, I'm proof of it.

Offline kendall

  • Developer
  • Member
  • *****
  • Posts: 535
  • Karma: 75
  • Peppermint Dev
    • View Profile
    • http://kendallweaver.com
Re: Guayadeque missing plugins(solved)
« Reply #12 on: July 07, 2014, 05:04:01 pm »
Excellent. I'm glad it worked for you. Hopefully we'll be able to do a little more research on it and get an official tutorial up at some point in the near future.
Co-Founder and CTO of Peppermint. Developer, Photographer, and spicy food lover.

Peppermint is powered by VPS.NET Cloud Servers.

Offline mc4man

  • nOOb
  • *
  • Posts: 1
  • Karma: 1
  • New Forum User
    • View Profile
Re: Guayadeque missing plugins(solved)
« Reply #13 on: October 19, 2014, 11:42:54 am »
Re: the trusty multimedia ppa which is mine.
You can pick & choose upgrades as desired instead of the whole ppa. (though I've tested everything fairly well.
I would in that case recommend using a package manager. There are some packages there, vlc for example, that occasionally require new packages so a terminal apt-get upgrade or apt-get install would not work correctly ( one would need to use apt-get dist-upgrade instead

I don't intend to put the gst-ffmpeg plugin in a standalone though anyone is free to do so.
As far as  Guayadeque the ppa has a new trusty build which amounts to the current latest svn 1893 & some minor improvements (0.3.7-1.1
Ck. the suggests for fuller codec support..
 

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5438
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Guayadeque missing plugins(solved)
« Reply #14 on: October 19, 2014, 01:33:32 pm »
Welcome aboard, Doug.    8)