Choose style:

Author Topic: PM5 always pausing at start-up  (Read 5752 times)

0 Members and 1 Guest are viewing this topic.

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
PM5 always pausing at start-up
« on: July 02, 2014, 05:54:00 pm »
Hi, not sure if this should be in Installation or Hardware forum.

On PM4, I had lightening fast startup time.

With PM5, it is fast - but not as fast as before, at it always pauses now on start-up. I have duel boot (with Win 7) and on choosing the top option (PM5) it says 'Scanning for BTFRS file system...' for several seconds. Then the monitor says 'Entering power save mode' (as if it were rebooting) - then after a few more seconds it boots into PM5.

This isn't a huge deal as it does work - I'm just not sure why it's searching for BTFRS filesystem at startup, or then goes to 'entering power save mode', as it feels like an unnecessary pause, especially compared with PM4 where I don't recall either of these 2 things happening - I just booted straight into PM4 (on choosing top option from grub).

Not a huge deal just kind of curious.  :-\

Thanks if you have any advice/ideas.  :)

Off-topic but FYI - the Quote/Modify/Remove buttons that appear AFTER my post don't work. Only the ones above it do. This was the same on another post I tried to modify.. Just an fyi.
« Last Edit: July 02, 2014, 05:58:50 pm by mattosensei »

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5449
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: PM5 always pausing at start-up
« Reply #1 on: July 02, 2014, 09:31:00 pm »
This isn't a huge deal as it does work - I'm just not sure why it's searching for BTFRS filesystem at startup, or then goes to 'entering power save mode', as it feels like an unnecessary pause, especially compared with PM4 where I don't recall either of these 2 things happening - I just booted straight into PM4 (on choosing top option from grub).

Here's how I get rid of it...   ;)

Code: [Select]
$ sudo apt-get purge btrfs-tools
Then, reboot.


WARNING:  DO NOT do this if you're running a Butterface file system...
« Last Edit: July 03, 2014, 09:00:35 am by VinDSL, Reason: Addendum »

Offline ronj1950

  • Jr. Member
  • **
  • Posts: 58
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5/32 bit
Re: PM5 always pausing at start-up
« Reply #2 on: July 03, 2014, 07:31:44 am »
Hello All,

I routinely start up PM5 at the same time I start up my Verizon HotSpot, and even with it doing this file search, it gets to the desktop before wi fi signal is established.

Any down side to dis-engaging BTFRS filesystem search?  I do notice a copy of files listed but PM5 is so fast can not really read.

Regards,

Ron
rej

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: PM5 always pausing at start-up
« Reply #3 on: July 03, 2014, 08:18:36 am »
There would  be a MAJOR downside if you installed using the btrfs file system .. but unless you manually set up the partitions and chose btrfs as the file system you won't be (the installer defaults to the "ext4" file system)

You can check with:
Code: [Select]
sudo blkid
and look for
TYPE="btrfs"

Or install and use gparted to list the partitions on your hard drive .. then look under "File System" for any partitions listed as btrfs .. as in this pic



If you haven't any, it's safe to remove btrfs-tools

But you won't be using btrfs unless you SPECIFICALLY chose it.
« Last Edit: July 03, 2014, 08:27:23 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ronj1950

  • Jr. Member
  • **
  • Posts: 58
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5/32 bit
Re: PM5 always pausing at start-up
« Reply #4 on: July 03, 2014, 08:50:39 am »
Hey PCNetSpec,

Yes, I used the default installer after getting live session established; the blkid command indicates ext4 .. I did the purge command and rebooted, and here I am.

Thank you.

Ron
rej

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: PM5 always pausing at start-up
« Reply #5 on: July 03, 2014, 12:27:12 pm »
For my part you're welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: PM5 always pausing at start-up
« Reply #6 on: July 03, 2014, 03:30:22 pm »
This isn't a huge deal as it does work - I'm just not sure why it's searching for BTFRS filesystem at startup, or then goes to 'entering power save mode', as it feels like an unnecessary pause, especially compared with PM4 where I don't recall either of these 2 things happening - I just booted straight into PM4 (on choosing top option from grub).

Here's how I get rid of it...   ;)

Code: [Select]
$ sudo apt-get purge btrfs-tools
Then, reboot.


WARNING:  DO NOT do this if you're running a Butterface file system...

Thanks. I did that and it gets rid of the message. There is still what feels like a perceptible pause - but that might just be the lack of a splash screen and in fact the operating system is just loading in the background as normal. I guess even on SSD, I shouldn't expect it to be instant.

Offline ronj1950

  • Jr. Member
  • **
  • Posts: 58
  • Karma: 4
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 5/32 bit
Re: PM5 always pausing at start-up
« Reply #7 on: July 03, 2014, 03:36:06 pm »
Yea .. Mattosensel .. in a similar post on Peppermint 4, I noted that on same netbook if I let it go to Windows Starter 7, I have lots of time to go to the potty, and even get my coffee going.

Start time does not bother me at all .. in the routine use, I have to wait for hotspot any way.
rej

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5449
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: PM5 always pausing at start-up
« Reply #8 on: July 03, 2014, 03:52:06 pm »
I guess even on SSD, I shouldn't expect it to be instant.

I have a SSD in my Dell Latitude ATG D630 -- boots in 11 sec. on Peppermint -- if that gives you any indication.  ;)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: PM5 always pausing at start-up
« Reply #9 on: July 03, 2014, 04:14:13 pm »
Just the fact that you have an SSD doesn't necessarily mean anything on its own....

I have an SSD on the Acer Aspire One zg5 .. and as it's an IDE SSD it's slower than the HDD model :(
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline mattosensei

  • Member
  • ***
  • Posts: 222
  • Karma: 28
  • Linux with 'L' plates
    • View Profile
  • Peppermint version(s): 6
Re: PM5 always pausing at start-up
« Reply #10 on: July 03, 2014, 04:44:44 pm »
Powering up from scratch I timed it at 24 seconds. That's me hitting return as soon as the grub window pops up.

I can live with that - I'm just sure it was faster in PM4  ;)

PS Another difference may be that I had the 32 bit edition last time round. This time I installed the 64 bit one.


Code: [Select]
ms@ms-LINUX-DESKTOP ~ $ inxi -F
System:    Host: ms-LINUX-DESKTOP Kernel: 3.13.0-30-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Five
Machine:   Mobo: ASUSTeK model: P8Z77-V LX version: Rev X.0x Bios: American Megatrends version: 2204 date: 08/14/2013
CPU:       Quad core Intel Core i5-2500K CPU (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
           Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Pitcairn PRO [Radeon HD 7850]
           X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1680x1050@59.9hz
           GLX Renderer: Gallium 0.4 on AMD PITCAIRN GLX Version: 3.0 Mesa 10.1.3
Audio:     Card-1: Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel
           Card-2: Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-30-generic
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlan0 state: up mac: f8:d1:11:89:1e:6a
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: down mac: c8:60:00:c3:0d:77
Drives:    HDD Total Size: 332.0GB (2.4% used) 1: id: /dev/sda model: M4 size: 128.0GB
           2: id: /dev/sdb model: Maxtor_6V200E0 size: 203.9GB
Partition: ID: / size: 28G used: 7.5G (29%) fs: ext4 ID: swap-1 size: 4.71GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 38.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 158 Uptime: 1 min Memory: 610.9/7933.1MB Client: Shell (bash) inxi: 1.9.17
ms@ms-LINUX-DESKTOP ~ $

« Last Edit: July 03, 2014, 04:50:10 pm by mattosensei »

Offline rjm65

  • Veteran
  • ****
  • Posts: 1004
  • Karma: 300
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: PM5 always pausing at start-up
« Reply #11 on: July 03, 2014, 05:08:09 pm »
My linux boxes all average around 49 seconds to boot up, and I run all sata drives and some ide drives, I don't own an SSD like you do, and 24 seconds I think is super fast, and vindsl 11 secs is just like WOW....   ;)
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5449
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: PM5 always pausing at start-up
« Reply #12 on: July 03, 2014, 07:07:18 pm »
[...] and vindsl 11 secs is just like WOW  ;)

I usually post some proof, when I make declarations like that, but I was on the trot and it had to wait until I returned home.

I'm back on my Peppermint 5 lappy now.  Here's proof, using BootChart (available in the repos) -- 10 sec. boot today...   ;D

Spoiler (click here to view / hide)

(click image to enlarge)

[close]

@mattosensei: BootChart should show you where the hangup is.  That's it's primary purpose...
« Last Edit: July 03, 2014, 09:51:46 pm by VinDSL, Reason: Added Spoiler Tag »

Offline rjm65

  • Veteran
  • ****
  • Posts: 1004
  • Karma: 300
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: PM5 always pausing at start-up
« Reply #13 on: July 04, 2014, 08:40:41 am »
I'm back on my Peppermint 5 lappy now.  Here's proof, using BootChart (available in the repos) -- 10 sec. boot today...   ;D

Is that a special program you have there that tracks your boot up time, and what is the name of it? I would like to test out my laptops...  ;)
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5449
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: PM5 always pausing at start-up
« Reply #14 on: July 04, 2014, 11:09:09 am »
Is that a special program you have there that tracks your boot up time, and what is the name of it? I would like to test out my laptops...  ;)

Yes, a very special utility.  It autoruns at boot and charts everything that's happening, and how long it takes -- hence, the name -- 'bootchart'.

It's available in the default repos.  Just do a search in Synaptic...   ;)