Choose style:

Author Topic: Video Tearing while SLI fishing on SKYLAKE  (Read 1045 times)

0 Members and 1 Guest are viewing this topic.

Offline crazyodaz

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): SIX - ATE - SE7EN
Video Tearing while SLI fishing on SKYLAKE
« on: September 13, 2017, 01:10:20 am »
Quote
I was thinking more of just disabling hyperthreading temporarily as a test (VMWARE will still work), if it eliminates the freezes we can look into the microcode update that fixes the hyperthreading issue.

[EDIT]

Looking at your pic, you might also want to look into (or start a topic about) solutions for that screen tearing in the video.

LOL, thanx to PCNetSpec,  Yes I've noticed this before, but in actuality it is worse via screenshot than it is while watching live the last picture will really jump out,  and of course, now that somebody actually pointed this out to me, i can off and on now start to notice this video tearing , it has to be something im doing wrong, either in bios or in the setup, the above picture is with PEPPERMINT 8 but of course being a memory hungry person, the rest of the pictures are Peppermint 6 and SIX is also my current setup if somebody has any ideas or solutions to play with

so long story short, because of a SANDYBRIDGE blowup, I ended up getting a SKYLAKE replacement just before xmas time last year,  I've been all over the place distro-hopping trying to get the best performance for both KODI and VMWARE, so needless to say, I always end up back here in peppermint land, cause it really is so much easier out of the box to get this tripple monitor setup going.  SKYLAKE 6700k / two EVGA GTX 970 (SLI) one is the SC (SUPER CLOCK) and the other just normal EVGA they are both 970's maybe one day when i build up courage i can research a nvidia firmware mod to bring them both into (SUPER CLOCK) wich really aint that much different.

The three BenQ GL2460  monitors are all on one card -- first sli setup, but dual boot windows wich wants them all on one card fro SLI --- one card gets now to 60+ wile the other hovers in the 30's -- so I am thinking of putting them back the way i had them still with the sli cable but broken up -- the LEFT monitor is named SPLITTER -- actually hooks up to one splitter, then to another , basically giving both Living-Room and Bedroom the LEFT monitor and sound via HDMI, because of splitting twice my last setup was the LEFT was on one card --  while CENTER and RIGHT was on the other card, this would even out the tempatures more, but again WINDOWS would NOT accept that setup for SLI Cinavision or what not --- so putting things back my original setup might be option, but i think it was tearing then too,

k, sorry for the ramble, just want to give all information and that means sharing the splitter -- setup like this is actually nice for me, can utilize the center and right screens to goof around, while watching kodi or vlc on the left, at same time duplicating / splitting into the bedroom 42" TV aswell as 55"Livingroom TV  ----

***TROUBLESHOOT NOTE -- the last two pictures i bring the video to center screen, so as to take the SPLITTER out , still tears, maybe worse

k, Tried different 4.4 kernels aswell as 3.19 kernel im on now with peppermint 6 -- there is a HAUPPAGE 2250 TV TUNER card that shows up in the DMESG | GREP FAIL  command in pictures as the phillips semiconductors SAA7154 -- , its there but have not installed that driver yet , supposed to be easier with the 3.19 kernel i just installed , dont think that would cause my issue

also notice a i915 intel audio messup, but im not even using the HDMI / intel audio, got that in bios to not use ,  so confused why thats even showing up, even the intel thunderboldt is fully disabled in bios,

im just at my wits end , gotta be something silly or stupid that im missing , being new to BOTH - Linux and SLI setups , I know and have read that Linux really dont like Nvidia SLI setups , prolly why i notice duriing some distro-hopping that it just be royal pain in the gutter to get these three monitors working  --- if ya got any ideas , let me know, Ill check back from time to time and update this soon as i can

here be the rest of info --- first two, on left side monitor with bunch stuff loaded to basically see my free ram --  the last two on the center monitor wich is NOT SPLITTED anywhere --  thanx again

Quote




center monitor / full screen mode sample


after previous picture -- if curious what desktop is on tripple monitor, wish it blended better, but it is what it is, not allot of tripple monitor wolves , its all good


lets just hope AMD still stays back in the game , we need these prices to come down, the price i paid last X-mas for replacing a SANDYBRIDGE 2600k and Nvidia 550 FERMI was ridiculas,  one would think video tearing would be obsolete with couple GTX 970's , but i guess I'm the exception to the rule -- lol -- thanx in advance

******* EDIT NOTE -- adding some dpkg greps here -- before im asked -- wow, some old stuff in there, prolly cause its peppermint six
Code: [Select]
default@silver ~ $ inxi -Gxxxz
Graphics:  Card-1: NVIDIA GM204 [GeForce GTX 970] bus-ID: 01:00.0 chip-ID: 10de:13c2
           Card-2: NVIDIA GM204 [GeForce GTX 970] bus-ID: 02:00.0 chip-ID: 10de:13c2
           X.Org: 1.16.0 driver: nvidia Resolution: 1920x1080@60.0hz, 1920x1080@60.0hz, 1920x1080@60.0hz
           GLX Renderer: GeForce GTX 970/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 384.69 Direct Rendering: Yes
why do i confuse myself so? -- why is 384.69 not listed below? -- its listed above, maybe dpkg only lists non-beta drivers -- either case 375.66 was tried in P8 and P6 before i jumped to 384's
Code: [Select]
default@silver ~ $ dpkg -l | grep nvidia
rc  nvidia-304                                  304.135-0ubuntu0.14.04.1                                    amd64        NVIDIA legacy binary driver - version 304.135
rc  nvidia-375                                  375.66-0ubuntu0.14.04.1                                     amd64        NVIDIA binary driver - version 375.66
rc  nvidia-opencl-icd-304                       304.135-0ubuntu0.14.04.1                                    amd64        NVIDIA OpenCL ICD
rc  nvidia-opencl-icd-375                       375.66-0ubuntu0.14.04.1                                     amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                0.6.2.1                                                     amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                             346.59-0ubuntu1~ubuntu14.04.1                               amd64        Tool for configuring the NVIDIA graphics driver
default@silver ~ $ dpkg -l | grep cuda
rc  libcuda1-304                                304.135-0ubuntu0.14.04.1                                    amd64        NVIDIA CUDA runtime library
rc  libcuda1-375                                375.66-0ubuntu0.14.04.1                                     amd64        NVIDIA CUDA runtime library
default@silver ~ $ dpkg -l | grep xserver-xorg
rc  xserver-xorg                                1:7.7+1ubuntu8.1                                            amd64        X.Org X server
rc  xserver-xorg-core                           2:1.15.1-0ubuntu2.7                                         amd64        Xorg X server - core server
ii  xserver-xorg-core-lts-utopic                2:1.16.0-1ubuntu1.2~trusty2                                 amd64        Xorg X server - core server
ii  xserver-xorg-input-all-lts-utopic           1:7.7+7ubuntu2~trusty1                                      amd64        X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev-lts-utopic         1:2.9.0-1ubuntu2~trusty1                                    amd64        X.Org X server -- evdev input driver
ii  xserver-xorg-input-mouse-lts-utopic         1:1.9.0-1build2~trusty1                                     amd64        X.Org X server -- mouse input driver
ii  xserver-xorg-input-synaptics-lts-utopic     1.8.1-1ubuntu1~trusty1                                      amd64        Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-vmmouse-lts-utopic       1:13.0.0-1build2~trusty1                                    amd64        X.Org X server -- VMMouse input driver to use with VMWare
ii  xserver-xorg-input-wacom-lts-utopic         1:0.25.0-0ubuntu1~trusty1                                   amd64        X.Org X server -- Wacom input driver
ii  xserver-xorg-lts-utopic                     1:7.7+7ubuntu2~trusty1                                      amd64        X.Org X server
ii  xserver-xorg-video-all-lts-utopic           1:7.7+7ubuntu2~trusty1                                      amd64        X.Org X server -- output driver metapackage
ii  xserver-xorg-video-ati-lts-utopic           1:7.4.0-2ubuntu2~trusty1                                    amd64        X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-cirrus-lts-utopic        1:1.5.2-2build1~trusty1                                     amd64        X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev-lts-utopic         1:0.4.4-1build2~trusty1                                     amd64        X.Org X server -- fbdev display driver
rc  xserver-xorg-video-intel                    2:2.99.910-0ubuntu1.4                                       amd64        X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-intel-lts-utopic         2:2.99.914-1~exp1ubuntu4.5~trusty1                          amd64        X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64-lts-utopic        6.9.4-2~trusty1                                             amd64        X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga-lts-utopic           1:1.6.3-2build1~trusty1                                     amd64        X.Org X server -- MGA display driver
ii  xserver-xorg-video-modesetting-lts-utopic   0.9.0-1build1~trusty1                                       amd64        X.Org X server -- Generic modesetting driver
ii  xserver-xorg-video-neomagic-lts-utopic      1:1.2.8-1build2~trusty1                                     amd64        X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau-lts-utopic       1:1.0.11-1ubuntu2~trusty1                                   amd64        X.Org X server -- Nouveau display driver
rc  xserver-xorg-video-openchrome               1:0.3.3-1build1                                             amd64        X.Org X server -- VIA display driver
ii  xserver-xorg-video-openchrome-lts-utopic    1:0.3.3-1build2~trusty1                                     amd64        X.Org X server -- VIA display driver
ii  xserver-xorg-video-r128-lts-utopic          6.9.2-1build2~trusty1                                       amd64        X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon-lts-utopic        1:7.4.0-2ubuntu2~trusty1                                    amd64        X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-savage-lts-utopic        1:2.3.7-2ubuntu3~trusty1                                    amd64        X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion-lts-utopic 1:1.7.7-2build2~trusty1                                     amd64        X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sisusb-lts-utopic        1:0.9.6-2build2~trusty1                                     amd64        X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx-lts-utopic          1:1.4.5-1build2~trusty1                                     amd64        X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident-lts-utopic       1:1.3.6-0ubuntu6~trusty1                                    amd64        X.Org X server -- Trident display driver
ii  xserver-xorg-video-vesa-lts-utopic          1:2.3.3-1build2~trusty1                                     amd64        X.Org X server -- VESA display driver
rc  xserver-xorg-video-vmware                   1:13.0.2-2ubuntu1                                           amd64        X.Org X server -- VMware display driver
ii  xserver-xorg-video-vmware-lts-utopic        1:13.0.2-3ubuntu1~trusty1                                   amd64        X.Org X server -- VMware display driver
« Last Edit: September 13, 2017, 02:29:02 am by crazyodaz »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Video Tearing while SLI fishing on SKYLAKE
« Reply #1 on: September 13, 2017, 07:20:51 am »
First thing to try (to eliminate screen tearing) would be to see if disabling desktop effects in the Peppermint Control Center makes any difference ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crazyodaz

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): SIX - ATE - SE7EN
Re: Video Tearing while SLI fishing on SKYLAKE
« Reply #2 on: September 13, 2017, 07:49:26 am »
First thing to try (to eliminate screen tearing) would be to see if disabling desktop effects in the Peppermint Control Center makes any difference ?

LOL -- I thought that was the first thing to try if you where memory hungry like me ?  ---  LOL, sorry I shoulda said something about that, Yupperz, was already turned off , no Eye-CANdy, Windows 10 gave me enought of that

the best eye-candy in the world can slow down the biggest supercomputer in the universe , I'll blame it on Ancient Aliens  -- LOL

playing with these NVenc stuff, but I'm prolly just braking it even worse

Quote


Code: [Select]
default@silver ~ $ nvidia-smi
Wed Sep 13 05:24:33 2017       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 384.69                 Driver Version: 384.69                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 970     Off  | 00000000:01:00.0  On |                  N/A |
|  5%   62C    P0    47W / 170W |    490MiB /  4092MiB |      1%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 970     Off  | 00000000:02:00.0 Off |                  N/A |
|  0%   35C    P8    14W / 170W |    490MiB /  4092MiB |      3%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|=============================================================================|
|    0      1467    G   /usr/bin/X                                     359MiB |
|    0      4267    G   guvcview                                         5MiB |
|    0     16383    G   /usr/lib/firefox/firefox                         3MiB |
|    0     17672    G   ...el-token=31CB4B55A46B8260FB3A871CDDCB67CE    99MiB |
|    1      1467    G   /usr/bin/X                                     359MiB |
|    1      4267    G   guvcview                                         5MiB |
|    1     16383    G   /usr/lib/firefox/firefox                         3MiB |
|    1     17672    G   ...el-token=31CB4B55A46B8260FB3A871CDDCB67CE    99MiB |
+-----------------------------------------------------------------------------+

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25661
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Video Tearing while SLI fishing on SKYLAKE
« Reply #3 on: September 13, 2017, 08:40:38 am »
Have you tried what's mentioned in this video
Code: [Select]
https://www.youtube.com/watch?v=Xo2jsZVXxYg

If you're using nvidia 365.20 or newer be sure to see the notes under the video as nVidia have now added a GUI method of applying Force Full Composition Pipeline.

Or see this topic
https://forum.peppermintos.com/index.php/topic,2874
« Last Edit: September 13, 2017, 09:02:55 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crazyodaz

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): SIX - ATE - SE7EN
Re: Video Tearing while SLI fishing on SKYLAKE
« Reply #4 on: September 15, 2017, 06:05:46 am »
Have you tried what's mentioned in this video
Code: [Select]
https://www.youtube.com/watch?v=Xo2jsZVXxYg

If you're using nvidia 365.20 or newer be sure to see the notes under the video as nVidia have now added a GUI method of applying Force Full Composition Pipeline.

Or see this topic
https://forum.peppermintos.com/index.php/topic,2874

NO -- i did not do that -- well I did, but only about 15 mins before your post, so yes i did, but just barely before your post,  no luck --- had another issue with the drivers so i went and installed 375.82 or something

got windows 7 running inside mint 6, will check that out and edit this post with another picture




this one under windows 7 -- VMware, so i dunno, unless linux not passing the right stuff over to vmware,  now i get a Nvidia in the dmesg | grep fail too, think they up there, when the 384.69 drivers flaked on me and installed the 375.82 --- also notice, the drivers section, all options greyed out no matter what, though i am sure i can still disable lightdm and use the nvidia run files if i wanted,  looking like a mess for sure




gotta be something stupid,  something im overlooking, going to try install some driver changes in the vmware section first unless ya got better ideas, im all game ,  the screen tear is hardly noticable when watching live, not as bad as these pictures make it look to be, I'm sure the screenshot just faster than the eye , but under heavy effects, ya can tell she be tearing
« Last Edit: September 15, 2017, 06:10:42 am by crazyodaz »