Choose style:

Author Topic: Cannot get WIFI to work.(SOLVED)  (Read 1196 times)

0 Members and 1 Guest are viewing this topic.

Offline GEMS

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Cannot get WIFI to work.(SOLVED)
« on: August 30, 2017, 04:05:29 pm »
I have a Intel NUC 6CAYH which has a Intel Dual Band wireless AC-3168 (802.11 AC ) wireless module. I can connect via Ethernet but cannot obtain a list of wireless connection points. Very frustrated. I do not know what I am doing wrong.

Spoiler (click here to view / hide)
gems@gems-desktop-lg ~ $ inxi -Fz
System:    Host: gems-desktop-lg Kernel: 4.4.0-93-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   Mobo: Intel model: NUC6CAYB v: J23203-402
           Bios: Intel v: AYAPLCEL.86A.0038.2017.0310.1633 date: 03/10/2017
CPU:       Quad core Intel Celeron J3455 (-MCP-) cache: 1024 KB
           clock speeds: max: 1501 MHz 1: 800 MHz 2: 1501 MHz 3: 900 MHz
           4: 1000 MHz
Graphics:  Card: Intel Device 5a85
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.93hz
           GLX Renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
           GLX Version: 3.0 Mesa 17.0.7
Audio:     Card Intel Device 5a98 driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-93-generic
Network:   Card-1: Intel Device 24fb
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 892.0GB (27.4% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 512.1GB
           ID-2: USB /dev/sdb model: Voyager_SliderX1 size: 256.1GB
           ID-3: USB /dev/sdc model: MKNUFDAM128GB size: 123.8GB
Partition: ID-1: / size: 462G used: 221G (51%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 8.43GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 53.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 180 Uptime: 1:13 Memory: 701.9/7829.1MB
           Client: Shell (bash) inxi: 2.2.35
[close]

PLEASE HELP. Thanks.

GEMS.
« Last Edit: September 09, 2017, 04:49:52 pm by GEMS »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23830
  • Karma: 2635
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Cannot get WIFI to work.
« Reply #1 on: August 30, 2017, 05:17:15 pm »
AFAIK that wireless adapter requires at least the 4.7 kernel to work, try either:-

a) Upgrading to the hwe-16.04 .. which will pull in the 4.10 kernel
connect via an ethernet cable, then run:
Code: [Select]
sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04
then once that's finished .. REBOOT.

or

b) Switch to Peppermint 8 which already has the 4.8 kernel, and will automagically update to the 4.10 kernel.
« Last Edit: September 09, 2017, 07:47:07 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GEMS

  • Jr. Member
  • **
  • Posts: 63
  • Karma: 5
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Cannot get WIFI to work.(SOLVED)
« Reply #2 on: September 09, 2017, 04:55:25 pm »
Sorry for the lateness of the response. I was sick. Thank you VERY MUCH. Your answer solved my problem. If it was not for your genius I would have had to reinstall Peppermint 8 on four machines, You are the best!!! Thanks.

GEMS.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23830
  • Karma: 2635
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Cannot get WIFI to work.(SOLVED)
« Reply #3 on: September 09, 2017, 07:45:24 pm »
You're most welcome GEMS, glad to hear you're feeling better :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec