Choose style:

Author Topic: Peppermint 8 - Making sure you always have the latest flashplayer  (Read 2928 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
To set Peppermint 8 to always have the latest flashplayer...

Go to:-

Menu > Preferences > Software & Updates > Other Software (tab)

Put a tick next to:-

Canonical Partners

and click the "Close" button.

Now open a terminal and run:
Code: [Select]
sudo apt-get update
then:
Code: [Select]
sudo apt-get install adobe-flashplugin adobe-flash-properties-gtk
then:
Code: [Select]
sudo apt-get upgrade
Now close ALL web browser instances.

Now reopen your web browser.
(it is IMPORTANT that you close ALL web browser instances before reopening one)
« Last Edit: December 12, 2017, 04:12:46 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8 - Making sure you always have the latest flashplayer
« Reply #1 on: December 12, 2017, 04:12:02 pm »
Additional info for those now on Chrome/Chromium 62 or higher...

Google in their infinite wisdom have decided to disable the ability in Chrome/Chromium 62+ to allow the user to choose "always allow" for flash content .. now the only options are to "ask first" (default) or "disable" flash content. This has also broken some of our default SSB's and will mean any future SSB's people attempt to create that have flash content won't work properly.

You can see this if you attempt to open the "Editor by Pixlr" or "First-Person Tetris" SSB's

The workaround for this is to first make sure you have adobe-flashplugin installed by following the instructions in the first posting in this topic..

Then in Chromium go to:
chrome://settings/content/flash
and next to "Allow" click the "Add" button, then add 2 entries

http://*

and

https://*

Which will whitelist flash content for all websites .. you should then find that those 2 SSB's I mentioned above now work, and so should flash on other sites in Chrome/Chromium.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Pmint

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Peppermint 8 - Making sure you always have the latest flashplayer
« Reply #2 on: December 18, 2017, 07:00:11 pm »
Re: Go to:-

Menu > Preferences > Software & Updates > Other Software (tab)

Put a tick next to:-

Canonical Partners

and click the "Close" button.

Now open a terminal and run....

Re: Chromium

I did this about a week ago and it worked for a few days - as I left some tabs open to check it, including adobe flash tabs - but it quit working on two laptops; one with Pmint 8, and the other with Pmint 8 Respin.  I used gparted and moved some /, home and other partitions on the laptop with the Respin release - that's one of the reasons that I mentioned that it quit working on two laptops.

EDIT: Reboot, still didn't work, later rebooted both laptops - it now works on both? 
Did nothing other than post this; correlation yes, cause & effect?

FYI, check MINT 18.3 xfce - again Chromium  - settings>content>flash ask first didn't enable flash as it DIDN'T ASK PERIOD,  but "white-listing" it,
specifically by ADDING in ALLOW did enable it.   

ALSO, in Pmint 8, these were enabled or "white-listed" via ALLOW in settings throughout, (continuously before, during, and after),  in both laptops in Pmint.
« Last Edit: December 19, 2017, 02:04:18 pm by Pmint »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8 - Making sure you always have the latest flashplayer
« Reply #3 on: December 19, 2017, 06:29:13 am »
Are you saying flash isn't working in Chromium in Peppermint ?

If so, what's the output from:
Code: [Select]
dpkg -l | grep flash
and
Code: [Select]
dpkg -l | grep fresh
?



And what do you see if you open the First Person Tetris SSB .. does it work, or do you just get a black window ?
Menu > Games > First Person Tetris
« Last Edit: December 19, 2017, 06:31:47 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Pmint

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Peppermint 8 - Making sure you always have the latest flashplayer
« Reply #4 on: December 19, 2017, 02:31:53 pm »
I'm saying:      "it worked for a few days - but [then] it quit working on two laptops...."
and                   "EDIT: Rebooted, still didn't work, later rebooted both laptops - it now works on both? "
To expound:   It initially worked (for a few days), then it quit working (possibly a few days) then worked with no changes whatsoever on my part
                         except this posting - obviously prior to - in context - this exact post, or "paragraph".

Re: "And what do you see if you open the First Person Tetris SSB .. does it work, or do you just get a black window ?
Menu > Games > First Person Tetris" 

A black screen, but that's what I would expect as I did nothing to address that; and that's not what I am addressing.

Apologies, I don't know how to properly post -  I think this is my first post here - and I didn't insert it in the proper location,
it may appear as though I am responding to "Which will whitelist flash content for all websites .. you should then find that those 2 SSB's...." which I am not.

I am referring to:  "Re: Go to:-
Menu > Preferences > Software & Updates > Other Software (tab)
Put a tick next to:-
Canonical Partners
and click the "Close" button.
Now open a terminal and run...." or more specifically: "To set Peppermint 8 to always have the latest flashplayer.."

For further clarification: Flash initially worked after I followed your suggestions, then it quit working, then, later it worked with no change on my part.
It started working shortly after I placed the original post.

pmint@255 ~ $ dpkg -l | grep flash
ii  adobe-flash-properties-gtk                  1:20171212.1-0ubuntu0.16.04.1                               amd64        GTK+ control panel for Adobe Flash Player plugin
ii  adobe-flashplugin                           1:20171212.1-0ubuntu0.16.04.1                               amd64        Adobe Flash Player plugin
ii  browser-plugin-freshplayer-pepperflash      0.3.4-3ubuntu0.1                                            amd64        PPAPI-host NPAPI-plugin adapter for pepperflash
rc  flashplugin-installer                       27.0.0.187ubuntu0.16.04.1                                   amd64        Adobe Flash Player plugin installer
pmint@255 ~ $

pmint@255 ~ $ dpkg -l | grep fresh
ii  browser-plugin-freshplayer-pepperflash      0.3.4-3ubuntu0.1                                            amd64        PPAPI-host NPAPI-plugin adapter for pepperflash
pmint@255 ~ $

Just in case you still want to know what the output is; and sorry for the inconvenience; particularly after it started working so soon thereafter.
« Last Edit: December 19, 2017, 02:37:45 pm by Pmint »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8 - Making sure you always have the latest flashplayer
« Reply #5 on: December 19, 2017, 02:42:16 pm »
You don't have to do this, but there's now no need for browser-plugin-freshplayer-pepperflash and flashplugin-installer so you may as well uninstall them:
Code: [Select]
sudo apt-get remove --purge browser-plugin-freshplayer-pepperflash flashplugin-installer
« Last Edit: December 19, 2017, 09:21:18 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Pmint

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Peppermint 8 - Making sure you always have the latest flashplayer
« Reply #6 on: December 19, 2017, 08:03:04 pm »
PCNetSpec,
I owe you one big apology, truely sorry, it appears as though this was all due me clearing the browser and cookies - forever, and I cleared everything possible - without me whitelisting then by ALLOWing  them in both the cookies and flash  content settings in Chromium; I just ALLOWed them in flash and not cookies.
Them being:  http://get.adobe.com and http://www.macromedia.com.

I still find it curious that the browser won't ask first as it is set to ask first.
And since it doesn't ask first and I didn't ALLOW it the content settings, this site:   https://helpx.adobe.com/flash-player.html
displayed this:  "Flash Player is pre-installed in Google Chrome, but not enabled.
You can skp the steps below. See Enable Flash Player on Google Chrome."
and that/this site:   https://support.google.com/chrome/answer/6258784
displayed:  Always ask to run Flash (recommended)           - as I said, it doesn't ask first or second or....
                    Always allow Flash on trusted sites                    - as you said, in Google's infinite wisdom...
                    Always block Flash

Just FYI for others who may follow you advice regarding deleting the unnecessary flash/installer programs,
the very end of the terminal command is missing an "r".              Yes, I did purge them.

Again, my apologies, I also forgot that I cleared the browsing data and cookies, and I forgot about both the flash and cookie 'ALLOWs'.

First "computer" was a chromebook about 3 years ago, then bought this weak HP-255 for $300 because it already had Ubuntu preinstalled - didn't want to mess w/Windose.
I found Peppermint 5 and 6 to be extremely reliable but always wished for a more xfce like interface so that the volume & brightness keys would just work out of the box, same w/keyboard shortcuts - I wanted the distro to work for me, not  vice-versa.   
The xfce panel and whatever else you added in Pmint 8 is a big user-end improvement - still fast, and I think the trend is towards more cloud based programs.

Re: ICE uses, I often keep "should-be-pocketed" bookmarks open, but https://www.nfl2go.com/Account/Login saves some "tab-memory" on Chromium when I open it as an SSB on this weak laptop.
Again, sorry.
« Last Edit: December 19, 2017, 08:13:08 pm by Pmint »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25930
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8 - Making sure you always have the latest flashplayer
« Reply #7 on: December 19, 2017, 09:18:36 pm »
Quote
I still find it curious that the browser won't ask first as it is set to ask first.

I can only assume this is a Chrome/Chromium bug (and really I should report it) .. ICE is just using a standard Chrome/Chromium feature (--app mode) so if "asking" isn't working properly in --app mode it can only really be viewed as a Chrome/Chromium bug.

Oh, and no need to apologise, we all make mistakes .. I certainly do anyway :)

And I've fixed the command .. thanks for pointing that out :)
« Last Edit: December 19, 2017, 09:23:06 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec