Author Topic: GPG verification issue for Peppermint-8-i386 (Solved)  (Read 1013 times)

Offline Andy

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
GPG verification issue for Peppermint-8-i386 (Solved)
« on: July 28, 2017, 07:34:46 pm »
Hello, I am currently having trouble verifying the ISO image as for some reason I cannot  connect to the GPG key server as stated below. Could anyone please help me? Thanks



Spoiler (click here to view / hide)
[close]
« Last Edit: August 09, 2017, 02:12:54 am by Andy »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: GPG verification issue for Peppermint-8-i386
« Reply #1 on: July 29, 2017, 03:24:42 am »
I take it you have an active internet connection ?

Because I'm not seeing the same issue .. the key just gets downloaded for me :-\

Maybe the keyserver was temporarily offline.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Andy

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
Re: GPG verification issue for Peppermint-8-i386
« Reply #2 on: July 29, 2017, 09:14:10 pm »
I do have an active internet connection, but for some reason I cannot connect to the key server to download the key.  Note that I have tried multiple attempts without success :(.
« Last Edit: July 29, 2017, 09:19:19 pm by Andy »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: GPG verification issue for Peppermint-8-i386
« Reply #3 on: July 30, 2017, 06:46:43 am »
Try getting my public key directly from the sks key pool
Code: [Select]
gpg --keyserver pool.sks-keyservers.net --recv-keys AECF1D2For
Code: [Select]
gpg --keyserver eu.pool.sks-keyservers.net --recv-keys AECF1D2For any of the other key pools listed here:
https://sks-keyservers.net/overview-of-pools.php
« Last Edit: July 30, 2017, 07:04:06 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Andy

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
Re: GPG verification issue for Peppermint-8-i386
« Reply #4 on: July 31, 2017, 03:14:20 am »
I have tried getting the public key directly from the sks key pool, but I am still having the same problem. I have also tried to disable the firewall to run the following bash script without any success. 

Spoiler (click here to view / hide)
[close]

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: GPG verification issue for Peppermint-8-i386
« Reply #5 on: July 31, 2017, 06:05:55 am »
Okay dunno what's going on at your end because the keyservers are working, but here's another method to import my public key:-

Download the AECF1D2F.asc file attached below to this posting, and place it in your home folder.

Now run:
Code: [Select]
gpg --import AECF1D2F.ascand you should see output similar to:
Code: [Select]
gpg: key AECF1D2F: public key "Mark Greaves (PCNetSpec) <mark@pcnetspec.co.uk>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
now continue from:
Code: [Select]
gpg --fingerprint AECF1D2Fhere:
https://peppermintos.com/gpg-verification/
« Last Edit: July 31, 2017, 06:10:51 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec