Choose style:

Author Topic: Very slow WiFi connection (SOLVED)  (Read 2401 times)

0 Members and 1 Guest are viewing this topic.

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Very slow WiFi connection (SOLVED)
« on: July 23, 2017, 10:32:06 am »
Hi, I am new to Peppermint. Everything works fine except for Wi-Fi. It works perfectly great on Windows, so it's not the router's problem. When I connect to Wi-Fi, it works for a little bit and really slow. If  I try to download something, it downloads very slow and sometimes just stops downloading. I have tried doing multiple things:
1) I did run sudo pluma /etc/modprobe.d/rtl8188ee.conf and put options rtl8188ee fwlps=0. It did change the situation slightly, the Internet is still slow.
2) Turning off ipv6 as people on forums advised didn't do any better. I just reversed it back as where it was by default.
3) I did write hosts: files dns which also helped a little. But still, while I am downloading something or just use the Internet, the connection is very slow. I didn't have the same issue with Windows 10 where Internet worked very fast with the same router.
Could you please help me with it?
« Last Edit: July 24, 2017, 06:41:07 pm by alek »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23898
  • Karma: 2645
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very slow WiFi connection
« Reply #1 on: July 23, 2017, 11:39:45 am »
Try either
Code: [Select]
options rtl8188ee ips=0 fwlps=0
or
Code: [Select]
options rtl8188ee ips=0 fwlps=0
or
Code: [Select]
options rtl8188ee ips=0 swlps fwlps=0
or
Code: [Select]
options rtl8188ee swenc=1 fwlps=0
rebooting between each time before testing.

If none of those work, please post the output from:
Code: [Select]
inxi -Fz
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Very slow WiFi connection
« Reply #2 on: July 23, 2017, 02:45:25 pm »
I tried your suggestions but everytime I do it, it says <options: command not found. So I just put the data of inxi -Fz as you said.
Here is what it says:
Code: [Select]
System:    Host: aleksandr-Lenovo-V580c Kernel: 4.10.0-27-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Eight
Machine:   System: LENOVO (portable) product: 20160 v: Lenovo V580c
           Mobo: LENOVO model: 20160 v: WIN8 STD SGL/FRU WIN8 STD
           Bios: LENOVO v: H1ET63WW (1.06 ) date: 09/04/2012
CPU:       Dual core Intel Core i5-3210M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 3100 MHz 1: 1199 MHz 2: 1199 MHz 3: 1199 MHz
           4: 1199 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF119M [GeForce 610M]
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 17.0.2
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.10.0-27-generic
Network:   Card-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge
           IF: wlp3s0b1 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.6% used)
           ID-1: /dev/sda model: WDC_WD5000BPVT size: 500.1GB
Partition: ID-1: / size: 455G used: 8.5G (2%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 4.04GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 46.0C mobo: 35.0C gpu: 33.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 199 Uptime: 8 min Memory: 543.4/3707.8MB
           Client: Shell (bash) inxi: 2.2.35

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23898
  • Karma: 2645
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very slow WiFi connection
« Reply #3 on: July 23, 2017, 03:55:21 pm »
Okay then .. those instructions were pretty useless because you bon't have a Realtek card so aren't using the rtl8188ee driver.

You have a Broadcom card .. can you post the output from:
Code: [Select]
lspci -vnn | grep -i net
so I can figure out the best driver for your model.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Very slow WiFi connection
« Reply #4 on: July 23, 2017, 04:02:54 pm »
Here is what it says:
Code: [Select]
03:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
Subsystem: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:0608]
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 07)
Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [17aa:5002]

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23898
  • Karma: 2645
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very slow WiFi connection
« Reply #5 on: July 23, 2017, 04:09:15 pm »
Okay, as you're using Peppermint 8 (the instructions would be slightly different for Peppermint 7) connect to your router with an ethernet cable .. then open a terminal and run:
Code: [Select]
sudo apt-get install build-essential linux-headers-generic-hwe-16.04 dkms bcmwl-kernel-source
Once that's finished .. REBOOT.

Once rebooted, post the output from:
Code: [Select]
lshw -C network
« Last Edit: July 23, 2017, 04:31:15 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Very slow WiFi connection
« Reply #6 on: July 23, 2017, 04:24:28 pm »
Code: [Select]
WARNING: you should run this program as super-user.
  *-network               
       description: Wireless interface
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 01
       serial: c0:14:3d:da:a0:43
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=192.168.1.50 latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:17 memory:eb500000-eb503fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: enp4s0
       version: 07
       serial: 3c:97:0e:34:e5:c4
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:26 ioport:2000(size=256) memory:eb404000-eb404fff memory:eb400000-eb403fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Very slow WiFi connection
« Reply #7 on: July 23, 2017, 04:25:20 pm »
This one as a super-user
Code: [Select]
  *-network               
       description: Wireless interface
       product: BCM4313 802.11bgn Wireless Network Adapter
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 01
       serial: c0:14:3d:da:a0:43
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) ip=192.168.1.50 latency=0 multicast=yes wireless=IEEE 802.11
       resources: irq:17 memory:eb500000-eb503fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: enp4s0
       version: 07
       serial: 3c:97:0e:34:e5:c4
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:26 ioport:2000(size=256) memory:eb404000-eb404fff memory:eb400000-eb403fff

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23898
  • Karma: 2645
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very slow WiFi connection
« Reply #8 on: July 23, 2017, 04:27:23 pm »
Is wireless working ?

If so, can you post the output from:
Code: [Select]
dpkg -l | grep linux-headers
because I made a mistake in an earlier command .. it won't have hurt anything, it just means we need to clean up some packages.

I've fixed the command above (for anyone else reading this) .. but I just want to check whether you installed some unnecessary packages
« Last Edit: July 23, 2017, 04:29:24 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Very slow WiFi connection
« Reply #9 on: July 23, 2017, 04:38:14 pm »
Wi-Fi is working. Here we go:
Code: [Select]
ii  linux-headers-4.10.0-27                     4.10.0-27.30~16.04.2                            all          Header files related to Linux kernel version 4.10.0
ii  linux-headers-4.10.0-27-generic             4.10.0-27.30~16.04.2                            amd64        Linux kernel headers for version 4.10.0 on 64 bit x86 SMP
ii  linux-headers-4.4.0-83                      4.4.0-83.106                                    all          Header files related to Linux kernel version 4.4.0
ii  linux-headers-4.4.0-83-generic              4.4.0-83.106                                    amd64        Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii  linux-headers-4.8.0-53                      4.8.0-53.56~16.04.1                             all          Header files related to Linux kernel version 4.8.0
ii  linux-headers-4.8.0-53-generic              4.8.0-53.56~16.04.1                             amd64        Linux kernel headers for version 4.8.0 on 64 bit x86 SMP
ii  linux-headers-4.8.0-58                      4.8.0-58.63~16.04.1                             all          Header files related to Linux kernel version 4.8.0
ii  linux-headers-4.8.0-58-generic              4.8.0-58.63~16.04.1                             amd64        Linux kernel headers for version 4.8.0 on 64 bit x86 SMP
ii  linux-headers-generic                       4.4.0.83.89                                     amd64        Generic Linux kernel headers
ii  linux-headers-generic-hwe-16.04             4.10.0.27.30                                    amd64        Generic Linux kernel headers

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23898
  • Karma: 2645
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very slow WiFi connection
« Reply #10 on: July 23, 2017, 04:45:34 pm »
Okay run:
Code: [Select]
sudo apt-get remove --purge linux-headers-generic linux-headers-4.4.0-83-generic linux-headers-4.4.0-83
to clean up.

Now we have 2 options here...

a) leave the wl driver installed (as you're using now) .. the downside of this is wireless MAY break when you get a kernel update
or
b) uninstall wl, then try the sta-dkms drivers .. which should auto-recompile when you get a kernel update.

Shall we try (b) ? .. then if it doesn't work, go back to (a) ?
« Last Edit: July 23, 2017, 04:47:50 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Very slow WiFi connection
« Reply #11 on: July 23, 2017, 04:48:30 pm »
If b is safe to do, let's do it. I guess there are not many options anyways... So what should I type?
« Last Edit: July 23, 2017, 04:54:59 pm by alek »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23898
  • Karma: 2645
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very slow WiFi connection
« Reply #12 on: July 23, 2017, 04:57:19 pm »
Okay, connect to your router with an ethernet cable and run:
Code: [Select]
sudo apt-get remove --purge bcmwl-kernel-source
then
Code: [Select]
sudo apt-get  install broadcom-sta-dkms
then REBOOT

Once rebooted, post the output from:
Code: [Select]
lshw -C network
again.

And let me know if wireless is working ?



If (and ONLY if) for some reason wireless doesn't work after doing the above, reconnect with an ethernet cable and run:
Code: [Select]
sudo apt-get remove --purge broadcom-sta-dkms
then
Code: [Select]
sudo apt-get install bcmwl-kernel-source
and REBOOT .. and you'll be back to where you are now
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline alek

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Very slow WiFi connection
« Reply #13 on: July 23, 2017, 05:12:55 pm »
I tried doing that but something went wrong (no wifi was showing, took 20 mins to turn off laptop). I will do the same tomorrow morning hoping for the best and show the output

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 23898
  • Karma: 2645
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Very slow WiFi connection
« Reply #14 on: July 23, 2017, 05:15:02 pm »
Okay :)

Is wireless working again now ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec