Choose style:

Author Topic: No keyboard volume control with certain browsers  (Read 447 times)

0 Members and 1 Guest are viewing this topic.

Offline arky217

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
No keyboard volume control with certain browsers
« on: June 29, 2017, 05:51:18 pm »
I had been using the Vivaldi browser with Peppermint 8 for some time,
but recently started using Firefox. I discovered that when I play any
video with Firefox, I lose the ability to control the volume with the
keyboard volume up/down keys. Even if I then close firefox, I still
have no keyboard volume control. The panel volume control via the
mouse still works. To get the keyboard volume control back, I have
to logoff/logon or reboot.

Now I have Linux Mint 18.1 xfce also on this same machine, so I thought I
would do some tests.

With Peppermint 8, I have 4 browsers installed, Firefox, Chromium,
Vivaldi, and Opera. I lose the keyboard volume control with Firefox
and Chromium but not with Vivaldi and Opera.

With Linux Mint, I have 5 browsers installed, Firefox, Chromium,
Chrome, Vivaldi, and Slimjet. I do not lose the keyboard volume
control with any of them.

Anyone have a clue why this would be ?

( By the way, the browser versions are the same on both distros )
« Last Edit: July 04, 2017, 07:05:56 pm by arky217 »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17341
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: No keyboard volume control with certain browsers
« Reply #1 on: June 30, 2017, 02:06:49 pm »
What are your keyboard volume keys ? .. separate keys, or something like

Volume Up = Fn+F8
Volume Down = Fn+F7
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline arky217

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: No keyboard volume control with certain browsers
« Reply #2 on: June 30, 2017, 09:17:51 pm »
It is a wireless Insignia keyboard, model ns-pnc6011 and the volume keys are separate keys above the function keys.

Offline arky217

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: No keyboard volume control with certain browsers
« Reply #3 on: July 01, 2017, 10:34:16 am »
Weird; after several days of having this problem, it seems to have 'fixed' itself !

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17341
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: No keyboard volume control with certain browsers [SOLVED, 'I think']
« Reply #4 on: July 01, 2017, 10:39:41 am »
Ya gotta love it when that happens  :-\ :D
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec


Offline arky217

  • Jr. Member
  • **
  • Posts: 56
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: No keyboard volume control with certain browsers [SOLVED]
« Reply #5 on: July 04, 2017, 06:38:15 pm »
Well, I spoke too soon about this problem being solved,
but now it is solved; It seems I've found what was causing the problem.

Evidently Flash takes over the up/down keyboard volume controls.
I went into Firefox Preferences/Applications and the two items marked
Shockwave Flash file, I changed to use the VLC media player.
That seems to have did the trick.

It also works ok now on Chromium, but I didn't change anything on Chromium ? Don't know why.


Sorry, thought it was solved, but the problem still exists. (may be getting closer though)
Just starting either Firefox or Chromium will turn off system sounds.
Starting Vivaldi or Chromium, however, doesn't turn system sounds off.
That's all I know now for sure.
Back to the drawing board.

By turning off system sounds, I mean that after a reboot, when I
click on the sound icon, it brings up the PulseAudio window,
however, if I then start either Firefox or Chromium, and then
click on the sound icon, it can't establish a connection to PulseAudio.

The reason that I thought it was solved was that if I'm playing a mp3
in VLC and start Firefox, there's no problem until I stop VLC, then once
again I can't establish a connection to PulseAudio until I reboot.

Thinking about going back to the Vivaldi Browser.
Neither it nor Opera has this effect.
« Last Edit: July 04, 2017, 07:18:09 pm by arky217 »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17341
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: No keyboard volume control with certain browsers
« Reply #6 on: July 05, 2017, 11:53:59 am »
Sounds more like a pulseaudio problem to me .. have you tried deleting your pulseaudio profile ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline bench

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: No keyboard volume control with certain browsers
« Reply #7 on: August 10, 2017, 08:36:55 pm »
I have the same problem when use Firefox for fullscreen video.
After I close fullscreen it works again.

Offline bench

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: No keyboard volume control with certain browsers
« Reply #8 on: August 11, 2017, 08:00:10 am »
Today volume control worked in Firefox fullscreen. :)

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17341
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: No keyboard volume control with certain browsers
« Reply #9 on: August 12, 2017, 03:08:26 pm »
Great news .. wonder what keeps causing this for some people :-\
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec


Offline bench

  • nOOb
  • *
  • Posts: 7
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: No keyboard volume control with certain browsers
« Reply #10 on: August 13, 2017, 01:33:28 pm »
In my case it was that the volume symbol is not shown when you have already full sound volume and press the louder button.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17341
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: No keyboard volume control with certain browsers
« Reply #11 on: August 13, 2017, 01:49:22 pm »
Yeah I think that's standard behaviour .. I don't get the notification either if it's already maxed out.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Enerathine

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
    • 10 best cam girls on whoagirls
  • Peppermint version(s): Peppermint-7
Re: No keyboard volume control with certain browsers
« Reply #12 on: August 24, 2017, 03:31:37 pm »
I had this problem on Peppermint 7 using Firefox for a period of time as well. I'm sure it has to be some type of Firefox weird issue with Peppermint.