Choose style:

Author Topic: Fully Disabling Touchpad Tap-To-Click (Reboot Persistent)  (Read 2032 times)

0 Members and 1 Guest are viewing this topic.

Offline calinb

  • nOOb
  • *
  • Posts: 8
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Fully Disabling Touchpad Tap-To-Click (Reboot Persistent)
« on: June 25, 2017, 03:13:18 pm »
I recently performed my first Peppermint installation ("Peppermint-8"), and discovered that touchpad Tap-To-Click must be fully disabled to preclude unwanted Two-Finger-Scrolling behaviors (like menu pop-ups). I first attempted to disable it by un-checking the "Tap-To-Click" button in the GUI provided at "Peppermint Settings Panel" >> "Peppermint Control Center" >> "Keyboard & Pointer," but I was still having problems when scrolling past links in my browser, because the right click menu kept popping-up over embedding links.

Running "synclient" from a terminal revealed that the GUI did not reset all tap buttons to 0, thus fully disabling Tap-To-Click as desired. I think the Peppermint Control Center GUI should correctly disable all three TapButton modes and hopefully its behavior will be changed with an update to the distro. This post shows how I corrected my touchpad configuration in the meantime.

Here are the TapButton settings after disabling Tap-To-Click in Peppermint Control Panel:
Code: [Select]
$ synclient | grep Tap
    MaxTapTime              = 180
    MaxTapMove              = 40
    MaxDoubleTapTime        = 100
    SingleTapTimeout        = 180
    TapButton1              = 0
    TapButton2              = 3
    TapButton3              = 0
    TapAndDragGesture       = 1

Many other forum users appear to be having this same problem (or similar problems) and attempted to persistently change the touchpad settings using the synclient command line utility. This typically means getting synclient to run automatically at logon. A much easier and simpler solution lies in the the Xorg configuration files and I believe they are the best place to solve this problem.

First, here's some information directly from the Debian "well":
https://wiki.debian.org/SynapticsTouchpad#Override_options_in_.2Fetc.2FX11.2Fxorg.conf.d.2Fsynaptics.conf

As explained above, editing /usr/share/X11/xorg.conf.d would work to change the touchpad settings, but the changes could be over-written by system updates. Another alternative cited is to put all settings in a combined /etc/X11/xorg.conf file but, in my experience it must be a fully COMBINED file, else the /usr/share/X11/xorg.conf.d/50-synaptics.conf file that ships with Peppermint (and can be updated by Peppermint) has priority and will override the desired settings changes.

First I created a /etc/X11/xorg.conf.d subdirectory:
Code: [Select]
$ sudo mkdir /etc/X11/xorg.conf.d

and then copied the default configuration file into it with a new filename:
Code: [Select]
$ sudo cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/synaptics.conf

Finally, I edited the copied file to reset all three TapButtons:
Code: [Select]
$ sudo xed /etc/X11/xorg.conf.d/synaptics.conf

My /etc/X11/xorg.conf.d/synaptics.conf file contains only the following lines:
Code: [Select]
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
Option "TapButton1" "0"
Option "TapButton2" "0"
Option "TapButton3" "0"
EndSection

A reboot of my computer made it so! Now all three TapButtons are disabled:
Code: [Select]
 $ synclient | grep Tap
    MaxTapTime              = 180
    MaxTapMove              = 40
    MaxDoubleTapTime        = 100
    SingleTapTimeout        = 180
    TapButton1              = 0
    TapButton2              = 0
    TapButton3              = 0
    TapAndDragGesture       = 1

Edit (BTW): If you mess up when editing your /etc/X11/xorg.conf.d/synaptics.conf file, X might not start and you might be staring at a black screen after reboot. In that case, hit <ctl><alt>F6 to get a terminal. Logon with your username and password and type:
Code: [Select]
sudo rm /etc/X11/xorg.conf.d/synaptics.conf
sudo reboot

and try the copy and edit of your synaptics.conf file again (or you could do the copy and edit procedure right from the terminal before rebooting or trying to start X).



« Last Edit: June 27, 2017, 12:02:47 am by calinb »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2808
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Fully Disabling Touchpad Tap-To-Click (Reboot Persistent)
« Reply #1 on: June 27, 2017, 07:57:36 pm »
Testing a tweaked version of peppermint-control-center now, so hopefully this manual workaround won't be necessary for long ;)

Thanks for the heads up calinb .. it certainly helped to isolate the problem :)
« Last Edit: June 27, 2017, 07:59:14 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2808
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Fully Disabling Touchpad Tap-To-Click (Reboot Persistent)
« Reply #2 on: June 29, 2017, 04:58:16 pm »
FIX RELEASED

peppermint-control-center (0.3.2)

Which now enables/disables both TapButtons.
(single finger and double finger tap-to-click)
« Last Edit: June 29, 2017, 05:51:00 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline cavy

  • Trusted User
  • Member
  • *****
  • Posts: 420
  • Karma: 55
  • Caveman
    • View Profile
    • PeppermentOS Pixies
  • Peppermint version(s): Peppermint Eight
Re: Fully Disabling Touchpad Tap-To-Click (Reboot Persistent)
« Reply #3 on: June 29, 2017, 08:32:56 pm »
It be lost on me. Sport. I'm defo..Old School...Go...With...What....Works.

Got used to using the right and left tap function keys with the touchpad, no longer think about it.

Nicely spotted and solved m8, Ditto with PCNetSpec enthusiasm. But Grandpa, (that be me) wont be be using, Too set in me ways.

“We know what we are, but not what we may be.”

Desktop Dell 7040 i7-6700 500Gb-SSD 32Gb ram
Laptop    Dell 7470 i5-6300 500Gb-SSD  16Gb ram
Various antiques to sample other OS's etc

Offline calinb

  • nOOb
  • *
  • Posts: 8
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: Fully Disabling Touchpad Tap-To-Click (Reboot Persistent)
« Reply #4 on: July 05, 2017, 02:36:22 am »
It be lost on me. Sport. I'm defo..Old School...Go...With...What....Works.

Got used to using the right and left tap function keys with the touchpad, no longer think about it.

Nicely spotted and solved m8, Ditto with PCNetSpec enthusiasm. But Grandpa, (that be me) wont be be using, Too set in me ways.
Yup--I'm pretty set in my ways too, cavy. Every time I scrolled, windows kept popping up all over the place!

Glad to see you put a sweet and GUI fix in place, PCNetSpec!

-Cal

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2808
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Fully Disabling Touchpad Tap-To-Click (Reboot Persistent)
« Reply #5 on: July 05, 2017, 08:23:39 am »
Cheers Cal .. You described the problem perfectly, so fixing it was a pleasure .. TVM ;)
« Last Edit: July 05, 2017, 08:27:14 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec