Choose style:

Author Topic: PulseAudio config files getting corrupted  (Read 637 times)

0 Members and 1 Guest are viewing this topic.

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
PulseAudio config files getting corrupted
« on: June 23, 2017, 11:22:51 am »
Hi,

Another sound issue here, which I only recently noticed because I have not been listening to local videos or MP3 files (that all are OK) but have only been listening to youtube videos and music in Firefox (which has no problems).

I have solved this problem temporarily using this post's methods, but after a short period the issue returns: in VLC the message is

Code: [Select]
Audio output failed:
The audio device "default" could not be used:
Connection refused

And when trying to start alsamixer:

Code: [Select]
$ alsamixer
shm_open() failed: No such file or directory
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Protocol error

cannot open mixer: Connection refused

Any ideas why the config files for PulseAudio keep getting corrupted? Any ideas how to correct this other than by using the methods listed in the linked post?  :-\

Also for infomation that might help:

Code: [Select]
$ inxi -Fz
System:    Host: x10 Kernel: 4.8.0-56-generic x86_64 (64 bit) Desktop: N/A
           Distro: Peppermint Eight
Machine:   Mobo: Acer model: BA50_HB v: V1.09
           Bios: Insyde v: V1.09 date: 07/11/2014
CPU:       Dual core Intel Core i3-4030U (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 1900 MHz 1: 1572 MHz 2: 1413 MHz 3: 1546 MHz
           4: 980 MHz
Graphics:  Card: Intel Haswell-ULT Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Haswell Mobile
           GLX Version: 3.0 Mesa 17.0.2
Audio:     Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel
           Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-56-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp1s0f1 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (4.1% used)
           ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB
Partition: ID-1: / size: 30G used: 5.4G (20%) fs: ext4 dev: /dev/sda8
           ID-2: swap-1 size: 4.22GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 51.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 180 Uptime: 25 min Memory: 896.6/3878.3MB
           Client: Shell (bash) inxi: 2.2.35

Regards,

-- Slim
« Last Edit: June 23, 2017, 11:24:39 am by Slim.Fatz »
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: PulseAudio config files getting corrupted
« Reply #1 on: June 23, 2017, 11:27:49 am »
Maybe it'd be easier to just remove pulseaudio ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: PulseAudio config files getting corrupted
« Reply #2 on: June 23, 2017, 11:29:57 am »
Or maybe tell VLC to use ALSA instead of pulseaudio

VLC > Preferences > Audio > Output Modules > ALSA > Audio output device
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: PulseAudio config files getting corrupted
« Reply #3 on: June 23, 2017, 05:39:28 pm »
Thanks for the reply, PCNetSpec!

I have rebooted again and everything is working fine for now. I will wait a few days, playing local and web files, and rebooting -- and if the problem occurs  again, then I will try your second tip first. Then -- if necessary -- the first tip. If things remain good, however, then I will get back here and close this thread (perhaps attributing the problem to gremlins in this laptop  ;D ).

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: PulseAudio config files getting corrupted
« Reply #4 on: June 24, 2017, 09:37:11 am »
Okey dokey .. I'll cross my finger for ya :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec